Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 479820 - app-admin/chrpath-0.13-r2: compile fails on G/FBSD, CC=clang
Summary: app-admin/chrpath-0.13-r2: compile fails on G/FBSD, CC=clang
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: FreeBSD (show other bugs)
Hardware: All FreeBSD
: Normal normal with 1 vote (vote)
Assignee: Gentoo/BSD Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: freebsd-clang-3.1
  Show dependency tree
 
Reported: 2013-08-05 10:56 UTC by Yuta SATOH
Modified: 2019-03-22 07:19 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
files/chrpath-0.13-fbsd-clang.patch (chrpath-0.13-fbsd-clang.patch,312 bytes, patch)
2013-08-05 11:04 UTC, Yuta SATOH
Details | Diff
sample patch for chrpath-0.13-r2.ebuild (479820.patch,497 bytes, patch)
2013-08-05 11:05 UTC, Yuta SATOH
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yuta SATOH 2013-08-05 10:56:11 UTC
The following message is displayed and fails to compile.


Configure status:
-----------------
 CC     = clang
 CFLAGS = -O2 -pipe -mtune=generic -ansi -pedantic -W -Wall -Wcast-align -Wcast-qual -Wcomments -Wmissing-declarations -Wmissing-prototypes -Wpointer-arith -Wreturn-type -Wstrict-prototypes
 LDRPATH= -R

>>> Source configured.
>>> Compiling source in /var/tmp/portage/app-admin/chrpath-0.13-r2/work/chrpath-0.13 ...
gmake -j1
gmake  all-recursive
gmake[1]: Entering directory `/var/tmp/portage/app-admin/chrpath-0.13-r2/work/chrpath-0.13'
Making all in testsuite
gmake[2]: Entering directory `/var/tmp/portage/app-admin/chrpath-0.13-r2/work/chrpath-0.13/testsuite'
clang -R /usr/local/lib -o prog prog.c
clang: warning: argument unused during compilation: '-R'
/usr/local/lib: file not recognized: File format not recognized
clang: error: linker command failed with exit code 1 (use -v to see invocation)
gmake[2]: *** [prog] Error 1
gmake[2]: Leaving directory `/var/tmp/portage/app-admin/chrpath-0.13-r2/work/chrpath-0.13/testsuite'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/var/tmp/portage/app-admin/chrpath-0.13-r2/work/chrpath-0.13'
gmake: *** [all] Error 2
emake failed
 * ERROR: app-admin/chrpath-0.13-r2 failed (compile phase):
 *   emake failed



Reproducible: Always

Steps to Reproduce:
1. CC=clang emerge app-admin/chrpath
2.
3.
Comment 1 Yuta SATOH 2013-08-05 11:04:43 UTC
Created attachment 355160 [details, diff]
files/chrpath-0.13-fbsd-clang.patch
Comment 2 Yuta SATOH 2013-08-05 11:05:19 UTC
Created attachment 355162 [details, diff]
sample patch for chrpath-0.13-r2.ebuild
Comment 3 François Bissey 2013-08-08 10:06:31 UTC
I have exactly the same problem on macos. And I also basically add "-Wl,-rpath" in the darwin section. However in my case chrpath should be completely masked because chrpath relies elf.h which is not there since the format is mach-o for me.
Comment 4 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2019-03-22 07:19:16 UTC
Obsoleting bugs for ancient clang versions.