Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 479752 - =app-office/libreoffice-bin-4.0.4.2 should be rebuilt against libjpeg.so.62 (like from >=media-libs/libjpeg-turbo-1.3.0-r2)
Summary: =app-office/libreoffice-bin-4.0.4.2 should be rebuilt against libjpeg.so.62 (...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Andreas K. Hüttel
URL:
Whiteboard:
Keywords:
: 480876 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-08-04 21:05 UTC by Dennis Schridde
Modified: 2014-03-10 10:17 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Schridde 2013-08-04 21:05:19 UTC
app-office/libreoffice-bin-4.0.4.2 needs media-libs/libjpeg-turbo-1.3.0, because the newer -r2 version installs SOVERSION 62, but libreoffice was linked against ABI version 8. For details on the ABI change please see libjpeg-turbo's ChangeLog.

Currently I have a preserved /usr/lib64/libjpeg.so.8 on my system, which cannot be removed, because app-office/libreoffice-bin-4.0.4.2 still depends on it.
Comment 1 Samuli Suominen gentoo-dev 2013-08-04 21:15:26 UTC
I believe libreoffice-bin binary package is created by the Gentoo maintainers, so this bug should be taken as a request for rolling a new package.

Maintainers: There is no more .so.8, current ~arch is either .so.62 or .so.9. You should compile the package against libjpeg-turbo-1.3.0-r2, and depend on virtual/jpeg:62 to ensure libjpeg.so.62 is installed.
Comment 2 Andreas K. Hüttel gentoo-dev 2013-08-05 00:53:03 UTC
(In reply to Samuli Suominen from comment #1)
> I believe libreoffice-bin binary package is created by the Gentoo
> maintainers, so this bug should be taken as a request for rolling a new
> package.
> 
> Maintainers: There is no more .so.8, current ~arch is either .so.62 or
> .so.9. You should compile the package against libjpeg-turbo-1.3.0-r2, and
> depend on virtual/jpeg:62 to ensure libjpeg.so.62 is installed.

If this change only occured in ~arch, then this bug is a WONTFIX.

libreoffice-bin is built against the current stable set; re-rolling the binary whenever a soversion in ~arch changes is not feasible.

You get bonus points if you tell me how to translate the jpeg virtual into some condition with fixed soversion for the dependencies.
Comment 3 Samuli Suominen gentoo-dev 2013-08-05 05:59:18 UTC
|| ( <media-libs/libjpeg-turbo-1.3.0-r2 =media-libs/jpeg-8* )

or

=virtual/jpeg-0:0

which would...

a) cause unresolvable dependencies because jpeg-9 and libjpeg-turbo-1.3.0-r2 are the ones with abi_x86_32 support

b) caused by a) massive downgrade of packages because of emul- blockers, which is much more than only jpeg

WONTFIX means libreoffice-bin is not installable on ~arch at all, but OK by me
Comment 4 Andreas K. Hüttel gentoo-dev 2013-08-05 07:32:51 UTC
(In reply to Samuli Suominen from comment #3)
> || ( <media-libs/libjpeg-turbo-1.3.0-r2 =media-libs/jpeg-8* )
> 
> or
> 
> =virtual/jpeg-0:0
> 
> which would...
> 
> a) cause unresolvable dependencies because jpeg-9 and libjpeg-turbo-1.3.0-r2
> are the ones with abi_x86_32 support
> 
> b) caused by a) massive downgrade of packages because of emul- blockers,
> which is much more than only jpeg
> 
> WONTFIX means libreoffice-bin is not installable on ~arch at all, but OK by
> me

That is already the case anyway (e.g. poppler soversion, and many others). I've added the explicit version as above.
Comment 5 Denys Duchier 2013-08-05 15:59:37 UTC
(In reply to Samuli Suominen from comment #3)
> WONTFIX means libreoffice-bin is not installable on ~arch at all, but OK by
> me

I am now in this situation... very uncool :-)  I need ~arch, I need libreoffice, and my machine is not capable of compiling that beast.  what to do?
Comment 6 Andreas K. Hüttel gentoo-dev 2013-08-05 16:10:02 UTC
Look at the libreoffice-bin ebuild, it has a block COMMON_BIN_DEPEND=... I've pasted it below but it may grow in the future. This is the difference in dependencies between binary and source libreoffice. 

Use /etc/portage/package.mask and mask from these packages all newer versions... and remember to update that mask when a newer libreoffice-bin comes out.


        =app-text/libexttextcat-3.4*
        app-text/poppler:0/35
        dev-libs/icu:0/51.1
        =media-gfx/graphite2-1.2*
        =media-libs/libpng-1.5*
        >=sys-libs/glibc-2.15-r3
        kde? ( >=kde-base/kdelibs-4.10.4:4 >=dev-qt/qtcore-4.8.4-r5:4 )
        || ( <media-libs/libjpeg-turbo-1.3.0-r2 =media-libs/jpeg-8* )
Comment 7 Andreas K. Hüttel gentoo-dev 2013-08-05 16:11:22 UTC
(In reply to Andreas K. Hüttel from comment #6)
> Use /etc/portage/package.mask and mask from these packages all newer
> versions... and remember to update that mask when a newer libreoffice-bin
> comes out.

All *other* versions I mean... of course you can have e.g. newer kde.
Comment 8 Chí-Thanh Christopher Nguyễn gentoo-dev 2013-08-13 14:20:20 UTC
*** Bug 480876 has been marked as a duplicate of this bug. ***
Comment 9 Samuli Suominen gentoo-dev 2013-08-13 15:33:18 UTC
Workaround:

1. Install stable libjpeg-turbo to compile libjpeg.so.8
2. Copy /usr/lib/libjpeg.so.8 to /usr/local/lib/
3. Copy libreoffice-bin ebuild to local overlay
4. Remove jpeg dependency from the copied ebuild
5. Let portage install latest libjpeg-turbo, because the lib is safe in /usr/local/lib/ now

And you have a working libreoffice-bin on ~arch, kept working by the old libjpeg.so.8 in /usr/local/lib/

This is what I told someone on forums, and it helped him, so I figured I share it here too.