Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 479666 - dev-libs/libgdata-0.13.4 - ./gdata/.libs/libgdata.so: undefined reference to `soup_session_new_with_options'
Summary: dev-libs/libgdata-0.13.4 - ./gdata/.libs/libgdata.so: undefined reference to ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: InVCS
Depends on:
Blocks: gnome-3.8
  Show dependency tree
 
Reported: 2013-08-03 21:28 UTC by Allan Gottlieb
Modified: 2013-08-06 12:48 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (file_479666.txt,16.16 KB, text/plain)
2013-08-03 21:29 UTC, Allan Gottlieb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Allan Gottlieb 2013-08-03 21:28:33 UTC
dev-libs/libgdata-0.13.4 fails to link.  Gives the error message
demos/scrapbook/.libs/scrapbook demos/scrapbook/demos_scrapbook_scrapbook-scrapbook.o -pthread  -Wl,--as-needed ./gdata/.libs/libgdata.so -lgtk-3 -lgdk-3 -lpangocairo-1.0 -lpango-1.0 -latk-1.0 -lcairo-gobject -lcairo -lgdk_pixbuf-2.0 -lgthread-2.0 -loauth -lsoup-gnome-2.4 -lsoup-2.4 -lgcr-base-3 -lgck-1 -lp11-kit -lxml2 -lgoa-1.0 -lgio-2.0 -lgobject-2.0 -lglib-2.0 -pthread
./gdata/.libs/libgdata.so: undefined reference to `soup_session_new_with_options'
collect2: error: ld returned 1 exit status
make[2]: *** [demos/scrapbook/scrapbook] Error 1
make[2]: Leaving directory `/mnt/junk/portage-tmpdir/portage/dev-libs/libgdata-0.13.4/work/libgdata-0.13.4'

Reproducible: Always

Steps to Reproduce:
1. emerge -1 libgdata
2.
3.
Actual Results:  
Fails with above

Expected Results:  
Should build and install

emerge --info will be an attachment (too big to paste)
Comment 1 Allan Gottlieb 2013-08-03 21:29:55 UTC
Created attachment 355060 [details]
emerge --info
Comment 2 Gilles Dartiguelongue gentoo-dev 2013-08-03 22:12:43 UTC
Looks like upstream forgot to raise its dependency on libsoup-2.42.
Comment 3 Allan Gottlieb 2013-08-03 22:37:48 UTC
(In reply to Gilles Dartiguelongue from comment #2)
> Looks like upstream forgot to raise its dependency on libsoup-2.42.

I see.  I have libsoup-2.42 masked (until I do systemd and gnome-3.8).  If this is the bug, it may also apply to sci-geosciences/geocode-glib-0.99.1.  I will file a bug on geocode-glib once the above dependency is confirmed to be the bug here.
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2013-08-06 09:34:56 UTC
+  06 Aug 2013; Lars Wendler <polynomial-c@gentoo.org> libgdata-0.13.4.ebuild:
+  Non-maintainer commit: Fixed dependency on dev-libs/libsoup (bug #479666).
+  Permission kindly granted by eva.
+