Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 479396 (CVE-2013-5018) - <net-misc/strongswan-5.1.0: "is_asn1()" XAuth Username and EAP Identity Handling Denial of Service Vulnerability (CVE-2013-5018)
Summary: <net-misc/strongswan-5.1.0: "is_asn1()" XAuth Username and EAP Identity Handl...
Status: RESOLVED FIXED
Alias: CVE-2013-5018
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Gentoo Security
URL: https://secunia.com/advisories/54315/
Whiteboard: B3 [glsa]
Keywords:
Depends on:
Blocks: 477502
  Show dependency tree
 
Reported: 2013-08-01 12:32 UTC by Agostino Sarubbo
Modified: 2013-09-02 01:30 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2013-08-01 12:32:32 UTC
From ${URL} :

escription

A vulnerability has been reported in strongSwan, which can be exploited by malicious people to 
cause a DoS (Denial of Service).

The vulnerability is caused due to an error within the "is_asn1()" function 
(libstrongswan/asn1/asn1.c) when handling XAuth usernames and EAP identities and can be exploited 
to cause a crash via specially crafted requests.

The vulnerability is reported in versions prior to 5.1.0.


Solution:
Update to version 5.1.0 or apply patch.

Further details available to Secunia VIM customers

Provided and/or discovered by:
Ewan Smythe in a bug report.

Original Advisory:
strongSwan:
http://strongswan.org/blog/2013/08/01/strongswan-5.1.0-released.html
http://strongswan.org/blog/2013/08/01/strongswan-denial-of-service-vulnerability-%28cve-2013-5018%29.html

Ewan Smythe:
https://lists.strongswan.org/pipermail/users/2013-July/009540.html


@maintainer(s): after the bump, in case we need to stabilize the package, please say explicitly if it is ready for the stabilization or not.
Comment 1 Bjarke Istrup Pedersen (RETIRED) gentoo-dev 2013-08-01 15:42:31 UTC
Bumped to 5.1.0 - please stabilize ASAP :-)
Comment 2 Chris Reffett gentoo-dev Security 2013-08-05 21:51:59 UTC
All right then. Arches, please stabilize =net-misc/strongswan-5.1.0, target arches amd64 arm ppc x86. Thanks!
Comment 3 Agostino Sarubbo gentoo-dev 2013-08-07 13:15:36 UTC
amd64 stable
Comment 4 Agostino Sarubbo gentoo-dev 2013-08-08 12:35:04 UTC
ppc stable
Comment 5 Agostino Sarubbo gentoo-dev 2013-08-08 12:38:13 UTC
x86 stable
Comment 6 Agostino Sarubbo gentoo-dev 2013-08-09 14:58:17 UTC
arm stable
Comment 7 Sergey Popov gentoo-dev 2013-08-24 04:52:38 UTC
GLSA vote: yes
Comment 8 Chris Reffett gentoo-dev Security 2013-08-25 19:20:34 UTC
GLSA vote: yes (since we're issuing a strongswan advisory already), added to GLSA request.
Comment 9 GLSAMaker/CVETool Bot gentoo-dev 2013-08-29 18:45:17 UTC
CVE-2013-5018 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-5018):
  The is_asn1 function in strongSwan 4.1.11 through 5.0.4 does not properly
  validate the return value of the asn1_length function, which allows remote
  attackers to cause a denial of service (segmentation fault) via a (1) XAuth
  username, (2) EAP identity, or (3) PEM encoded file that starts with a 0x04,
  0x30, or 0x31 character followed by an ASN.1 length value that triggers an
  integer overflow.
Comment 10 GLSAMaker/CVETool Bot gentoo-dev 2013-09-02 01:30:57 UTC
This issue was resolved and addressed in
 GLSA 201309-02 at http://security.gentoo.org/glsa/glsa-201309-02.xml
by GLSA coordinator Chris Reffett (creffett).