Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 478076 - Keyword sys-apps/systemd and unmask USE systemd
Summary: Keyword sys-apps/systemd and unmask USE systemd
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: High normal with 1 vote (vote)
Assignee: Gentoo systemd Team
Depends on: 438368 480218 497252 497254
Blocks: gnome-3.8 478082 487344
  Show dependency tree
Reported: 2013-07-25 06:07 UTC by Pacho Ramos
Modified: 2014-01-19 12:02 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2013-07-25 06:07:24 UTC
We need it keyworded in more arches due Gnome 3.8
Comment 1 Matt Turner gentoo-dev 2013-07-25 06:14:42 UTC
I think this might be where these three architectures have to hop off the gnome train. I suspect it's going to be very difficult to keep up with systemd and its requirements.

Let's see what others think.

I really don't want these architectures to hold up gnome 3.8. Can we (perhaps temporarily) USE mask systemd and the bits of gnome that unconditionally depend on it and be safe?
Comment 2 Pacho Ramos gentoo-dev 2013-07-25 06:18:50 UTC
I would really prefer if you could try to keyword it, if major problems appear in the future, you can drop the keyword then. What exact problems have systemd currently on your arches?
Comment 3 Samuli Suominen (RETIRED) gentoo-dev 2013-07-25 07:02:39 UTC
Alpha, HPPA, SH and everyone who doesn't support CONFIG_AUDITSYSCALL=y kernel feature should package.use.mask 'pam' for sys-apps/systemd as per:

As in, please don't forward port the bugs from CK handling over to systemd too
Comment 4 Pacho Ramos gentoo-dev 2013-08-21 10:33:22 UTC
ia64 looks to have problems for this, but what is blocking sparc and ppc?
Comment 5 Agostino Sarubbo gentoo-dev 2013-08-23 08:50:34 UTC
Keywords for sys-apps/systemd:
        |                           | u   |                                                                                                                                         
        | a a             p     s   | n   |                                                                                                                                         
        | l m   h i m m   p s   p   | u s | r                                                                                                                                       
        | p d a p a 6 i p c 3   a x | s l | e                                                                                                                                       
        | h 6 r p 6 8 p p 6 9 s r 8 | e o | p                                                                                                                                       
        | a 4 m a 4 k s c 4 0 h c 6 | d t | o                                                                                                                                       
 201    | o + + o o o o o + o o o + | # 0 | gentoo                                                                                                                                  
 204    | o + + o o o o + + o o o + | o   | gentoo                                                                                                                                  
 206-r3 | o ~ ~ o o o o ~ ~ o o o ~ | o   | gentoo                                                                                                                                  
9999-r1 | o o o o o o o o o o o o o | o   | gentoo 

ppc is done
Comment 6 Pacho Ramos gentoo-dev 2013-09-02 17:17:05 UTC
But looks like systemd USE flag is still masked on ppc
Comment 7 Pacho Ramos gentoo-dev 2013-09-11 14:20:04 UTC
ppc done (after talking with Ago)
Comment 8 Pacho Ramos gentoo-dev 2013-09-18 20:00:14 UTC
Can anyone from sparc and alpha team look at this? Thanks
Comment 9 Jack Morgan (RETIRED) gentoo-dev 2013-09-19 05:29:56 UTC
i'll take a look at this for sparc as i can do run-time testing, i had to fix my cvs tree first. thanks
Comment 10 Pacho Ramos gentoo-dev 2013-10-21 20:10:23 UTC
Would be nice if alpha and sparc (at least, since ia64 issue looks more complicated) could give this a higher priority :|
Comment 11 Matt Turner gentoo-dev 2013-11-05 07:29:55 UTC
I spent some time this weekend trying to make systemd work on alpha (sorry for the long delays). The ebuild says I need CONFIG_SECCOMP, which isn't available on alpha.

I ran into a kernel panic that I need to work through, but once that's fixed I'll attempt to run systemd without SECCOMP.
Comment 12 Mike Gilbert gentoo-dev 2013-11-05 15:30:39 UTC
(In reply to Matt Turner from comment #11)
> I ran into a kernel panic that I need to work through, but once that's fixed
> I'll attempt to run systemd without SECCOMP.

It will probably run, but there might be trouble with any units that utilize the SystemCallFilter parameter. systemd does not ship with any such units.
Comment 13 Matt Turner gentoo-dev 2013-11-13 04:18:35 UTC
added ~alpha and removed systemd from use.mask. :)
Comment 14 Pacho Ramos gentoo-dev 2013-11-13 19:20:04 UTC
Nice, thanks a lot :D
Comment 15 Pacho Ramos gentoo-dev 2013-11-14 21:18:54 UTC
If anyone could look for this on sparc, would be nice (to not need to drop packages from gnome-3.8 stabilization list). Thanks
Comment 16 Pacho Ramos gentoo-dev 2013-12-27 11:15:49 UTC
Comment 17 Pacho Ramos gentoo-dev 2014-01-07 09:47:02 UTC
ia64 done
Comment 18 Pacho Ramos gentoo-dev 2014-01-18 12:00:37 UTC
sparc? ping!
Comment 19 Agostino Sarubbo gentoo-dev 2014-01-19 12:02:19 UTC
sparc done