Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 477766 - dev-qt/designer - fix un-SLOTted reverse dependencies
Summary: dev-qt/designer - fix un-SLOTted reverse dependencies
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Qt Bug Alias
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: qt5-porting
  Show dependency tree
 
Reported: 2013-07-22 16:52 UTC by Eugene Shalygin
Modified: 2013-07-23 14:28 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Shalygin 2013-07-22 16:52:32 UTC
There are number of ebuild that have unslotted dependency on dev-qt/designer. In case qt overlay is active, these packages try to install latest (5th) version of the Qt tooolkit because of this dep.

All of these packages have the same (incorrect) line in ebuilds:
|| ( <dev-qt/qtgui-4.8.5:4 ( >=dev-qt/qtgui-4.8.5:4 dev-qt/designer ) )


Reproducible: Always




After a sync today, the list of ebuilds having this wrong dep is the following:

app-office/texstudio/texstudio-2.6.0.ebuild
app-office/texstudio/texstudio-2.6.2.ebuild
dev-util/qdevelop/qdevelop-0.28.ebuild
media-gfx/qosmic/qosmic-1.5.0.ebuild
net-voip/yate/yate-2.0.0.ebuild
net-voip/yate/yate-4.3.0.1.ebuild
sci-libs/vtk/vtk-5.10.0.ebuild
sci-libs/vtk/vtk-5.10.1.ebuild
sci-mathematics/qtoctave/qtoctave-0.10.1-r1.ebuild
sci-visualization/kst/kst-2.0.5.ebuild
sci-visualization/kst/kst-2.0.6.ebuild
x11-libs/libqxt/libqxt-0.6.2.ebuild
x11-libs/qscintilla/qscintilla-2.6.2.ebuild
x11-libs/qscintilla/qscintilla-2.7.1.ebuild
x11-libs/qscintilla/qscintilla-2.7.2.ebuild
x11-libs/qtermwidget/qtermwidget-0.4.0.ebuild
x11-plugins/qled/qled-0.6.2.ebuild
Comment 1 Michael Palimaka (kensington) gentoo-dev 2013-07-23 13:29:44 UTC
In addition to pinning the slot, I think we should change the dependency order:

|| ( ( >=dev-qt/qtgui-4.8.5:4 dev-qt/designer ) <dev-qt/qtgui-4.8.5:4 )
Comment 2 Ben de Groot (RETIRED) gentoo-dev 2013-07-23 13:49:48 UTC
Make that:

 || ( ( >=dev-qt/qtgui-4.8.5:4 dev-qt/designer:4 ) <dev-qt/qtgui-4.8.5:4 )

We can't allow unslotted dev-qt deps. And obviously we prefer the newer version.
Comment 3 Davide Pesavento gentoo-dev 2013-07-23 13:59:01 UTC
(In reply to Ben de Groot from comment #2)
> Make that:
> 
>  || ( ( >=dev-qt/qtgui-4.8.5:4 dev-qt/designer:4 ) <dev-qt/qtgui-4.8.5:4 )
> 
> We can't allow unslotted dev-qt deps. And obviously we prefer the newer
> version.

+1
Comment 4 Michael Palimaka (kensington) gentoo-dev 2013-07-23 14:28:20 UTC
Thank-you for the report. All the listed package have had their dependency corrected to include the slot, as well as the reorder discussed.