Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 477452 - development in overlays not working without masters = gentoo_prefix
Summary: development in overlays not working without masters = gentoo_prefix
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Unclassified (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS
Depends on:
Blocks: 472632
  Show dependency tree
 
Reported: 2013-07-20 07:52 UTC by Justin Lecher
Modified: 2013-07-26 08:11 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Justin Lecher gentoo-dev 2013-07-20 07:52:59 UTC
When using an overlay on a prefix with following settings

prefix: alias = gentoo
overlay: master = gentoo

I can't run repoman because I get massive errors:


alpha" doesn't have a valid profile listed in profiles.desc.
You need to either "cvs update" your profiles dir or follow this
up with the alpha team.

"amd64" doesn't have a valid profile listed in profiles.desc.
You need to either "cvs update" your profiles dir or follow this
up with the amd64 team.

"amd64-fbsd" doesn't have a valid profile listed in profiles.desc.
You need to either "cvs update" your profiles dir or follow this
up with the amd64-fbsd team.

"amd64-linux" doesn't have a valid profile listed in profiles.desc.
You need to either "cvs update" your profiles dir or follow this
up with the amd64-linux team.

and so on ....

The only way to fix it is setting the overlay to "masters = gentoo gentoo_prefix" but this will annoy the regular users. 

But principally this should be working or am I wrong?
Comment 1 Zac Medico gentoo-dev 2013-07-20 08:04:05 UTC
(In reply to Justin Lecher from comment #0)
> But principally this should be working or am I wrong?

It's not necessarily safe to for repoman to respect aliases, since that could lead to differing results depending on the user's local configuration, and the intention is for repoman to give reproducible results regardless of the user's configuration.

I guess we can come up with some sort of compromise that will allow repoman to use aliases, but something like that probably should not be enabled by default, since we'd like to have the results be as reproducible as possible with default settings.
Comment 2 Zac Medico gentoo-dev 2013-07-20 08:06:15 UTC
(In reply to Justin Lecher from comment #0)
> The only way to fix it is setting the overlay to "masters = gentoo
> gentoo_prefix" but this will annoy the regular users. 

If you omit the masters setting from layout.conf, then repoman will automatically use PORTDIR as the default master repo.
Comment 3 Justin Lecher gentoo-dev 2013-07-20 08:31:00 UTC
(In reply to Zac Medico from comment #2)
> (In reply to Justin Lecher from comment #0)
> > The only way to fix it is setting the overlay to "masters = gentoo
> > gentoo_prefix" but this will annoy the regular users. 
> 
> If you omit the masters setting from layout.conf, then repoman will
> automatically use PORTDIR as the default master repo.

Okay that works. Thanks.
Comment 4 Arfrever Frehtes Taifersar Arahesis 2013-07-24 00:40:19 UTC
Fix:
http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commitdiff;h=4c4f95b81294b8ef7673938ce3e6c95f0d814dfc

You should properly set force, aliases and masters attributes in /etc/portage/repos.conf.
Comment 5 Zac Medico gentoo-dev 2013-07-26 08:11:22 UTC
This is fixed in 2.1.13 and 2.2.0_alpha189.

Something like this in /etc/portage/repos.conf should do what you want:

[gentoo_prefix]
force = aliases