Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 477298 - fix for nvidia-drivers to build against >=3.6.10-Kernel
Summary: fix for nvidia-drivers to build against >=3.6.10-Kernel
Status: RESOLVED DUPLICATE of bug 447566
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-18 12:54 UTC by Jens Ott
Modified: 2013-07-18 13:11 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Ebuils using the patch (nvidia-drivers-325.08-r1.ebuild,12.70 KB, text/plain)
2013-07-18 12:55 UTC, Jens Ott
Details
The actual patch fixing nv-i2c.c (nv-i2c-3.6.10.patch,17.69 KB, patch)
2013-07-18 12:56 UTC, Jens Ott
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jens Ott 2013-07-18 12:54:41 UTC
The current ebuild nvidia-drivers (x11-drivers/nvidia-drivers-325.08) is not building against 3.6.10.X kernel. I found a patch under http://pastie.org/8123499 which makes it working properly and created an ebuild using this patch on 3.6.10 kernels.
Comment 1 Jens Ott 2013-07-18 12:55:55 UTC
Created attachment 353578 [details]
Ebuils using the patch

This ebuild auto-patches if kernel is >= 3.6.10
Comment 2 Jens Ott 2013-07-18 12:56:42 UTC
Created attachment 353580 [details, diff]
The actual patch fixing nv-i2c.c
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2013-07-18 12:59:28 UTC
(Quoting Doug Goldstein from bug #447566 comment #56)
> It is and has always been Gentoo's policy to support what NVIDIA supports. The current versions of the drivers do not support 3.10. You are more than welcome to use the capabilities of epatch_user (which are present in all the ebuilds) to make the changes yourself but they do not go into the main tree.

*** This bug has been marked as a duplicate of bug 447566 ***