Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 477074 - sys-apps/portage- emerging net-firewall/iptables- - /usr/lib64/portage/bin/ line 99: `___eapi_best_version_and_has_version_support_--host-root': not a valid identifier
Summary: sys-apps/portage- emerging net-firewall/iptables- - /usr/lib...
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Unclassified (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Portage team
Depends on:
Reported: 2013-07-16 14:35 UTC by Tim
Modified: 2013-07-17 17:19 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

build.log (build.log,94.26 KB, text/plain)
2013-07-16 14:35 UTC, Tim
Details (,4.90 KB, text/plain)
2013-07-16 14:36 UTC, Tim
emerge -pqv (emerge.pqv,190 bytes, text/plain)
2013-07-16 14:36 UTC, Tim
environment (environment,104.33 KB, text/plain)
2013-07-16 14:36 UTC, Tim

Note You need to log in before you can comment on or make changes to this bug.
Description Tim 2013-07-16 14:35:46 UTC
Created attachment 353452 [details]

Attempting to install iptables fails with "newinid failed". We're using systemd as openrc was causing us some problems affecting /proc. Any ideas how we can identify the cause of this?
Comment 1 Tim 2013-07-16 14:36:09 UTC
Created attachment 353454 [details]
Comment 2 Tim 2013-07-16 14:36:25 UTC
Created attachment 353456 [details]
emerge -pqv
Comment 3 Tim 2013-07-16 14:36:35 UTC
Created attachment 353458 [details]
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2013-07-16 14:38:33 UTC
Please don't do that.
Comment 5 Tim 2013-07-16 14:52:53 UTC
Thanks for looking into this. I'm not sure what the error means in the summary though.
Comment 6 Arfrever Frehtes Taifersar Arahesis 2013-07-16 14:59:52 UTC
(In reply to Tim from comment #3)
> declare -x SHELL="/bin/zsh"

It looks very bad.
Show: ls -l /bin/{ba,z,}sh
Comment 7 Tim 2013-07-16 15:08:05 UTC
-rwxr-xr-x 1 root root 741936 Jul 11 06:10 /bin/bash*
lrwxrwxrwx 1 root root      4 Jul 11 06:10 /bin/sh -> bash*
-rwxr-xr-x 2 root root 696808 Jul 16 14:49 /bin/zsh*
Comment 8 Arfrever Frehtes Taifersar Arahesis 2013-07-16 15:23:06 UTC
Do you set SHELL in make.conf or anywhere else?
What shell is used by root?
Reinstall app-shells/bash.
Comment 9 Tim 2013-07-16 15:28:54 UTC
Preference is to use zsh, therefore I emerged zsh, made sure the configuration exists in /root/.zshrc and changed the root shell with chsh -s /bin/zsh root. Do you think this is related?
Comment 10 Arfrever Frehtes Taifersar Arahesis 2013-07-16 15:43:55 UTC
Show: head -n1 /usr/lib64/portage/bin/ebuild-helpers/newinitd
Comment 11 Tim 2013-07-16 16:30:52 UTC
# head -n1 /usr/lib64/portage/bin/ebuild-helpers/newinitd 
Comment 12 Arfrever Frehtes Taifersar Arahesis 2013-07-16 16:38:36 UTC
Does reinstallation of app-shells/bash or sys-apps/portage help?
Comment 13 Tim 2013-07-17 06:40:57 UTC
Trying to re-emerge portage results in

"___eapi_best_version_and_has_version_support_--host-root': not a valid identifier"

Same error as python-exec and iptables :(
Comment 14 Zac Medico gentoo-dev 2013-07-17 06:51:45 UTC
You can try extracting this to replace /bin/bash:
Comment 15 Tim 2013-07-17 10:11:58 UTC
Too many packages throwing the same error. We gave up on this, formatted the drive and installed from scratch again. It seems to be working fine this time, perhaps it was a result of a bad stage3 tar ball or something to do with webrsync process (this time we downloaded the portage snapshot tar ball and extracted manually).