Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 476646 - Next version Gentoo/FreeBSD 9.2
Summary: Next version Gentoo/FreeBSD 9.2
Status: RESOLVED FIXED
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: FreeBSD (show other bugs)
Hardware: All FreeBSD
: Normal normal (vote)
Assignee: Gentoo/BSD Team
URL: http://lists.freebsd.org/pipermail/fr...
Whiteboard:
Keywords:
Depends on: 458570 477914
Blocks:
  Show dependency tree
 
Reported: 2013-07-12 16:44 UTC by Yuta SATOH
Modified: 2013-08-13 14:41 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
sample patch for freebsd-contrib-9.2_rc1.ebuild (476646-freebsd-contrib-9.2_rc1.ebuild.patch,773 bytes, patch)
2013-08-10 05:24 UTC, Yuta SATOH
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yuta SATOH 2013-07-12 16:44:38 UTC
I'll list some changes for FreeBSD 9.2.
Comment 2 Yuta SATOH 2013-07-12 16:46:23 UTC
freebsd-lib

freebsd-lib-9.9999: force install telnet.h , freebsd-{rescue,usbin}-9.9999 requires it.
http://git.overlays.gentoo.org/gitweb/?p=proj/gentoo-bsd.git;a=blob;f=sys-freebsd/freebsd-lib/files/freebsd-lib-9.9999-telnet.h.patch;h=7a08f13b27057b3792378d428b1889d537b66809;hb=719184b570e3ce3360c6fc5870b43e3b3bd23eb8

===> dconschat (all)
Warning: Object directory not changed from original /var/tmp/portage/sys-freebsd/freebsd-usbin-9.9999/work/usr.sbin/dconschat
x86_64-gentoo-freebsd9.0-gcc -O2 -pipe -fno-strict-aliasing  -I/var/tmp/portage/sys-freebsd/freebsd-usbin-9.9999/work/usr.sbin/dconschat/../../sys -std=gnu99 -fstack-protector -Wsystem-headers -Wno-pointer-sign -c dconschat.c
dconschat.c:59:25: fatal error: arpa/telnet.h: No such file or directory
compilation terminated.
*** [dconschat.o] Error code 1
1 error
*** [all] Error code 2
1 error
 * ERROR: sys-freebsd/freebsd-usbin-9.9999 failed (compile phase):


x86_64-gentoo-freebsd9.0-gcc -O2 -pipe  -DRESCUE -std=gnu99 -fstack-protector -Wsystem-headers -Wall -Wno-format-y2k -W -Wno-unused-parameter -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith -Wreturn-type -Wcast-qual -Wwrite-strings -Wswitch -Wshadow -Wunused-parameter -Wcast-align -Wchar-subscripts -Winline -Wnested-externs -Wredundant-decls -Wold-style-definition -Wno-pointer-sign -c mt.c
(cd /var/tmp/portage/sys-freebsd/freebsd-rescue-9.9999/work/rescue/rescue/../../usr.bin/nc &&  make -DRESCUE CRUNCH_CFLAGS=-DRESCUE DIRPRFX=rescue/nc/ depend && make -DRESCUE CRUNCH_CFLAGS=-DRESCUE DIRPRFX=rescue/nc/ netcat.o atomicio.o socks.o)
rm -f .depend
CC='x86_64-gentoo-freebsd9.0-gcc' mkdep -f .depend -a    -DIPSEC -DRESCUE -std=gnu99   /var/tmp/portage/sys-freebsd/freebsd-rescue-9.9999/work/usr.bin/nc/../../contrib/netcat/netcat.c /var/tmp/portage/sys-freebsd/freebsd-rescue-9.9999/work/usr.bin/nc/../../contrib/netcat/atomicio.c /var/tmp/portage/sys-freebsd/freebsd-rescue-9.9999/work/usr.bin/nc/../../contrib/netcat/socks.c
/var/tmp/portage/sys-freebsd/freebsd-rescue-9.9999/work/usr.bin/nc/../../contrib/netcat/netcat.c:50:25: fatal error: arpa/telnet.h: No such file or directory
compilation terminated.
mkdep: compile failed
*** [.depend] Error code 1
1 error
*** [nc_make] Error code 2
1 error
*** [objs] Error code 2
1 error
*** [all] Error code 2
1 error
 * ERROR: sys-freebsd/freebsd-rescue-9.9999 failed (compile phase):
Comment 8 Yuta SATOH 2013-07-23 12:02:14 UTC
added support for upgrade from a previous version.
Please fix it if you know a better way.

http://git.overlays.gentoo.org/gitweb/?p=proj/gentoo-bsd.git;a=commit;h=8c457c2832e7ca01e98e2ad4d1563f89d9cb779e

FYI,
http://svnweb.freebsd.org/base/stable/9/UPDATING?r1=250121&r2=250070


cd /var/tmp/portage/sys-freebsd/freebsd-lib-9.2_beta1/work/include/../sys/rpc;  install -C -o portage -g 0 -m 444 types.h  /var/tmp/portage/sys-freebsd/freebsd-lib-9.2_beta1/work/include_proper_x86_fbsd/rpc
/var/tmp/portage/sys-freebsd/freebsd-lib-9.2_beta1/work/include_proper_x86_fbsd/aio.h -> sys/aio.h
install: illegal option -- l
usage: install [-bCcMpSsv] [-B suffix] [-f flags] [-g group] [-m mode]
               [-o owner] file1 file2
       install [-bCcMpSsv] [-B suffix] [-f flags] [-g group] [-m mode]
               [-o owner] file1 ... fileN directory
       install -d [-v] [-g group] [-m mode] [-o owner] directory ...
*** [installincludes] Error code 64

Stop in /var/tmp/portage/sys-freebsd/freebsd-lib-9.2_beta1/work/include.
 * ERROR: sys-freebsd/freebsd-lib-9.2_beta1 failed (compile phase):
 *   install_includes() failed
Comment 10 Yuta SATOH 2013-07-23 13:14:13 UTC
freebsd-sources-9.9999: added 2 patches, required for successful compile.

http://git.overlays.gentoo.org/gitweb/?p=proj/gentoo-bsd.git;a=commit;h=264ac9e4606fcd392ea8777bf87436e7750a3063

* freebsd-sources-9.9999-gentoo-gcc.patch
If you don't apply the patch, output two lines.
limited to one line.

$ gcc -v 2>&1 | grep 'version'
Configured with: /var/tmp/portage/sys-devel/gcc-4.6.4/work/gcc-4.6.4/configure --prefix=/usr --bindir=/usr/x86_64-gentoo-freebsd9.0/gcc-bin/4.6.4 --includedir=/usr/lib/gcc/x86_64-gentoo-freebsd9.0/4.6.4/include --datadir=/usr/share/gcc-data/x86_64-gentoo-freebsd9.0/4.6.4 --mandir=/usr/share/gcc-data/x86_64-gentoo-freebsd9.0/4.6.4/man --infodir=/usr/share/gcc-data/x86_64-gentoo-freebsd9.0/4.6.4/info --with-gxx-include-dir=/usr/lib/gcc/x86_64-gentoo-freebsd9.0/4.6.4/include/g++-v4 --host=x86_64-gentoo-freebsd9.0 --build=x86_64-gentoo-freebsd9.0 --disable-altivec --disable-fixed-point --without-cloog --without-ppl --disable-lto --enable-nls --without-included-gettext --with-system-zlib --enable-obsolete --disable-werror --enable-secureplt --enable-multilib --disable-libmudflap --disable-libssp --disable-libgomp --with-python-dir=/share/gcc-data/x86_64-gentoo-freebsd9.0/4.6.4/python --enable-checking=release --disable-libgcj --enable-libstdcxx-time --disable-libquadmath --enable-languages=c,c++ --enable-shared --enable-threads=posix --enable-__cxa_atexit --enable-targets=all --with-bugurl=http://bugs.gentoo.org/ --with-pkgversion='Gentoo 4.6.4 p1.0, pie-0.5.2'
gcc version 4.6.4 (Gentoo 4.6.4 p1.0, pie-0.5.2)

$ gcc -v 2>&1 | grep 'version' | tail -n 1
gcc version 4.6.4 (Gentoo 4.6.4 p1.0, pie-0.5.2)
$ clang -v 2>&1 | grep 'version' | tail -n 1
clang version 3.3 (tags/RELEASE_33/final)

* freebsd-sources-9.9999-no_ctf.patch
add nomakeoptions WITH_CTF to conf/GENERIC.
Workaround for the following problem.

===> aic7xxx/ahc (depend)
@ -> /usr/src/sys-9.2
machine -> /usr/src/sys-9.2/amd64/include
x86 -> /usr/src/sys-9.2/x86/include
( cd /usr/src/sys-9.2/modules/aic7xxx/ahc/../aicasm; make aicasm; )
cc -O2 -pipe  -I. -I/usr/src/sys-9.2/modules/aic7xxx/aicasm/../../../dev/aic7xxx/aicasm -g -std=gnu99 -fstack-protector -Wsystem-headers -Wall -Wno-format-y2k -W -Wno-unused-parameter -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith -Wreturn-type -Wcast-qual -Wwrite-strings -Wswitch -Wshadow -Wunused-parameter -Wcast-align -Wno-pointer-sign -c /usr/src/sys-9.2/modules/aic7xxx/aicasm/../../../dev/aic7xxx/aicasm/aicasm.c
ctfconvert -L VERSION -g aicasm.o
*** [aicasm.o] Signal 11

Stop in /usr/src/sys-9.2/modules/aic7xxx/aicasm.
*** [../aicasm/aicasm] Error code 1
Comment 11 Yuta SATOH 2013-07-23 15:47:49 UTC
added bug 458570 to depends.
I'll create based on svn live ebuild, version 9.2 or later.
Comment 12 Yuta SATOH 2013-08-03 11:23:49 UTC
freebsd-{lib,libexec,ubin}-9999: Change that can be disabled USE=multilib

http://git.overlays.gentoo.org/gitweb/?p=proj/gentoo-bsd.git;a=commit;h=13f5651a8fd6274c291bfd167fd7d0535d481a99
Comment 13 Alexis Ballier gentoo-dev 2013-08-09 15:16:25 UTC
(In reply to Yuta SATOH from comment #1)
> * freebsd-pf
> 
> freebsd-{pf,sources}-9.9999: need freebsd-mk-defs in same revision
> http://git.overlays.gentoo.org/gitweb/?p=proj/gentoo-bsd.git;a=blobdiff;
> f=sys-freebsd/freebsd-pf/freebsd-pf-9.9999.ebuild;
> h=0ac14079cb5bdd7986d412924ecc85ea4676479c;
> hp=c169a4f5b8253a55695b10573a93218ce928f2a9;
> hb=b43462566fff9d18f4e0541857ad1200b23153bb;
> hpb=5b6a4f39d2e6be501e61569eab1f1bc243dddc24

applied this one to 9.1
Comment 14 Alexis Ballier gentoo-dev 2013-08-09 15:26:59 UTC
(In reply to Yuta SATOH from comment #4)
> freebsd-sources
> 
> freebsd-{pf,sources}-9.9999: need freebsd-mk-defs in same revision
> http://git.overlays.gentoo.org/gitweb/?p=proj/gentoo-bsd.git;a=blobdiff;
> f=sys-freebsd/freebsd-sources/freebsd-sources-9.9999.ebuild;
> h=2b97737f2030ae1e6f61ce41aa90ec3a2af40c0c;
> hp=cc9ecb324ebdd2057eaf0f2b013f1a8ecfde995a;
> hb=b43462566fff9d18f4e0541857ad1200b23153bb;
> hpb=5b6a4f39d2e6be501e61569eab1f1bc243dddc24
> 
> freebsd-sources-9.9999: I forgot to replace ${RV}. fix it.
> http://git.overlays.gentoo.org/gitweb/?p=proj/gentoo-bsd.git;a=blobdiff;
> f=sys-freebsd/freebsd-sources/freebsd-sources-9.9999.ebuild;
> h=27ca3bb30f5177c335835c1dec4a2ae19640f3f2;
> hp=2887458a66807a2df0adbbb351fa84747b66508c;
> hb=215c51a65ef452b184003ae3a01b78adfa5881b3;
> hpb=9d230319cc81f5af0f7dfa4c61327435fbfc3bfd

applied these 2 to 9.1
Comment 15 Alexis Ballier gentoo-dev 2013-08-09 15:33:09 UTC
(In reply to Yuta SATOH from comment #5)
> freebsd-usbin
> 
> freebsd-usbin-9.9999: added new use flag, kerberos
> http://svnweb.freebsd.org/base?view=revision&revision=245089
> http://git.overlays.gentoo.org/gitweb/?p=proj/gentoo-bsd.git;a=commit;
> h=f17761b22859bb6c14f3ed8f6a587d692b8c7cf6

shouldnt be needed since we dont build gssd with kerberos useflag disabled
Comment 16 Alexis Ballier gentoo-dev 2013-08-09 15:33:31 UTC
(In reply to Yuta SATOH from comment #12)
> freebsd-{lib,libexec,ubin}-9999: Change that can be disabled USE=multilib
> 
> http://git.overlays.gentoo.org/gitweb/?p=proj/gentoo-bsd.git;a=commit;
> h=13f5651a8fd6274c291bfd167fd7d0535d481a99

fixed by converting them to multilib-build btw
Comment 17 Alexis Ballier gentoo-dev 2013-08-09 15:39:29 UTC
(In reply to Yuta SATOH from comment #6)
> freebsd-usbin-9.9999: Remove sysrc/service command.
> 
> http://git.overlays.gentoo.org/gitweb/?p=proj/gentoo-bsd.git;a=blobdiff;
> f=sys-freebsd/freebsd-usbin/freebsd-usbin-9.9999_p253216.ebuild;
> h=118686ae0db6b2e62ef6df02a43710dc6f4af40e;
> hp=c0dbf187d8c503d0c8c5cc396e2f7d82397b7cd3;
> hb=3ea3f92356346fefbb1f1c12d18a123a8f14d5f5;
> hpb=0ad59959602a8a3672dd8a6c3369f684e81a619e

removed service from 9.1, sysrc is 9.2 it seems
Comment 18 Alexis Ballier gentoo-dev 2013-08-09 19:30:16 UTC
(In reply to Yuta SATOH from comment #8)
> added support for upgrade from a previous version.
> Please fix it if you know a better way.
> 
> http://git.overlays.gentoo.org/gitweb/?p=proj/gentoo-bsd.git;a=commit;
> h=8c457c2832e7ca01e98e2ad4d1563f89d9cb779e
> 
> FYI,
> http://svnweb.freebsd.org/base/stable/9/UPDATING?r1=250121&r2=250070

I've added it to freebsd_src_unpack; please test!
Comment 19 Alexis Ballier gentoo-dev 2013-08-09 21:15:30 UTC
(In reply to Yuta SATOH from comment #2)
> freebsd-lib
> 
> freebsd-lib-9.9999: force install telnet.h , freebsd-{rescue,usbin}-9.9999
> requires it.
> http://git.overlays.gentoo.org/gitweb/?p=proj/gentoo-bsd.git;a=blob;f=sys-
> freebsd/freebsd-lib/files/freebsd-lib-9.9999-telnet.h.patch;
> h=7a08f13b27057b3792378d428b1889d537b66809;
> hb=719184b570e3ce3360c6fc5870b43e3b3bd23eb8

fixed differently in 9.2_rc1 in portage tree: just dont disable libtelnet
Comment 20 Alexis Ballier gentoo-dev 2013-08-09 22:04:48 UTC
the underlink patch for fbsd-cddl is still needed here it seems
Comment 21 Yuta SATOH 2013-08-10 05:24:35 UTC
Created attachment 355578 [details, diff]
sample patch for freebsd-contrib-9.2_rc1.ebuild

(In reply to Alexis Ballier from comment #18)
> (In reply to Yuta SATOH from comment #8)
> > added support for upgrade from a previous version.
> > Please fix it if you know a better way.
> > 
> > http://git.overlays.gentoo.org/gitweb/?p=proj/gentoo-bsd.git;a=commit;
> > h=8c457c2832e7ca01e98e2ad4d1563f89d9cb779e
> > 
> > FYI,
> > http://svnweb.freebsd.org/base/stable/9/UPDATING?r1=250121&r2=250070
> 
> I've added it to freebsd_src_unpack; please test!

freebsd-contrib does not call freebsd_src_unpack.
Remove src_unpack() from ebuild, I'll attach a sample patch to call freebsd_src_unpack.
Comment 22 Alexis Ballier gentoo-dev 2013-08-11 19:17:24 UTC
(In reply to Yuta SATOH from comment #21)
> Created attachment 355578 [details, diff] [details, diff]
> sample patch for freebsd-contrib-9.2_rc1.ebuild
> 
> (In reply to Alexis Ballier from comment #18)
> > (In reply to Yuta SATOH from comment #8)
> > > added support for upgrade from a previous version.
> > > Please fix it if you know a better way.
> > > 
> > > http://git.overlays.gentoo.org/gitweb/?p=proj/gentoo-bsd.git;a=commit;
> > > h=8c457c2832e7ca01e98e2ad4d1563f89d9cb779e
> > > 
> > > FYI,
> > > http://svnweb.freebsd.org/base/stable/9/UPDATING?r1=250121&r2=250070
> > 
> > I've added it to freebsd_src_unpack; please test!
> 
> freebsd-contrib does not call freebsd_src_unpack.
> Remove src_unpack() from ebuild, I'll attach a sample patch to call
> freebsd_src_unpack.

not optimal but applied, thx
Comment 23 Alexis Ballier gentoo-dev 2013-08-11 19:46:09 UTC
+*freebsd-rescue-9.2_rc1 (11 Aug 2013)
+
+  11 Aug 2013; Alexis Ballier <aballier@gentoo.org>
+  +freebsd-rescue-9.2_rc1.ebuild:
+  Version bump, based on work of Yuta Satoh, simplified by me: Build our own
+  static libarchive. It is good to use system shared libraries but here it is a
+  statically linked rescue shell, trying use system libarchive.a made us carry
+  a lot of patches and pkg-config started to fail on us. Not counting
+  libarchive.pc not correctly declaring its private libs.
+


should be all setup to rc1 now! thanks a lot!

and please update the overlay!
Comment 24 Yuta SATOH 2013-08-13 14:41:25 UTC
(In reply to Alexis Ballier from comment #23)
> should be all setup to rc1 now! thanks a lot!
Thanks for merge to main tree and reviews patches.

> and please update the overlay!
I've updated -9.9999 ebuild and freebsd.eclass on overlay.
and I removed -9.2.9999* ebuild from overlay.