Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 476392 - =dev-libs/cyrus-sasl-2.1.16-r1 - Variable 'exec_prefix' not defined in '/usr/lib/pkgconfig/libsasl2.pc'
Summary: =dev-libs/cyrus-sasl-2.1.16-r1 - Variable 'exec_prefix' not defined in '/usr/...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-10 13:16 UTC by Anton Kochkov
Modified: 2019-03-26 20:02 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
cyrus-sasl-2.1.26-pkgconfig.patch (cyrus-sasl-2.1.26-pkgconfig.patch,217 bytes, patch)
2013-12-10 14:53 UTC, Fabio Rossi
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Anton Kochkov 2013-07-10 13:16:18 UTC
pkg-config --list-all /usr/lib/pkgconfig/libsasl2.pc
is failing with
Variable 'exec_prefix' not defined in '/usr/lib/pkgconfig/libsasl2.pc'
Comment 1 Eray Aslan gentoo-dev 2013-07-14 08:33:25 UTC
Please provide emerge --info output and the exact command that returns an error.  I can't reproduce it.  The fix is trivial if there is indeed an error.
Comment 2 Anton Kochkov 2013-07-25 22:24:45 UTC
(In reply to Eray Aslan from comment #1)
> Please provide emerge --info output and the exact command that returns an
> error.  I can't reproduce it.  The fix is trivial if there is indeed an
> error.

Sorry for the late response. I've checked a few my gentoo installations with the same cyrus-sasl version, and looks like libsasl2.pc is different.

it was:

libdir = ${exec_prefix}/lib

(... package description ...)

On the other pc it is

libdir = /usr/lib64

(... package description ...)
Comment 3 Fabio Rossi 2013-12-10 14:53:09 UTC
Created attachment 365054 [details, diff]
cyrus-sasl-2.1.26-pkgconfig.patch

Here is a simple patch to solve the issue