Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 475640 - =x11-misc/slim-1.3.5-r2, =sys-auth/pambase-20120417-r2 - Slim restarts during fingerprint scanner swipe. - slim: unexpected signal 15 - localhost polkitd: Error converting subject to JS object: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: ...
Summary: =x11-misc/slim-1.3.5-r2, =sys-auth/pambase-20120417-r2 - Slim restarts during...
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Ian Stakenvicius
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-03 17:59 UTC by Štěpán Dalecký
Modified: 2018-09-23 17:00 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
/etc/pam.d/system-auth (system-auth,533 bytes, text/plain)
2013-07-03 18:03 UTC, Štěpán Dalecký
Details
dmesg (dmesg,61.20 KB, text/plain)
2013-07-09 19:44 UTC, Štěpán Dalecký
Details
lspci -vvv (lspci,21.96 KB, text/plain)
2013-07-09 19:45 UTC, Štěpán Dalecký
Details
lsusb -vvv (lsusb,38.25 KB, text/plain)
2013-07-09 19:47 UTC, Štěpán Dalecký
Details
messages (messages,985.21 KB, text/plain)
2013-07-09 20:47 UTC, Štěpán Dalecký
Details
slim.log (slim.log,8.24 KB, text/x-log)
2013-07-09 20:47 UTC, Štěpán Dalecký
Details
strace when slim freezes (slim_freeze,62.14 KB, text/plain)
2014-02-04 01:28 UTC, Štěpán Dalecký
Details
ltrace when slim freezes (slim_freeze_ltrace,10.68 KB, text/plain)
2014-02-04 18:08 UTC, Štěpán Dalecký
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Štěpán Dalecký 2013-07-03 17:59:15 UTC
After update to the latest pambase and shadow slim start restarting after swipe over the fingerprint reader.




I try to search in /var/log/[messages, Xorg.0.log, slim.log, dmesg] but found nothing interesting.

If I start slim from root command line, problem is not reproducible.
# slim

Reproducible: Always

Steps to Reproduce:
1. Boot up
2. Display slim
3. Swipe
4. Slim restarts
5. Swipe again ( sometimes work and sometimes black screen after swipe )
6. If black screen, on other console /etc/init.d/xdm restart and jump to 2
Actual Results:  
Black screen or slim restart or login

Expected Results:  
Login every time
Comment 1 Štěpán Dalecký 2013-07-03 18:03:22 UTC
Created attachment 352536 [details]
/etc/pam.d/system-auth

Edited pam.d conf file
Added only line with pam_fprintd.so
Comment 2 Jeroen Roovers gentoo-dev 2013-07-04 13:06:30 UTC
Please post your `emerge --info' output in a comment.
Comment 3 Štěpán Dalecký 2013-07-04 13:58:11 UTC
Portage 2.1.12.2 (default/linux/amd64/13.0/desktop, gcc-4.6.3, glibc-2.15-r3, 3.10.0-gentoo x86_64)
=================================================================
System uname: Linux-3.10.0-gentoo-x86_64-Intel-R-_Core-TM-_i5-2540M_CPU_@_2.60GHz-with-gentoo-2.2
KiB Mem:     8124224 total,   5489308 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Wed, 03 Jul 2013 22:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
ccache version 3.1.9 [enabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.5, 3.2.5-r1
dev-util/ccache:          3.1.9
dev-util/cmake:           2.8.10.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo-haskell gentoo gamerlay xfce-dev x-portage
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache clean-logs config-protect-if-modified distlocks ebuild-locks fail-clean fixlafiles merge-sync news parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="cs_CZ.UTF-8"
LC_ALL="cs_CZ.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/dev/shm"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/haskell /usr/portage /var/lib/layman/gamerlay /var/lib/layman/xfce-dev /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 android apache2 apng archive autoipd avahi avx bash-completion berkdb bluetooth bookmarks branding bzip2 c++0x cairo cdda cddb cdr city cli cmake connection-sharing consolekit cracklib crypt cups curl cxx dbus device-mapper dhcpcd dia directfb djbfft dot dri drm dvd dvdr emboss encode exif extra extras fakevim fam fat fbcon ffmpeg firefox flac fontconfig fuse g3dvl gallium gbm gconf gd gdbm gdu geoip gif gimp git gles gles2 gnome gnome-keyring gnutls gpm gstreamer gtk gtk3 gtkstyle gui hdaps hddtemp hoogle hscolour iconv icu imlib inotify introspection ipv6 java jpeg lame latex lcms ldap libcanberra libkms libnotify libv4l2 mad mdnsresponder-compat mg5200 minizip mms mmx mmxext mng modules mp3 mp4 mpeg mtp mudflap multilib mysql mysqli ncurses network networkmanager new-login nls nptl nsplugin ntfsprogs ntp odf offensive ogg opengl openmp optimized-qmake opus pam pango pch pcre pdf perl php png policykit ppds private-headers profile python python3 qt4 raw readline rss s3tc samba scsi sdl secure-delete session sna sound spell sqlite sse sse2 sse3 sse4_1 ssl ssse3 startup-notification steamgames_trine2 subversion svg system-libCg system-sqlite tcl tcpd theora thinkpad threads thunar tiff toolbar truetype udev udisks unicode unlock-notify upnp upower usb utils v4l vaapi vala valgrind vim-syntax vorbis wayland webgl webkit wifi wxwidgets x264 xcb xfce xinerama xml xnest xorg xv xvid xvmc zeroconf zip zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="cs" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XFCE_PLUGINS="brightness logout trash" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 4 Jeroen Roovers gentoo-dev 2013-07-07 13:56:37 UTC
What do you mean by slim restarting?
Comment 5 Štěpán Dalecký 2013-07-07 22:30:45 UTC
When I swipe the reader VTY is visible for a second and then slim appears again. When I swipe again, screen turns black and I have to restart xdm.
Comment 6 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-07-09 18:08:07 UTC
1) Which fingerprint reader device is this? Please provide lspci and dmesg.
2) Can you try to debug it? After pam_fprintd.so you can add the word debug.
3) Failing to debug pam_fprintd, try to add the debug word after more .so files.
4) Failing to debug anything, can you try to use the audit word instead?
5) If possible, try to see if you can enable debug / logs for slim or fprintd.

For these steps; debug and audit information will be output to /var/log/messages.
Comment 7 Štěpán Dalecký 2013-07-09 19:44:10 UTC
Created attachment 352942 [details]
dmesg
Comment 8 Štěpán Dalecký 2013-07-09 19:45:57 UTC
Created attachment 352944 [details]
lspci -vvv
Comment 9 Štěpán Dalecký 2013-07-09 19:47:29 UTC
Created attachment 352946 [details]
lsusb -vvv
Comment 10 Štěpán Dalecký 2013-07-09 20:44:24 UTC
1) I'm using USB reader "Bus 001 Device 004: ID 147e:2016 Upek Biometric Touchchip/Touchstrip Fingerprint Sensor".
2), 3), 4) Tried but I could not see anything special (log attached). Tried:
debug with frpintd, debug with fprintd and next line, same for audit
5) Slim log attached.
Comment 11 Štěpán Dalecký 2013-07-09 20:47:19 UTC
Created attachment 352954 [details]
messages
Comment 12 Štěpán Dalecký 2013-07-09 20:47:32 UTC
Created attachment 352956 [details]
slim.log
Comment 13 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-07-09 20:54:01 UTC
The errors that I feel may be most relevant are in the bug summary; assigned to slim maintainers and CC-ed pambase maintainers, so they can work together on finding the root cause.
Comment 14 Štěpán Dalecký 2014-02-03 21:22:54 UTC
Any progress?
I tried it with actually stable versions of packages and still doesn't work. I also cannot find any useful debug info.
Comment 15 Ian Stakenvicius gentoo-dev 2014-02-03 22:31:41 UTC
I cannot reproduce this.  pam_fprintd.so works just fine for me with slim and everything else I've tried so far, both when part of pam.d/system-auth and when alternatively part of pam.d/system-{,local-}login 

It is worth noting that for me, after slim received uid information, the screen doesn't update -- this would be because the pam auth module doesn't trigger the password callback.  I expect some sort of an extension could be added so that a 'scan-your-finger' message comes up, but, that's outside the scope of this bug.

Another thing that may be worth noting, is that slim does auth to the root user; so it's possible that if you've got fprints enrolled for both your regular user and your root user, that this is messing things up..?
Comment 16 Štěpán Dalecký 2014-02-04 01:28:19 UTC
I don't have fingeprint login for root user. I tried to strace slim and I'm able to strace situation when slim freezes (black screen after swipe). Strace attached.

If restart occurs with strace I'll add it.
Comment 17 Štěpán Dalecký 2014-02-04 01:28:49 UTC
Created attachment 369490 [details]
strace when slim freezes
Comment 18 Ian Stakenvicius gentoo-dev 2014-02-04 16:41:25 UTC
OK, some progress -- I was able to produce a frozen/blank-screen situation when I added an fprint for my root user, and also scanned a completely unverifyable finger.  As such, I think the issue may have to do with slim simply not having the means to handle the callbacks that pam_fprintd.so outputs or triggers.

Thank you for the strace, i'll keep at it from here.
Comment 19 Štěpán Dalecký 2014-02-04 18:08:23 UTC
Created attachment 369550 [details]
ltrace when slim freezes

Maybe it helps, too.
Comment 20 Ian Stakenvicius gentoo-dev 2014-03-14 13:49:44 UTC
Is it possible that this might relate?

http://developer.berlios.de/bugs/?func=detailbug&bug_id=19284&group_id=2663
Comment 21 Štěpán Dalecký 2014-03-14 19:14:14 UTC
I've just applied this patch http://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/patches/slim-sigusr1.patch?id=f9ec07a9859c5b305105ab38bff3f3db0dcb842d
and nothing has changed for me.