Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 473524 - app-editors/emacs-24.3-r2 Error: symbol `pread64' is already defined on prefix
Summary: app-editors/emacs-24.3-r2 Error: symbol `pread64' is already defined on prefix
Status: RESOLVED FIXED
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: Prefix Support (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Prefix
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-16 20:06 UTC by William Throwe
Modified: 2014-07-09 12:07 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description William Throwe 2013-06-16 20:06:15 UTC
i686-pc-linux-gnu-gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I/home/supernova/wthrowe/gentoo/var/tmp/portage/app-editors/emacs-24.3-r2/work/emacs-24.3/lib -I../src -I/home/supernova/wthrowe/gentoo/var/tmp/portage/app-editors/emacs-24.3-r2/work/emacs-24.3/src      -march=native -O2 -pipe -ggdb -c careadlinkat.c
...
{standard input}: Assembler messages:
{standard input}:122: Error: symbol `pread64' is already defined
make[2]: *** [careadlinkat.o] Error 1


http://gcc.gnu.org/bugzilla/show_bug.cgi?id=42735 seems to suggest that this is a bug in old glibc which newer gcc is supposed to work around but isn't for some reason.


$ rpm -qa | grep glibc
glibc-headers-2.5-81.el5_8.4
glibc-devel-2.5-81.el5_8.4
glibc-common-2.5-81.el5_8.4
glibc-2.5-81.el5_8.4
$ emerge --info && emerge -pqv emacs

!!! Your current profile is deprecated and not supported anymore.
!!! Use eselect profile to update your profile.
!!! Please upgrade to the following profile if possible:

        default/linux/x86/13.0

You may use the following command to upgrade:

        eselect profile set default/linux/x86/13.0

Portage 2.2.01.22013-prefix (prefix/linux/x86, gcc-4.7.2, unavailable, 2.6.18-308.11.1.el5PAE i686)
=================================================================
System uname: Linux-2.6.18-308.11.1.el5PAE-i686-Intel-R-_Xeon-R-_CPU_5150_@_2.66GHz-with-redhat-5.8-Tikanga
KiB Mem:     4145608 total,    353676 free
KiB Swap:    3068404 total,   2258408 free
Timestamp of tree: Fri, 14 Jun 2013 20:40:27 +0000
ld GNU ld (GNU Binutils) 2.23
app-shells/bash:          4.2_p39-r1
dev-lang/python:          2.7.3-r3, 3.3.0-r1
dev-util/cmake:           2.8.11.1
dev-util/pkgconfig:       0.28
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.12.4
sys-devel/binutils:       2.23
sys-devel/gcc:            4.6.3, 4.7.2-r1
sys-devel/gcc-config:     1.8-r00.1
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
Repositories: gentoo_prefix g-cpan
ACCEPT_KEYWORDS="x86-linux ~x86-linux"
ACCEPT_LICENSE="@FREE"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -ggdb"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe -ggdb"
DISTDIR="/home/astrosun/wthrowe/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--ask"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs clean-logs collision-protect compress-build-logs config-protect-if-modified distlocks ebuild-locks fixlafiles force-prefix merge-sync news parallel-fetch preserve-libs protect-owned sfperms splitdebug strict unknown-features-warn unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="POSIX"
LDFLAGS="-Wl,-O1 -Wl,--hash-style=gnu"
MAKEOPTS="-j3"
PKGDIR="/home/supernova/wthrowe/gentoo/usr/portage/packages"
PORTAGE_CONFIGROOT="/home/supernova/wthrowe/gentoo/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/home/supernova/wthrowe/gentoo/var/tmp"
PORTDIR="/home/supernova/wthrowe/gentoo/usr/portage"
PORTDIR_OVERLAY="/home/supernova/wthrowe/gentoo/var/lib/g-cpan"
SYNC="rsync://rsync.prefix.freens.org/gentoo-portage-prefix"
USE="berkdb bindist bzip2 cli cracklib crypt cxx dri fortran gdbm iconv ipv6 modules mudflap ncurses nls nptl openmp pcre prefix readline session ssl tcpd unicode x86 zlib" ABI_X86="32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

[ebuild     U ] app-editors/emacs-24.3-r2 [24.2] USE="-X -Xaw3d -alsa (-aqua) -athena -dbus -games -gconf -gif -gnutls (-gpm) -gsettings -gtk -gtk3 -gzip-el (-hesiod) -imagemagick -jpeg -kerberos -libxml2 -livecd (-m17n-lib) -motif -pax_kernel -png (-selinux) -sound -source -svg -tiff -toolkit-scroll-bars -wide-int -xft -xpm"
Comment 1 Michael Haubenwallner gentoo-dev 2014-07-09 07:32:14 UTC
Same here during Prefix bootstrap with coreutils-8.22 here on RHEL 5.4 (glibc-2.5), this is because of the "-std=gnu99" compiler flag.

However, there is the "-fgnu89-inline" compiler flag:
available since gcc-4.1.3, necessary since gcc-4.3.

I'm working on a profile.bashrc for Prefix to add this flag on such platforms for selected (=breaking) packages as a workaround for now. Seems like this is fixed since glibc-2.6.
Comment 2 Michael Haubenwallner gentoo-dev 2014-07-09 12:07:21 UTC
(In reply to Michael Haubenwallner from comment #1)
> for selected (=breaking) packages

As the list of packages breaking with glibc-2.5 and older likely will grow over time, I'm adding -fgnu89-inline for each package now to profiles/prefix/linux/profile.bashrc (similar to how default-fortify-source is disabled for glibc-2.11 and older).