Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 473438 - dev-perl/IO-Socket-IP-0.180.0 fails t/11sockopts.t
Summary: dev-perl/IO-Socket-IP-0.180.0 fails t/11sockopts.t
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Perl team
URL: https://rt.cpan.org/Ticket/Display.ht...
Whiteboard:
Keywords: TESTFAILURE
Depends on:
Blocks: perl-testfailure
  Show dependency tree
 
Reported: 2013-06-16 00:21 UTC by Kent Fredric (IRC: kent\n)
Modified: 2013-12-06 10:39 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kent Fredric (IRC: kent\n) gentoo-dev 2013-06-16 00:21:37 UTC
t/11sockopts.t ...................... 1/3 Cannot socket() - Protocol not available at t/11sockopts.t line 30.
# Looks like you planned 3 tests but ran 1.
# Looks like your test exited with 92 just after 1.
t/11sockopts.t ...................... Dubious, test returned 92 (wstat 23552, 0x5c00)
Failed 2/3 subtests 
t/12port-fallback.t ................. ok   


cave info dev-perl/IO-Socket-IP : https://gist.github.com/kentfredric/5790155/raw/119ecf6b82b928c4be891de5dbb27d2b4dfec388/gistfile1.txt 

emerge --info dev-perl/IO-Socket-IP ( may be helpful, but may be incorrect, as this box hasn't used emerge for several years ) https://gist.github.com/kentfredric/5790157/raw/fc3e15c52ffb6153f5b717805e069203e2dd62a1/gistfile1.txt
Comment 1 Alexander Vershilov (RETIRED) gentoo-dev 2013-06-20 05:58:47 UTC
Confirmed, this tests fails because lack of SO_PORTREUSE that is avaliable only in kernel-3.9 [1]. It's possible that test framework incorrectly detects if this option is enabled in current kernel.


[1] https://lwn.net/Articles/542629/
Comment 2 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2013-07-29 20:24:57 UTC
>>> Source compiled.
t/00use.t .................. ok
t/01local-client-v4.t ...... ok
t/02local-server-v4.t ...... ok
t/03local-cross-v4.t ....... ok
t/04local-client-v6.t ...... skipped: Unable to bind to ::1
t/05local-server-v6.t ...... skipped: Unable to bind to ::1
t/06local-cross-v6.t ....... skipped: Unable to bind to ::1
t/10args.t ................. ok
t/11sockopts.t ............. ok
t/12port-fallback.t ........ ok
t/13addrinfo.t ............. ok
t/14fileno.t ............... ok
t/15io-socket.t ............ ok
t/16v6only.t ............... skipped: Unable to bind to ::1
t/17gai-flags.t ............ ok
t/18fdopen.t ............... ok
t/20nonblocking-connect.t .. ok
t/99pod.t .................. ok
All tests successful.
Files=18, Tests=107,  1 wallclock secs ( 0.08 usr  0.02 sys +  1.37 cusr  0.14 csys =  1.61 CPU)
Result: PASS
Comment 3 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2013-12-06 10:39:47 UTC
Fixed in 0.23 according upstream bugreport