Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 473276 - dev-util/cmake-2.8.11.1 - segmentation fault in ld linking cmake during bootstrap
Summary: dev-util/cmake-2.8.11.1 - segmentation fault in ld linking cmake during boots...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: HPPA Linux
: Normal normal (vote)
Assignee: HPPA Porters
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks: 488586
  Show dependency tree
 
Reported: 2013-06-14 15:26 UTC by Jeroen Roovers (RETIRED)
Modified: 2013-11-30 13:56 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
dev-util:cmake-2.8.11.1:20130614-151758.log (20130614-151758.log,397.01 KB, text/plain)
2013-06-14 15:26 UTC, Jeroen Roovers (RETIRED)
Details
HPPA bootstrap patch (cmake-2.8.11.1-hppa.patch,531 bytes, patch)
2013-06-14 16:05 UTC, Jeroen Roovers (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jeroen Roovers (RETIRED) gentoo-dev 2013-06-14 15:26:32 UTC
Created attachment 350944 [details]
dev-util:cmake-2.8.11.1:20130614-151758.log

Fri Jun 14 17:25:58 CEST 2013
emerge --info 
Portage 2.1.12.4 (default/linux/hppa/13.0, gcc-4.6.3, glibc-2.17, 3.8.13-JeR parisc64)
=================================================================
System uname: Linux-3.8.13-JeR-parisc64-PA8800_-Mako-with-gentoo-2.2
KiB Mem:     2050408 total,    370900 free
KiB Swap:    2101676 total,   2101676 free
Timestamp of tree: Fri, 14 Jun 2013 03:15:01 +0000
ld GNU ld (GNU Binutils) 2.22
distcc 3.1 hppa2.0-unknown-linux-gnu [enabled]
ccache version 3.1.9 [disabled]
app-shells/bash:          4.2_p45
dev-lang/python:          2.5.4-r5, 2.6.8-r1, 2.7.3-r3, 3.1.5-r1, 3.2.3-r2
dev-util/ccache:          3.1.9
dev-util/cmake:           2.8.10.2-r2
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6, 1.12.6
sys-devel/binutils:       2.22-r1, 2.23.1
sys-devel/gcc:            4.6.3, 4.7.2-r1, 4.7.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo JeR
ACCEPT_KEYWORDS="hppa"
ACCEPT_LICENSE="* -@EULA"
CBUILD="hppa2.0-unknown-linux-gnu"
CFLAGS="-mschedule=8000 -march=2.0 -ggdb -pipe -Wall -O2 -Wno-comment"
CHOST="hppa2.0-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib/distcc/bin /usr/lib/python2.5/site-packages/buildbot/status/web /usr/lib/python2.6/site-packages/buildbot/status/web /usr/lib/python2.7/site-packages/buildbot/status/web /usr/share/easy-rsa /usr/share/gnupg/qualified.txt /var/bind /var/www/localhost/htdocs/wordpress/wp-config.php"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-mschedule=8000 -march=2.0 -ggdb -pipe -Wall -O2"
DISTDIR="/world/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=n"
FCFLAGS=""
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distcc distlocks ebuild-locks fixlafiles merge-sync metadata-transfer news notitles parallel-fetch preserve-libs protect-owned sfperms splitdebug strict test test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv xattr"
FFLAGS="-mschedule=8000 -march=2.0 -ggdb -pipe -Wall -O2"
GENTOO_MIRRORS="http://de-mirror.org/distro/gentoo/ http://mirror.netcologne.de/gentoo/ http://ftp.snt.utwente.nl/pub/os/linux/gentoo http://gentoo.tiscali.nl/ http://mirror.leaseweb.com/gentoo/ "
LANG="en_GB.utf8"
LC_ALL="C"
LDFLAGS="-Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed"
MAKEOPTS="-j6"
PKGDIR="/keeps/gentoo/packages/karsten"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/world/gentoo/portage"
PORTDIR_OVERLAY="/keeps/gentoo/local"
SYNC="rsync://rsync.nl.gentoo.org/gentoo-portage"
USE="256-color X acl amr apng bash-completion bzip2 canberra cli coverage cracklib crypt cups custom-cflags cxx dirac directfb dri exif fbcon filecaps firefox firmware foomaticdb fortran frontend-optional gdbm geoip glep gpm gsm gstreamer gtk gudev hppa hwdb iconv idn imlib ipv6 jpeg kmod ladspa launch-frontend libcaca libcanberra libwww lua lzo mad mng mod modplug modules mp3 mudflap multislot ncurses netlink nls nptl openmp pam pcre php pkcs11 png pnm python qt quvi readline regression-test rtmp samba session smi speex spell sqlite ssl tcl tcpd test tga theora threads tk truetype unicode v4l vim-syntax vorbis wcwidth xattr xcb xft xml2 xvfb xvid zlib" ALSA_CARDS="ad1889 usb-audio" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="nss" DRACUT_MODULES="nfs syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev joystick keyboard mouse acecad aiptek calcomp citron digitaledge dmc dynapro elo2300 elographics fpit hyperpen jamstudio magellan microtouch mutouch palmax penmount spaceorb summa tek4957 tslib ur98 void" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en nl he" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_5 python2_6 python2_7 python3_1 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="stifb dummy" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.5 2.6 2.7 3.1 3.2"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2013-06-14 16:05:31 UTC
Created attachment 350946 [details, diff]
HPPA bootstrap patch

With this patch the bootstrap phase succeeds. It's not complete, though, since we apparently need to check the compiler and linker version instead.
Comment 2 Rolf Eike Beer archtester 2013-06-17 22:01:58 UTC
Just to have it recorded here, too: I added those lines to the bootstrap file because otherwise bootstrap fails on my machine when running outside of emerge, see http://sourceware.org/bugzilla/show_bug.cgi?id=13168
Comment 3 Rolf Eike Beer archtester 2013-09-12 19:12:28 UTC
I've tried to create a better workaround:

http://cmake.org/gitweb?p=cmake.git;a=commitdiff;h=ca63bb1001dea6929e194ac15921fdeb7d434dcd
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2013-11-13 16:13:02 UTC
Would it be alright to stabilise a newer cmake for bug #488586? 2.8.12 is working fine.
Comment 5 Michael Palimaka (kensington) gentoo-dev 2013-11-13 16:25:59 UTC
(In reply to Jeroen Roovers from comment #4)
> Would it be alright to stabilise a newer cmake for bug #488586? 2.8.12 is
> working fine.

2.8.12 had some regressions, and was replaced with 2.8.12.1 a couple of days ago. Does the current stable still work for HPPA?
Comment 6 Jeroen Roovers (RETIRED) gentoo-dev 2013-11-13 16:42:00 UTC
(In reply to Michael Palimaka (kensington) from comment #5)
(In reply to Jeroen Roovers from comment #4)
> 2.8.12 had some regressions, and was replaced with 2.8.12.1 a couple of days
> ago.

I am testing 2.8.12.1 right now.

> Does the current stable still work for HPPA?

Yes, 2.8.10.2-r2 is good.
Comment 7 Johannes Huber gentoo-dev 2013-11-23 19:27:51 UTC
(In reply to Jeroen Roovers from comment #6)
> (In reply to Michael Palimaka (kensington) from comment #5)
> (In reply to Jeroen Roovers from comment #4)
> > 2.8.12 had some regressions, and was replaced with 2.8.12.1 a couple of days
> > ago.
> 
> I am testing 2.8.12.1 right now.
> 
> > Does the current stable still work for HPPA?
> 
> Yes, 2.8.10.2-r2 is good.

So this can be closed?
Comment 8 Jeroen Roovers (RETIRED) gentoo-dev 2013-11-24 13:48:31 UTC
(In reply to Johannes Huber from comment #7)
> So this can be closed?

Not until we have a newer release marked stable.
Comment 9 Johannes Huber gentoo-dev 2013-11-29 19:33:15 UTC
(In reply to Jeroen Roovers from comment #8)
> Not until we have a newer release marked stable.

2.12.2.1-r1 is not long enough in tree (for such a important package). 

(In reply to Rolf Eike Beer from comment #3)
> I've tried to create a better workaround:
> 
> http://cmake.org/gitweb?p=cmake.git;a=commitdiff;
> h=ca63bb1001dea6929e194ac15921fdeb7d434dcd

What about this to fix the issue?
Comment 10 Jeroen Roovers (RETIRED) gentoo-dev 2013-11-30 13:43:09 UTC
(In reply to Johannes Huber from comment #9)
> (In reply to Rolf Eike Beer from comment #3)
> > I've tried to create a better workaround:
> > 
> > http://cmake.org/gitweb?p=cmake.git;a=commitdiff;
> > h=ca63bb1001dea6929e194ac15921fdeb7d434dcd
> 
> What about this to fix the issue?

Yes, what about it? It's already upstream, it's acknowledged here and nothing has been done. It's a small patch that affects only HPPA. Why isn't it in the tree yet?
Comment 11 Johannes Huber gentoo-dev 2013-11-30 13:56:27 UTC
> Yes, what about it? It's already upstream, it's acknowledged here and
> nothing has been done. It's a small patch that affects only HPPA. Why isn't
> it in the tree yet?

Your wish is my desire. Thanks all. Upstream patch added. Please proceed with bug #488586 after sync.

+  30 Nov 2013; Johannes Huber <johu@gentoo.org>
+  +files/cmake-2.8.11.2-hppa-bootstrap.patch, cmake-2.8.11.2.ebuild:
+  Add upstream patch to fix linking while bootstrap on hppa fixes bug #473276.
+