Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 471816 - =media-video/gnome-mplayer-1.0.7[-dconf] - segmentation fault in g_sequence_iter_get_sequence() from /usr/lib64/libglib-2.0.so.0
Summary: =media-video/gnome-mplayer-1.0.7[-dconf] - segmentation fault in g_sequence_i...
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-30 15:27 UTC by am1
Modified: 2016-02-26 11:20 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge-info.log,4.37 KB, text/x-log)
2013-05-30 15:27 UTC, am1
Details
strace gnome-mplayer (strace_gnome-mplayer.zip,336.62 KB, application/zip)
2013-05-30 15:30 UTC, am1
Details
gdb backtrace (gdb_backtrace-gnome-mplayer.log,3.27 KB, text/x-log)
2013-05-31 15:08 UTC, am1
Details
gdb backtrace (gdb_backtrace-gnome-mplayer.log,2.98 KB, text/x-log)
2013-05-31 15:31 UTC, am1
Details
gdb gnome-mplayer (gdb_backtrace-gnome-mplayer.log,17.94 KB, text/x-log)
2013-06-12 09:04 UTC, am1
Details

Note You need to log in before you can comment on or make changes to this bug.
Description am1 2013-05-30 15:27:02 UTC
Each time i want to play videos (doesn't matter which codec is used) the gnome-mplayer crashs. Playing with mplayer2 directly it works each time - each. gnome-mplayer crashs with "Segmentation fault". Its always the default config, i only select "mplayer2" as executable-bin.

What do you need aswell?

Reproducible: Always

Steps to Reproduce:
1. Remove default config in ~/.config/gnome-mplayer/gnome-mplayer.conf
2. Start gnome-mplayer
3. Switch to mplayer-tab to select mplayer2
4. Play a video
Actual Results:  
Crashs with "Segmentation fault"

Expected Results:  
Play the video?

media-video/gnome-mplayer-1.0.7 (use: alsa dbus libnotify)
media-video/mplayer2-2.0_p20120828 (use: X alsa dts enca iconv ipv6 jpeg kernel_linux libass mmx mmxext mp3 opengl png quicktime rtc shm sse sse2 ssse3 truetype unicode xv xvid)

kernel: 3.9.4-gentoo
cpu: i7-3520m
ram: 16gb
vga: intel hd 4000
Comment 1 am1 2013-05-30 15:27:49 UTC
Created attachment 349662 [details]
emerge --info
Comment 2 am1 2013-05-30 15:30:09 UTC
Created attachment 349664 [details]
strace gnome-mplayer
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2013-05-31 14:09:26 UTC
Comment on attachment 349664 [details]
strace gnome-mplayer

Please attach a gdb backtrace.
Comment 4 am1 2013-05-31 15:00:45 UTC
(In reply to Jeroen Roovers from comment #3)

Ok how? I emerged "gdb" from portage with default flags. What do you need especially?

Second, what do you mean with "... in ?" in headline.

Ty for reply.
Comment 5 am1 2013-05-31 15:08:21 UTC
Created attachment 349730 [details]
gdb backtrace
Comment 6 Jeroen Roovers (RETIRED) gentoo-dev 2013-05-31 15:26:52 UTC
Comment on attachment 349730 [details]
gdb backtrace

http://www.gentoo.org/proj/en/qa/backtraces.xml

Great. Now do the same and then run something like 'thread apply all backtrace full' on the gdb command line.
Comment 7 am1 2013-05-31 15:31:05 UTC
Created attachment 349740 [details]
gdb backtrace

Ty ;-)

> gdb gnome-mplayer | tee gdb_backtrace-gnome-mplayer.log
> thread apply all backtrace full
> run
Comment 8 am1 2013-06-03 21:29:57 UTC
I found out, that i have this issue only, when using gnome-mplayer WITHOUT use-flag "dconf". I reenabled this, now it works.

1.0.8 too.
Comment 9 Jeroen Roovers (RETIRED) gentoo-dev 2013-06-05 13:09:48 UTC
Comment on attachment 349740 [details]
gdb backtrace

(In reply to seves985 from comment #7)
> Created attachment 349740 [details]
> gdb backtrace
> 
> Ty ;-)
> 
> > gdb gnome-mplayer | tee gdb_backtrace-gnome-mplayer.log
> > thread apply all backtrace full
> > run

No, in this order, please:

1) gdb gnome-mplayer
2) run
3) thread apply all backtrace full
Comment 10 am1 2013-06-12 09:04:40 UTC
Created attachment 350818 [details]
gdb gnome-mplayer

Sorry bro, i missed some time for this, because my vacation are starting this week.

Here is the output for you, btw: same happens with gnome-mplayer-1.0.8 for me. Enabling "dconf"-Useflag solves the problem...

Let me know if you need some more... :)
Comment 11 Samuli Suominen (RETIRED) gentoo-dev 2014-05-28 19:21:30 UTC
Try 1.0.9, in Portage as of today, 1.0.7 no longer in tree