Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 471368 - dev-libs/folks-0.9.1 USE="telepathy -vala" depends on USE=zeitgeist
Summary: dev-libs/folks-0.9.1 USE="telepathy -vala" depends on USE=zeitgeist
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
Depends on:
Blocks: gnome-3.8
  Show dependency tree
Reported: 2013-05-26 22:53 UTC by crabbed halo ablution
Modified: 2013-08-09 11:44 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

build log (folks-0.9.1:20130526-220930.log,173.17 KB, text/plain)
2013-05-27 17:51 UTC, crabbed halo ablution
My build.log ending ok (folks-0.9.1:20130527-202640.log,419.37 KB, text/plain)
2013-05-27 20:29 UTC, Pacho Ramos

Note You need to log in before you can comment on or make changes to this bug.
Description crabbed halo ablution 2013-05-26 22:53:53 UTC
See also upstream commit:

Results if compiling with USE="telepathy -zeitgeist":

tpf-persona-store.c:34:23: fatal error: zeitgeist.h: No such file or directory
compilation terminated.
tpf-persona.c:34:23: fatal error: zeitgeist.h: No such file or directory
compilation terminated.

Since all the zeitgeist use-flag does (according to configure --help) is build zeitgeist support into the telepathy backend, it seems to me that it doesn't make much sense to have a separate zeitgeist use flag, unless some hacking can be done so the telepathy backend can build without zeitgeist support, so I propose just merging the two flags into USE="telepathy"
Comment 1 Pacho Ramos gentoo-dev 2013-05-27 06:48:25 UTC
But we are now applying upstream patches to allow telepathy support without zeitgeist, doesn't it work? (probably I didn't notice build failure because, even if I tried disabling its support, zeitgeist was still present on my system):
Comment 2 crabbed halo ablution 2013-05-27 17:51:58 UTC
Created attachment 349372 [details]
build log

Nope, the patches do nothing. As you can see, they were applied during the build.
Comment 3 Pacho Ramos gentoo-dev 2013-05-27 20:28:04 UTC
Strange, I have removed all zeitgeist and still compiles ok for me :|
Comment 4 Pacho Ramos gentoo-dev 2013-05-27 20:29:59 UTC
Created attachment 349392 [details]
My build.log ending ok
Comment 5 Pacho Ramos gentoo-dev 2013-05-27 20:32:44 UTC
It occurs when vala is also disabled :O
Comment 6 Pacho Ramos gentoo-dev 2013-08-09 08:32:16 UTC
+  09 Aug 2013; Pacho Ramos <>
+  -files/folks-0.9.1-automagic-fix1.patch,
+  -files/folks-0.9.1-automagic-fix2.patch,
+  -files/folks-0.9.1-automagic-fix3.patch, -folks-0.9.1.ebuild,
+  -folks-0.9.2.ebuild, folks-0.9.3.ebuild:
+  Fix vala/zeitgeist compilation problems (#471368 by Peter Alfredsen, #479600
+  by Juergen Rose and Marien Zwart, #479758 by Fabio Coatti), drop old.
Comment 7 redneb 2013-08-09 11:38:13 UTC
This change now causes the following problem: gnome-extra/gnome-contacts-3.8.3 depends on dev-libs/folks[vala], but dev-libs/folks doesn't have the vala USE flag anymore.
Comment 8 Pacho Ramos gentoo-dev 2013-08-09 11:44:15 UTC
Just solved, syncing in some minutes should help. Thanks!