Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 47105 - portage troubles NoneType' object has no attribute 'match'
Summary: portage troubles NoneType' object has no attribute 'match'
Status: RESOLVED DUPLICATE of bug 47063
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Unclassified (show other bugs)
Hardware: All Linux
: High blocker (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
: 47064 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-04-07 08:20 UTC by Hans-Christian Armingeon
Modified: 2005-07-17 13:06 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hans-Christian Armingeon 2004-04-07 08:20:53 UTC
My Portage Tree is currently broken. Which directories can I delete to fix the issue? I deleted /usr/portage and /var/cache/edb/, but it didn't help.

Johnny

# emerge -uDp world
Traceback (most recent call last):
  File "/usr/bin/emerge", line 14, in ?
    import portage
  File "/usr/lib/portage/pym/portage.py", line 6128, in ?
    settings.regenerate() # XXX: Regenerate use after we get a vartree -- GLOBAL
  File "/usr/lib/portage/pym/portage.py", line 1392, in regenerate
    self.configdict["auto"]["USE"]=autouse(db[root]["vartree"],use_cache=use_cache)
  File "/usr/lib/portage/pym/portage.py", line 1121, in autouse
    myresult=dep_check(mydep,myvartree.dbapi,None,use="no",use_cache=use_cache)
  File "/usr/lib/portage/pym/portage.py", line 3309, in dep_check
    mylist=flatten(dep_listcleanup(dep_zapdeps(mysplit,mysplit2)))
  File "/usr/lib/portage/pym/portage.py", line 3052, in dep_zapdeps
    myresult=dep_zapdeps(unreduced[x],reduced[x])
  File "/usr/lib/portage/pym/portage.py", line 3038, in dep_zapdeps
    elif myportapi.match(x):
AttributeError: 'NoneType' object has no attribute 'match'

# emerge info
Traceback (most recent call last):
  File "/usr/bin/emerge", line 14, in ?
    import portage
  File "/usr/lib/portage/pym/portage.py", line 6128, in ?
    settings.regenerate() # XXX: Regenerate use after we get a vartree -- GLOBAL
  File "/usr/lib/portage/pym/portage.py", line 1392, in regenerate
    self.configdict["auto"]["USE"]=autouse(db[root]["vartree"],use_cache=use_cache)
  File "/usr/lib/portage/pym/portage.py", line 1121, in autouse
    myresult=dep_check(mydep,myvartree.dbapi,None,use="no",use_cache=use_cache)
  File "/usr/lib/portage/pym/portage.py", line 3309, in dep_check
    mylist=flatten(dep_listcleanup(dep_zapdeps(mysplit,mysplit2)))
  File "/usr/lib/portage/pym/portage.py", line 3052, in dep_zapdeps
    myresult=dep_zapdeps(unreduced[x],reduced[x])
  File "/usr/lib/portage/pym/portage.py", line 3038, in dep_zapdeps
    elif myportapi.match(x):
AttributeError: 'NoneType' object has no attribute 'match'

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Haldir 2004-04-07 08:29:26 UTC
I second that bug, happened here with the latest portage from unstable and after emerge sync
Comment 2 Radek Podgorny 2004-04-07 08:47:22 UTC
Me to... :-(

Could it be caused by me when I interrupted the "regenerating portage cache" last time?
Comment 3 Georg Müller 2004-04-07 08:50:26 UTC
here a quickfix:

goto line 3038 of /usr/lib/portage/pym/portage.py:
and change to this:

elif myportapi and myportapi.match(x):
Comment 4 petre rodan (RETIRED) gentoo-dev 2004-04-07 09:20:56 UTC
see http://bugs.gentoo.org/show_bug.cgi?id=47063
Comment 5 Nicholas Jones (RETIRED) gentoo-dev 2004-04-07 09:57:15 UTC
*** Bug 47064 has been marked as a duplicate of this bug. ***
Comment 6 Nicholas Jones (RETIRED) gentoo-dev 2004-04-07 10:01:04 UTC

*** This bug has been marked as a duplicate of 47063 ***