Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 470902 - x11-libs/xpyb: enable multiple python support
Summary: x11-libs/xpyb: enable multiple python support
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
: 486612 (view as bug list)
Depends on: 470900
Blocks:
  Show dependency tree
 
Reported: 2013-05-21 18:52 UTC by Maxim Koltsov
Modified: 2017-03-04 19:08 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
xpyb-1.3.1-r2.ebuild (xpyb-1.3.1-r2.ebuild,1.07 KB, text/plain)
2013-05-21 18:53 UTC, Maxim Koltsov
Details
files/xpyb-python.patch (xpyb-python.patch,551 bytes, patch)
2013-05-21 18:54 UTC, Maxim Koltsov
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Maxim Koltsov gentoo-dev 2013-05-21 18:52:31 UTC
Please review attached ebuild (xpyb-1.3.1-r2) and commit it or let me do it. This is needed to correct x11-wm/qtile depends.

Reproducible: Always
Comment 1 Maxim Koltsov gentoo-dev 2013-05-21 18:53:32 UTC
Created attachment 348846 [details]
xpyb-1.3.1-r2.ebuild
Comment 2 Maxim Koltsov gentoo-dev 2013-05-21 18:54:00 UTC
Created attachment 348848 [details, diff]
files/xpyb-python.patch
Comment 3 Maxim Koltsov gentoo-dev 2013-05-22 09:17:44 UTC
Commited per radhermit and lu_zero permission on IRC.
Comment 4 Rémi Cardona gentoo-dev 2013-10-02 17:55:03 UTC
@maksbotan, your ebuild dropped python 3.2 support. Was that intended?

Cheers
Comment 5 Maxim Koltsov gentoo-dev 2013-10-02 18:38:01 UTC
(In reply to Rémi Cardona from comment #4)
> @maksbotan, your ebuild dropped python 3.2 support. Was that intended?
> 
> Cheers

Looks like it was my fault. You are free to change it if you like to.
Comment 6 Maxim Koltsov gentoo-dev 2013-10-02 18:42:52 UTC
(In reply to Maxim Koltsov from comment #5)
> (In reply to Rémi Cardona from comment #4)
> > @maksbotan, your ebuild dropped python 3.2 support. Was that intended?
> > 
> > Cheers
> 
> Looks like it was my fault. You are free to change it if you like to.

I re-checked it and found that it doesn't build with 3.*.
But you still are free to fix that ;)
Comment 7 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2013-11-09 09:05:14 UTC
Please remember to sync your changes in -9999::x11.

I've ported that to -9999 but without the patch since xcb-proto-9999::x11 is already free of that stupid 'pythondir'.

The current git doesn't build for me but I suspect it's problem with the git and not my ebuild. I may be wrong.
Comment 8 Matt Turner gentoo-dev 2015-02-23 01:45:11 UTC
*** Bug 486612 has been marked as a duplicate of this bug. ***
Comment 9 Matt Turner gentoo-dev 2017-03-04 19:08:52 UTC
The package does not support python3 upstream. That would have to be fixed first. xpyb looks to be completely abandoned upstream...

Honestly though... it's used only by pycairo, which itself is completely abandoned. Unfortunately a lot of things actually do depend on it.