Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 470878 - install-amd64-minimal-20130516.iso: doesn't boot from usb
Summary: install-amd64-minimal-20130516.iso: doesn't boot from usb
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: InstallCD (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Release Team
URL: http://distfiles.gentoo.org/releases/...
Whiteboard:
Keywords:
: 472952 (view as bug list)
Depends on: 458606
Blocks:
  Show dependency tree
 
Reported: 2013-05-21 14:06 UTC by kik1n
Modified: 2013-09-11 17:32 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kik1n 2013-05-21 14:06:29 UTC
Greetings.
Well trying to use the new image of gentoo, which is install-amd64-minimal-20130516.iso. I do not recognize anything.
At the beginning where you can choose the kernel if it recognizes the keyboard, but I press enter, load and choose the keymap does not detect the keyboard, and load rules.
Please specify another value or: Press Enter for the same, type "shell" for a shell, or "q" to skip ...

In contrast with the install-amd64-minimal-20130509.iso not happened to me, detects the keyboard and ready to install gentoo.

Do not know if it is bug.
But it is annoying that I pass the following isos equal.

Greetings.
Comment 1 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2013-05-21 14:56:11 UTC
Please paste the "complete" and "exact" error message.
Comment 2 kik1n 2013-05-21 15:40:31 UTC
(In reply to comment #1)
> Please paste the "complete" and "exact" error message.

This is.

"Please specify another value or: Press Enter for the same, type "shell" for a shell, or "q" to skip ..."
Comment 3 Ben Kohler gentoo-dev 2013-05-21 17:12:54 UTC
Are you attempting to boot this from CD, or USB?  This is the first release with isohybrid run on it, so it SHOULD be usb-ready, but bug #458606	is breaking USB functionality in the initramfs (until later when udev starts).  So that affects your USB keyboard, AND the mounting of the usb storage.

Or it could be something else entirely, if you are indeed booting straight from CD.
Comment 4 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2013-05-21 17:17:05 UTC
I just tried the ISO on my ganeti server and it boots fine.
Comment 5 kik1n 2013-05-21 19:50:56 UTC
(In reply to comment #3)
> Are you attempting to boot this from CD, or USB?  This is the first release
> with isohybrid run on it, so it SHOULD be usb-ready, but bug #458606	is
> breaking USB functionality in the initramfs (until later when udev starts). 
> So that affects your USB keyboard, AND the mounting of the usb storage.
> 
> Or it could be something else entirely, if you are indeed booting straight
> from CD.

Both(In reply to comment #3)
> Are you attempting to boot this from CD, or USB?  This is the first release
> with isohybrid run on it, so it SHOULD be usb-ready, but bug #458606	is
> breaking USB functionality in the initramfs (until later when udev starts). 
> So that affects your USB keyboard, AND the mounting of the usb storage.
> 
> Or it could be something else entirely, if you are indeed booting straight
> from CD.

Ahhh, ok.
Well, but this bug is going to fix, I mean, in the next installment, work as in previous versions.

Excuse me, in the previous version everything ran great without any problems.

Thank you very much for answering, greetings: D

I'm booting from the CD and runs excellent, while USB no.
Comment 6 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2013-05-21 20:36:00 UTC
In that case, let's keep this open as there's a bug that needs to be fixed.
Comment 7 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2013-06-01 00:40:00 UTC
There were some recent changes to genkernel that changed handling of slowusb and cdroot, could you please accurately trace the last version that worked?

http://git.overlays.gentoo.org/gitweb/?p=proj/genkernel.git;a=commit;h=ffa5076fd4681e6b65968b826b84a66fabcd75f6
Comment 8 Ben Kohler gentoo-dev 2013-06-01 01:25:15 UTC
This bug was brought on by the move to a 3.8 kernel where ehci-pci is split out into its own module, not the recent slowusb changes.  I have confirmed that gentoo.igz is missing ehci-pci, so no amount of waiting will bring up ehci-pci controllers.

These CD's are all being built with genkernel-3.4.45, we're gonna need a new release or at least a patched genkernel modules_load file to fix this.
Comment 9 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2013-06-11 11:27:55 UTC
*** Bug 472952 has been marked as a duplicate of this bug. ***
Comment 10 Ben Kohler gentoo-dev 2013-09-11 17:32:22 UTC
We have had several releases on x86 and amd64 now since this was fixed, closing.