Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 470066 - app-text/djvu : does not respect AR
Summary: app-text/djvu : does not respect AR
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal QA (vote)
Assignee: TeX project
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2013-05-16 12:14 UTC by Agostino Sarubbo
Modified: 2020-06-25 22:26 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
djvu-3.5.25.3.patch (djvu-3.5.25.3.patch,60 bytes, patch)
2013-05-22 19:26 UTC, Michael Mair-Keimberger (iamnr3)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2013-05-16 12:14:59 UTC
You receive this bug because this package does not respect my system's AR (x86_64-pc-linux-gnu-ar) and calls directly /usr/bin/ar
The possible solutions to fix this issue are:
1)Fix the buildsystem, if you can;
2)inherit toolchain-funcs and use tc-export AR
3)inherit toolchain-funcs and use emake AR="$(tc-getAR)"


From the build log:

/usr/bin/ar cr libjb2cmp.a classify.o cuts.o frames.o patterns.o
Comment 1 Michael Mair-Keimberger (iamnr3) 2013-05-22 19:26:10 UTC
Created attachment 348940 [details, diff]
djvu-3.5.25.3.patch

This simple patch should fix the issue. please review.
Comment 2 Jonas Stein gentoo-dev 2019-01-07 23:13:07 UTC
Agostino, does the patch solve your issue?
Comment 3 John Helmert III (ajak) gentoo-dev Security 2020-06-25 22:08:27 UTC
I can't reproduce after moving /usr/bin/ar away from that path and compiling djvu-3.5.27-r2. Makefile has 'AR = x86_64-pc-linux-gnu-ar'.
Comment 4 Sam James archtester gentoo-dev Security 2020-06-25 22:26:12 UTC
(In reply to John Helmert III (ajak) from comment #3)
> I can't reproduce after moving /usr/bin/ar away from that path and compiling
> djvu-3.5.27-r2. Makefile has 'AR = x86_64-pc-linux-gnu-ar'.

closing