Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 469708 - =sys-apps/hwloc-1.7 - Version bump.
Summary: =sys-apps/hwloc-1.7 - Version bump.
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Kacper Kowalik (Xarthisius) (RETIRED)
URL: http://www.open-mpi.org/community/lis...
Whiteboard:
Keywords: PATCH
Depends on:
Blocks:
 
Reported: 2013-05-13 17:48 UTC by Mario Kicherer
Modified: 2013-08-09 09:03 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
hwloc.ebuild.patch (hwloc.patch,1.19 KB, patch)
2013-05-13 17:49 UTC, Mario Kicherer
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mario Kicherer 2013-05-13 17:48:57 UTC
hwloc-1.7 has been released. The ebuild for 1.6.2 works for me but 1.7 contains new features like OpenCL device discovery. I attach the ebuild patch. Hwloc has a opencl configure flag but it depends on AMD's OpenCL library therefore I did not call the use flag "opencl" but "amd" as it might create confusion on non-AMD systems. Same goes for the "gl" flag that depends on nvidia-settings - according to the docs, I did not test.

Reproducible: Always
Comment 1 Mario Kicherer 2013-05-13 17:49:30 UTC
Created attachment 348180 [details, diff]
hwloc.ebuild.patch
Comment 2 Kacper Kowalik (Xarthisius) (RETIRED) gentoo-dev 2013-05-20 17:53:46 UTC
(In reply to comment #0)
> hwloc-1.7 has been released. The ebuild for 1.6.2 works for me but 1.7
> contains new features like OpenCL device discovery. I attach the ebuild
> patch. Hwloc has a opencl configure flag but it depends on AMD's OpenCL
> library therefore I did not call the use flag "opencl" but "amd" as it might
> create confusion on non-AMD systems. Same goes for the "gl" flag that
> depends on nvidia-settings - according to the docs, I did not test.

Sorry I takes so long, I'm a bit swamped at work I haven't had time look closely at changes in 1.7.x. I'll try to do it this week
Comment 3 Kacper Kowalik (Xarthisius) (RETIRED) gentoo-dev 2013-08-09 09:03:47 UTC
+*hwloc-1.7.1 (09 Aug 2013)
+
+  09 Aug 2013; Kacper Kowalik <xarthisius@gentoo.org> +hwloc-1.7.1.ebuild,
+  metadata.xml:
+  Version bump wrt #469708 by Mario Kicherer <dev@kicherer.org>