Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 469476 - =net-dialup/pptpd-1.3.4-r2: configure.in:3: error: 'AM_CONFIG_HEADER': this macro is obsolete.
Summary: =net-dialup/pptpd-1.3.4-r2: configure.in:3: error: 'AM_CONFIG_HEADER': this m...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Dialup Developers
URL: https://sourceforge.net/p/poptop/patc...
Whiteboard:
Keywords: UPSTREAM
Depends on:
Blocks: automake-1.13
  Show dependency tree
 
Reported: 2013-05-11 17:57 UTC by Kobboi
Modified: 2013-06-18 05:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kobboi 2013-05-11 17:57:09 UTC
# cat /var/tmp/portage/net-dialup/pptpd-1.3.4-r2/temp/aclocal.out
***** aclocal *****
***** PWD: /var/tmp/portage/net-dialup/pptpd-1.3.4-r2/work/pptpd-1.3.4
***** aclocal

aclocal-1.13: warning: autoconf input should be named 'configure.ac', not 'configure.in'
configure.in:3: error: 'AM_CONFIG_HEADER': this macro is obsolete.
    You should use the 'AC_CONFIG_HEADERS' macro instead.
/usr/share/aclocal-1.13/obsolete-err.m4:12: AM_CONFIG_HEADER is expanded from...
configure.in:3: the top level
autom4te-2.69: /usr/bin/m4 failed with exit status: 1
aclocal-1.13: error: echo failed with exit status: 1

Reproducible: Always
Comment 1 Sergey Popov gentoo-dev Security 2013-05-15 10:55:34 UTC
+  15 May 2013; Sergey Popov <pinkbyte@gentoo.org> +pptpd-1.3.4-r3.ebuild,
+  +files/pptpd-1.3.4-sandbox-fix.patch:
+  Revision bump: Add epatch_user, add patch to prevent sandbox violations, use
+  default 'emake install' instead of einstall, add compatibility with Automake
+  1.13, wrt bug #469476

Please test. If everything goes right, i will turn this bug into stabilization request for new revision...
Comment 2 Sergey Popov gentoo-dev Security 2013-05-15 11:03:31 UTC
Also, reported upstream
Comment 3 Sergey Popov gentoo-dev Security 2013-06-18 05:06:53 UTC
Stabilization request has been filed, see bug #473654

So, closing this as FIXED