Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 469388 - app-crypt/gnupg-1.4.13 - gpg: keyblock resource `[...]/homedir/.gnupg/secring.gpg': file open error
Summary: app-crypt/gnupg-1.4.13 - gpg: keyblock resource `[...]/homedir/.gnupg/secring...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Crypto team [DISABLED]
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-11 09:32 UTC by Lukas Durdak
Modified: 2013-05-13 19:37 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log of app-crypt/gnupg-1.4.13 (build.log,59.51 KB, text/plain)
2013-05-11 16:24 UTC, Lukas Durdak
Details
build.log of app-crypt/gnupg-1.4.13 with MAKEOPTS=-j1 (build.log,58.68 KB, text/plain)
2013-05-12 07:12 UTC, Lukas Durdak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Durdak 2013-05-11 09:32:19 UTC
seems that build fails because requested files are located in /var/tmp/portage/app-crypt/gnupg-1.4.13/work/gnupg-1.4.13/checks/ instead of location requested by ebuild process:
...
gpg: keyblock resource `/var/tmp/portage/app-crypt/gnupg-1.4.13/homedir/.gnupg/secring.gpg': file open error
gpg: keyblock resource `/var/tmp/portage/app-crypt/gnupg-1.4.13/homedir/.gnupg/pubring.gpg': file open error
gpg: keyblock resource `/var/tmp/portage/app-crypt/gnupg-1.4.13/homedir/.gnupg/secring.gpg': file open error
gpg: keyblock resource `/var/tmp/portage/app-crypt/gnupg-1.4.13/homedir/.gnupg/pubring.gpg': file open error
make[2]: *** [secring.gpg] Error 2
make[2]: *** Waiting for unfinished jobs....
make[2]: *** [pubring.gpg] Error 2
gpg: keyblock resource `/var/tmp/portage/app-crypt/gnupg-1.4.13/homedir/.gnupg/secring.gpg': file open error
gpg: keyblock resource `/var/tmp/portage/app-crypt/gnupg-1.4.13/homedir/.gnupg/pubring.gpg': file open error

same issue with gnupg-1.4.13-r1, tested only on amd64 platform


Reproducible: Always

Steps to Reproduce:
emerge -av =app-crypt/gnupg-1.4.13



# emerge --info '=app-crypt/gnupg-1.4.13'
Portage 2.1.11.62 (hardened/linux/amd64/selinux, gcc-4.6.3, glibc-2.15-r3, 3.4.3-pf x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.4.3-pf-x86_64-Intel-R-_Core-TM-2_Duo_CPU_P9400_@_2.40GHz-with-gentoo-2.1
KiB Mem:     4004792 total,   1972752 free
KiB Swap:    4194300 total,   4194228 free
Timestamp of tree: Sat, 11 May 2013 08:15:01 +0000
ld GNU ld (GNU Binutils) 2.22
ccache version 3.1.8 [disabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.10
dev-lang/python:          2.7.2-r3, 3.1.3-r1
dev-util/ccache:          3.1.8
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.5
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.1, 1.12.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r1, 4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.2.10
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.4-r2 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo smithdanea mv x-portage x-theebuilds x-localbuild
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe -msse4.1"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -O2 -pipe -msse4.1"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch protect-owned sandbox selinux sesandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.fi.muni.cz/pub/linux/gentoo/ http://gentoo.wheel.sk/ http://gentoo.mneisen.org/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/smithdanea /var/lib/layman/mv /usr/local/portage /var/lib/layman/theebuilds /var/lib/layman/localbuild"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X acl acpi alsa amd64 bash-completion berkdb bzip2 cli cracklib crypt cxx dbus device-mapper djvu dri dvd exif ffmpeg gdbm gif gpm gsm gstreamer gtk gtkstyle hardened iconv idn ipv6 jbig jit jpeg jpeg2k justify libnotify lzma lzo mmx mng modules mp3 mudflap multilib ncurses nls nptl odf open_perms opengl openmp pam pax_kernel pcre pdf png python readline rle selinux session smp spell sse sse2 sse3 sse4 sse4_1 ssl ssse3 svg tcpd tiff truetype udev unicode urandom utf8 vaapi vdpau webgl webkit webp xattr xinerama xml xpm zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="canon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DVB_CARDS="it9135 usb-dib0700" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard evdev mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en cs" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_1" QEMU_USER_TARGETS="arm armeb i386 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XFCE_PLUGINS="menu trash brightness" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

# emerge -pqv '=app-crypt/gnupg-1.4.13'
[ebuild     UD] app-crypt/gnupg-1.4.13 [2.0.17] USE="bzip2 curl%* nls readline%* (selinux) usb%* zlib%* -ldap -smartcard -static (-adns%) (-caps%) (-doc%) (-openct%) (-pcsc-lite%)" LINGUAS="-ru%"
Comment 1 Jeroen Roovers gentoo-dev 2013-05-11 15:59:18 UTC
Please attach the entire build log to this bug report.
Comment 2 Lukas Durdak 2013-05-11 16:24:32 UTC
Created attachment 347988 [details]
build.log of app-crypt/gnupg-1.4.13
Comment 3 Alon Bar-Lev gentoo-dev 2013-05-11 17:34:35 UTC
I cannot reproduce.
Please attach build log with MAKEOPTS="-j1"

Thanks!
Comment 4 Lukas Durdak 2013-05-12 07:12:02 UTC
Created attachment 348046 [details]
build.log of app-crypt/gnupg-1.4.13 with MAKEOPTS=-j1

built with MAKEOPTS=-j1, still same.
Comment 5 Alon Bar-Lev gentoo-dev 2013-05-12 15:00:14 UTC
the -j1 was requested so I can see clearly what is happening.

I still cannot reproduce.

Can you please try to add in src_prepare() phase of the ebuild?
---
    sed -i 's/--batch --dearmor/--homedir . --batch --dearmor/' checks/Makefile || die
---

Thanks!
Comment 6 Lukas Durdak 2013-05-12 19:12:13 UTC
with patched ebuild it emerges just fine. Thanks!

###
--- gnupg-1.4.13-r1.ebuild	2013-01-19 21:12:23.000000000 +0100
+++ gnupg-1.4.13-r2.ebuild	2013-05-12 20:59:44.159841602 +0200
@@ -49,6 +49,9 @@
 		|| die "sed PIC failed"
 	sed -i -e 's:if PIC:ifdef __PIC__:' mpi/sparc32v8/mpih-mul{1,2}.S || \
 		die "sed PIC failed"
+
+	sed -i -e 's/--batch --dearmor/--homedir . --batch --dearmor/' checks/Makefile.* || \
+		die "sed DEARMOR failed"
 }
 
 src_configure() {
###
Comment 7 Alon Bar-Lev gentoo-dev 2013-05-13 19:29:50 UTC
Fixed in gnupg-1.4.13-r1.
Thanks!
Comment 8 Alon Bar-Lev gentoo-dev 2013-05-13 19:37:46 UTC
https://bugs.g10code.com/gnupg/issue1498