Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 469040 - app-office/dia-0.97.2-r1 segmentation fault
Summary: app-office/dia-0.97.2-r1 segmentation fault
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: GNOME Office (OBSOLETE)
: 485124 (view as bug list)
Depends on:
Reported: 2013-05-08 12:24 UTC by Andreas Proteus
Modified: 2013-09-22 11:22 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---

Output of emerge --info (emrge-info,5.77 KB, text/plain)
2013-05-08 12:24 UTC, Andreas Proteus

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Proteus 2013-05-08 12:24:28 UTC
Created attachment 347744 [details]
Output of emerge --info

Crashes with these messages:
sys:1: Warning: attempting to add an interface (DiaInteractiveRendererInterface) to class (DiaGdkRenderer) after class_init
** (dia:747): CRITICAL **: dia_renderer_set_size: assertion `irenderer != NULL' failed
** (dia:747): CRITICAL **: dia_renderer_set_size: assertion `irenderer != NULL' failed
Segmentation fault

equery u dia

 * Found these USE flags for app-office/dia-0.97.2-r1:
 U I
 - - cairo  : Enable support for the cairo graphics library
 - - debug  : Enable extra debug codepaths, like asserts and extra output. If you want to get meaningful backtraces see
 - - doc    : Adds extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally
 - - gnome  : Adds GNOME support
 + + python : Adds optional support/bindings for the Python language
Comment 1 Andreas Proteus 2013-05-08 12:59:51 UTC
Additional ifo.

dia --nonew 
starts the application.
If I then attempt to open a file or create a new one
it sigfaults as above.
Comment 2 Mark R. Pariente 2013-05-27 10:57:20 UTC
Looks like its:

Workaround suggested in bug worked for me. Edit ~/.dia/persistence to make view_antialiased true instead of false:

  <dia:boolean role="view_antialised">
    <dia:attribute name="booleanvalue">
-     <dia:boolean val="false"/>
+     <dia:boolean val="true"/>

A fix was pushed on the development branch of dia but not backported to 0.97 branch:

Gentoo maintainers could perhaps consider pulling this patch to 0.97.2, since this pretty much affects everyone using recent glib versions.
Comment 3 Karl Lindén 2013-08-04 16:19:53 UTC
I can confirm this bug. I can also add that the workaround worked for me.

$ gdb dia
GNU gdb (Gentoo 7.6 p1) 7.6
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
For bug reporting instructions, please see:
Reading symbols from /usr/bin/dia...Reading symbols from /usr/lib64/debug/usr/bin/dia.debug...done.
(gdb) run
Starting program: /usr/bin/dia 
warning: Could not load shared library symbols for
Do you need "set solib-search-path" or "set sysroot"?
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/".
[New Thread 0x7fffd9bc0700 (LWP 6347)]

(dia:6063): GLib-GObject-WARNING **: attempting to add an interface (DiaInteractiveRendererInterface) to class (DiaGdkRenderer) after class_init

** (dia:6063): CRITICAL **: dia_renderer_set_size: assertion `irenderer != NULL' failed

** (dia:6063): CRITICAL **: dia_renderer_set_size: assertion `irenderer != NULL' failed

Program received signal SIGSEGV, Segmentation fault.
ddisplay_update_handler (ddisp=0xa9a0e0) at display.c:566
566	    g_return_val_if_fail (   renderer->clip_region_clear != NULL
(gdb) bt
#0  ddisplay_update_handler (ddisp=0xa9a0e0) at display.c:566
#1  0x00007ffff67ccdf4 in g_main_context_dispatch () from /usr/lib64/
#2  0x00007ffff67cd164 in ?? () from /usr/lib64/
#3  0x00007ffff67cd5d2 in g_main_loop_run () from /usr/lib64/
#4  0x00007ffff78486ef in gtk_main () from /usr/lib64/
#5  0x000000000041e845 in main (argc=<optimized out>, argv=<optimized out>) at main.c:35
(gdb) c
[Thread 0x7fffd9bc0700 (LWP 6347) exited]

Program terminated with signal SIGSEGV, Segmentation fault.
The program no longer exists.
(gdb) q

$ emerge --info app-office/dia
Portage (default/linux/amd64/13.0/desktop, gcc-4.7.3, glibc-2.17, 3.10.4-gentoo x86_64)
                         System Settings
System uname: Linux-3.10.4-gentoo-x86_64-AMD_Athlon-tm-_II_X4_640_Processor-with-gentoo-2.2
KiB Mem:     8180800 total,   5082560 free
KiB Swap:    2097148 total,   2097148 free
Timestamp of tree: Tue, 30 Jul 2013 15:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.5-r1, 3.3.2-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.13.4, 1.14
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.7.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo science proaudio x-local lilrc
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=amdfam10 -O2 -fomit-frame-pointer -pipe"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=amdfam10 -O2 -fomit-frame-pointer -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS=" rsync://"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/home/kalle/overlays/science /home/kalle/overlays/proaudio /home/kalle/overlays/local /home/kalle/overlays/lilrc"
USE="3dnow 3dnowext X a52 aac acl amd64 aspell avahi bluetooth cairo caps cd cdda cddb cdr consolekit cracklib cups curl dbus devhelp dssi dvd dvdr exif ffmpeg fftw filecaps flac fltk gallium gif gimp git glib gmp gnutls gstreamer gtk gtk2 gtkspell gtkstyle gudev hwdb jack javascript jit joystick jpeg keymap kmod ladspa lame libgig libnotify libsamplerate lv2 mad mmx mmxext mp3 mpeg multilib nls nptl ogg opengl openmp openrc orc pam pdf png policykit pulseaudio qt4 readline spell sse sse2 sse3 sse4_1 ssl startup-notification svg svn theora threads thunar tiff truetype udev unicode usb v4l vorbis webgl webkit x264 xcomposite xfce xml xorg xscreensaver zlib" ABI_X86="64" ALSA_CARDS="ca0106 hda-intel" CURL_SSL="gnutls" ELIBC="glibc" GRUB_PLATFORMS="pc" INPUT_DEVICES="evdev" KERNEL="linux" LINGUAS="en en_GB sv sv_SE" PYTHON_SINGLE_TARGET="python3_3" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19" USERLAND="GNU" VIDEO_CARDS="radeon" XFCE_PLUGINS="trash"

                        Package Settings

app-office/dia-0.97.2-r1 was built with the following:
USE="cairo (multilib) -debug -doc -gnome -python" ABI_X86="64"
CFLAGS="-march=amdfam10 -pipe -O2 -ggdb"
CXXFLAGS="-march=amdfam10 -pipe -O2 -ggdb"
Comment 4 Alexander Tsoy 2013-08-26 12:45:02 UTC
(In reply to Mark R. Pariente from comment #2)

> A fix was pushed on the development branch of dia but not backported to 0.97
> branch:

It was backported recently:
Comment 5 Pacho Ramos gentoo-dev 2013-09-22 10:55:32 UTC
*** Bug 485124 has been marked as a duplicate of this bug. ***
Comment 6 Pacho Ramos gentoo-dev 2013-09-22 11:22:22 UTC
+*dia-0.97.2-r2 (22 Sep 2013)
+  22 Sep 2013; Pacho Ramos <> +dia-0.97.2-r2.ebuild,
+  +files/dia-0.97.2-glib2.36.patch,
+  +files/dia-0.97.2-implicit-declaration.patch:
+  Migrate to new python eclasses, improve desktop file translations, drop
+  unneeded libgnome* deps, let it compile with latest automake, don't mess with
+  localedir, fix glib-2.36 compat, apply upstream patch to fix some warnings.