Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 468754 - mail-filter/libspf2 - configure.ac:9: error: 'AM_CONFIG_HEADER': this macro is obsolete.
Summary: mail-filter/libspf2 - configure.ac:9: error: 'AM_CONFIG_HEADER': this macro i...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Net-Mail Packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: automake-1.13
  Show dependency tree
 
Reported: 2013-05-06 12:36 UTC by Casey Allen Shobe
Modified: 2014-10-23 04:03 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Casey Allen Shobe 2013-05-06 12:36:55 UTC
Since a week or so ago, I've been unable to cleanly emerge -e @world.  I was hoping this would be noticed by others and resolved but as of today it is still the case.

I can complete an emerge -e @world by using --resume --skipfirst a number of times, each time such a package is encountered.

The first one in my particular installation to hit this happens to be libspf2.  Here are the details:

 * Messages for package mail-filter/libspf2-1.2.9-r3:

 * Failed Running aclocal !
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/mail-filter/libspf2-1.2.9-r3/temp/aclocal.out
 * ERROR: mail-filter/libspf2-1.2.9-r3 failed (prepare phase):
 *   Failed Running aclocal !
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_prepare
 *   environment, line 2843:  Called eautoreconf
 *   environment, line  784:  Called eaclocal
 *   environment, line  687:  Called autotools_run_tool '--at-m4flags' 'aclocal'
 *   environment, line  557:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";
 *
 * If you need support, post the output of `emerge --info '=mail-filter/libspf2-1.2.9-r3'`,
 * the complete build log and the output of `emerge -pqv '=mail-filter/libspf2-1.2.9-r3'`.
 * The complete build log is located at '/var/tmp/portage/mail-filter/libspf2-1.2.9-r3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/mail-filter/libspf2-1.2.9-r3/temp/environment'.
 * Working directory: '/var/tmp/portage/mail-filter/libspf2-1.2.9-r3/work/libspf2-1.2.9'
 * S: '/var/tmp/portage/mail-filter/libspf2-1.2.9-r3/work/libspf2-1.2.9'


# cat /var/tmp/portage/mail-filter/libspf2-1.2.9-r3/temp/aclocal.out
***** aclocal *****
***** PWD: /var/tmp/portage/mail-filter/libspf2-1.2.9-r3/work/libspf2-1.2.9
***** aclocal

configure.ac:9: error: 'AM_CONFIG_HEADER': this macro is obsolete.
    You should use the 'AC_CONFIG_HEADERS' macro instead.
/usr/share/aclocal-1.13/obsolete-err.m4:12: AM_CONFIG_HEADER is expanded from...
configure.ac:9: the top level
autom4te-2.69: /usr/bin/m4 failed with exit status: 1
aclocal-1.13: error: echo failed with exit status: 1
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2013-05-06 12:39:57 UTC

*** This bug has been marked as a duplicate of bug 451744 ***
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2013-05-06 12:42:34 UTC
Sorry, I was a bit too fast in duping this bug...

Let's rename it and make it block the tracker bug instead...
Comment 3 Tim Harder gentoo-dev 2014-10-23 04:03:12 UTC
Fixed in 1.2.10.