Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 468204 - media-video/lightworks - Professional NLE system for editing and mastering of movies.
Summary: media-video/lightworks - Professional NLE system for editing and mastering of...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement with 3 votes (vote)
Assignee: Default Assignee for New Packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-01 21:13 UTC by Pavel Borisov
Modified: 2017-05-08 15:22 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Lightworks 11.5.b ebuild (lwks-11.5b.ebuild,1.35 KB, text/plain)
2013-11-30 23:00 UTC, Martin Samek
Details
launch script (lightworks,543 bytes, application/x-shellscript)
2013-11-30 23:00 UTC, Martin Samek
Details
updated lwks-12.0 ebuild (lwks-12.0.ebuild,1.36 KB, text/plain)
2014-09-25 14:58 UTC, Walter
Details
updated lwks-12.0.1 ebuild (lwks-12.0.1.ebuild,1.53 KB, text/plain)
2014-11-27 23:42 UTC, Walter
Details
new version 14.0.0 (lightworks-14.0.0.ebuild,1.07 KB, text/plain)
2017-05-08 15:22 UTC, Maxim Konyushikhin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Borisov 2013-05-01 21:13:41 UTC
the famous Lightworks video editor was released for Linux. 
http://www.lwks.com/index.php?option=com_kunena&func=view&catid=19&id=44717&Itemid=81

only AMD64 is supported. Direct download, only DEB: http://cdn.2safe.com/518537033045/lwks-11.1.H-amd64.deb
Comment 1 Leho Kraav (:macmaN @lkraav) 2013-05-01 21:29:57 UTC
+1!
Comment 2 Martin Samek 2013-11-30 22:59:38 UTC
I slightly modified an ebuild from this Git:

http://code.r3pek.org/gentoo-overlay/src/e6a69d0ce92c5c7ebc4714f2e2a2d76743eb6247/media-video/lwks/

and successfully install Lightworks 11.5.B. My ebuild is in attachments.
Comment 3 Martin Samek 2013-11-30 23:00:07 UTC
Created attachment 364300 [details]
Lightworks 11.5.b ebuild
Comment 4 Martin Samek 2013-11-30 23:00:54 UTC
Created attachment 364302 [details]
launch script
Comment 5 Walter 2014-09-25 14:58:54 UTC
Created attachment 385444 [details]
updated lwks-12.0 ebuild

+1 ... I've been using this for over a year from non-official ebuilds.

This updated 12.0 ebuild is modified from the layman r3pek media-gfx/lwks-11.1f ebuild. Added some deps. Verified working with a freshly downloaded .deb from http://www.lwks.com/index.php?option=com_lwks&view=download&Itemid=206
Comment 6 Martin Samek 2014-10-18 20:35:19 UTC
ebuild 12.0 fails for me, there is a block:

[blocks B      ] media-libs/libjpeg-turbo:0 ("media-libs/libjpeg-turbo:0" is blocking media-libs/jpeg-8d-r1)
[blocks B      ] media-libs/jpeg:0 ("media-libs/jpeg:0" is blocking media-libs/libjpeg-turbo-1.3.1)
Comment 7 Walter 2014-11-27 23:42:19 UTC
OK, so the 12.0 ebuild didn't work entirely.

Martin, your issue is the same I had .. to fix it, upgrade to media-libs/libjpeg-turbo. The old ebuilds had another jpeg RDEP in them which is no longer current.

I am uploading a new lwks-12.0.1 ebuild now which I would appreciate anyone who can testing out.
Comment 8 Walter 2014-11-27 23:42:53 UTC
Created attachment 390434 [details]
updated lwks-12.0.1 ebuild
Comment 9 Ron 2015-02-19 10:00:22 UTC
Is it just me or does someone else still getting this:

lightworks: error while loading shared libraries: libjpeg.so.8: cannot open shared object file: No such file or directory
Comment 10 Walter 2015-02-19 18:42:15 UTC
The error you are experiencing is, in my experience, if I remember correctly, caused by not upgrading to libjpeg-turbo from older libjpeg.

Now, I am no ebuild expert, and probably someone else needs to look at this and give it the once over, but I would have thought the dependency 'media-libs/libjpeg-turbo' should have solved the issue for you if you are using the latest version of the ebuild file?

If that does not work then all I can suggest is, for the moment, to try the non ebuild based install process detailed at http://www.lwks.com/index.php?option=com_kunena&func=view&catid=21&id=79671&Itemid=81#83740 which seems to work for myself and others.
Comment 11 Maxim Konyushikhin 2017-05-08 15:22:30 UTC
Created attachment 471968 [details]
new version 14.0.0