Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 467988 - media-libs/aalib: configure.in:7: error: 'AM_CONFIG_HEADER': this macro is obsolete.
Summary: media-libs/aalib: configure.in:7: error: 'AM_CONFIG_HEADER': this macro is ob...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Sergei Trofimovich
URL:
Whiteboard:
Keywords:
: 468272 (view as bug list)
Depends on:
Blocks: automake-1.13
  Show dependency tree
 
Reported: 2013-04-30 11:43 UTC by Lars Wendler (Polynomial-C)
Modified: 2013-05-10 15:29 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Wendler (Polynomial-C) gentoo-dev 2013-04-30 11:43:36 UTC
***** aclocal *****
***** PWD: /var/tmp/portage/media-libs/aalib-1.4_rc5-r4/work/aalib-1.4.0
***** aclocal

aclocal-1.13: warning: autoconf input should be named 'configure.ac', not 'configure.in'
configure.in:129: warning: underquoted definition of AC_USE_SUNOS_CURSES
configure.in:129:   run info Automake 'Extending aclocal'
configure.in:129:   or see http://www.gnu.org/software/automake/manual/automake.html#Extending-aclocal
configure.in:7: error: 'AM_CONFIG_HEADER': this macro is obsolete.
    You should use the 'AC_CONFIG_HEADERS' macro instead.
/usr/share/aclocal-1.13/obsolete-err.m4:12: AM_CONFIG_HEADER is expanded from...
configure.in:7: the top level
autom4te-2.69: /usr/bin/m4 failed with exit status: 1
aclocal-1.13: error: echo failed with exit status: 1
Comment 1 Sergei Trofimovich gentoo-dev 2013-04-30 17:00:23 UTC
Pushed fix for both ebuilds:

> 30 Apr 2013; Sergei Trofimovich <slyfox@gentoo.org> aalib-1.4_rc5-r4.ebuild,
> aalib-1.4_rc5.ebuild:
> Fixed build failure against automake-1.13 (use of outdated AM_CONFIG_HEADER),
> bug #467988 by Lars Wendler (Polynomial-C).


Thanks for the report!
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2013-05-02 11:35:30 UTC
*** Bug 468272 has been marked as a duplicate of this bug. ***
Comment 3 Anthony Basile gentoo-dev 2013-05-08 08:31:15 UTC
This commit

http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/media-libs/aalib/aalib-1.4_rc5-r4.ebuild?r1=1.2&r2=1.3

is missing eautoreconf and leads to the following:

 <cut>
creating ./config.status
creating Makefile
creating man/Makefile
creating doc/Makefile
creating src/Makefile
creating aalib-config
creating src/config.h
make -j9 CC=x86_64-pc-linux-gnu-gcc 
make: *** No rule to make target `configure.in', needed by `Makefile.in'.  Stop.
emake failed
 * ERROR: media-libs/aalib-1.4_rc5 failed (compile phase):
 *   (no error message)
 * 
 * Call stack:
 *     ebuild.sh, line  93:  Called src_compile
 *   environment, line 2892:  Called die
 * The specific snippet of code:
 *       emake CC="$(tc-getCC)" || die
 * 
 * If you need support, post the output of `emerge --info '=media-libs/aalib-1.4_rc5'`,
 * the complete build log and the output of `emerge -pqv '=media-libs/aalib-1.4_rc5'`.
 * The complete build log is located at '/var/tmp/portage/media-libs/aalib-1.4_rc5/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-libs/aalib-1.4_rc5/temp/environment'.
 * Working directory: '/var/tmp/portage/media-libs/aalib-1.4_rc5/work/aalib-1.4.0'
 * S: '/var/tmp/portage/media-libs/aalib-1.4_rc5/work/aalib-1.4.0'
Comment 4 Anthony Basile gentoo-dev 2013-05-08 08:32:08 UTC
(In reply to comment #3)
> This commit
> 
> http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/media-libs/aalib/
> aalib-1.4_rc5-r4.ebuild?r1=1.2&r2=1.3
> 

Oops, wrong ebuild.  I meant aalib-1.4_rc5.ebuild, not -r4.
Comment 5 Anthony Basile gentoo-dev 2013-05-08 09:50:11 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > This commit
> > 
> > http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/media-libs/aalib/
> > aalib-1.4_rc5-r4.ebuild?r1=1.2&r2=1.3
> > 
> 
> Oops, wrong ebuild.  I meant aalib-1.4_rc5.ebuild, not -r4.

Okay this one is a no brainer, so I went ahead and committed it.  Please review and make sure there isn't something subtle here that I may have overlooked.
Comment 6 Sergei Trofimovich gentoo-dev 2013-05-10 15:29:50 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > (In reply to comment #3)
> > > This commit
> > > 
> > > http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/media-libs/aalib/
> > > aalib-1.4_rc5-r4.ebuild?r1=1.2&r2=1.3
> > > 
> > 
> > Oops, wrong ebuild.  I meant aalib-1.4_rc5.ebuild, not -r4.
> 
> Okay this one is a no brainer, so I went ahead and committed it.  Please
> review and make sure there isn't something subtle here that I may have
> overlooked.

Yeah, accidentally dropped here:

http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/media-libs/aalib/aalib-1.4_rc5.ebuild?r1=1.27&r2=1.28

Thanks for catching/fixing it!