Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 467746 - media-libs/libpgf fails to build with =sys-devel/automake-1.13.1
Summary: media-libs/libpgf fails to build with =sys-devel/automake-1.13.1
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Viorel
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks: automake-1.13
  Show dependency tree
 
Reported: 2013-04-28 14:29 UTC by 白川間瀬流
Modified: 2021-04-01 04:43 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Ebuild for workaround (libpgf-6.12.27-r1.ebuild,883 bytes, text/plain)
2013-04-28 19:06 UTC, 白川間瀬流
Details

Note You need to log in before you can comment on or make changes to this bug.
Description 白川間瀬流 2013-04-28 14:29:06 UTC
* Messages for package media-libs/libpgf-6.12.27:

 * Failed Running aclocal !
 * 
 * Include in your bugreport the contents of:
 * 
 *   /var/tmp/portage/media-libs/libpgf-6.12.27/temp/aclocal.out
 * ERROR: media-libs/libpgf-6.12.27 failed (prepare phase):
 *   Failed Running aclocal !
 * 
 * Call stack:
 *     ebuild.sh, line   93:  Called src_prepare
 *   environment, line 1507:  Called eautoreconf
 *   environment, line  616:  Called eaclocal
 *   environment, line  519:  Called autotools_run_tool '--at-m4flags' 'aclocal'
 *   environment, line  498:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";
 * 
 * If you need support, post the output of `emerge --info '=media-libs/libpgf-6.12.27'`,
 * the complete build log and the output of `emerge -pqv '=media-libs/libpgf-6.12.27'`.
 * The complete build log is located at '/var/tmp/portage/media-libs/libpgf-6.12.27/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-libs/libpgf-6.12.27/temp/environment'.
 * Working directory: '/var/tmp/portage/media-libs/libpgf-6.12.27/work/libpgf-6.12.27'
 * S: '/var/tmp/portage/media-libs/libpgf-6.12.27/work/libpgf-6.12.27'

 * GNU info directory index is up-to-date.
VampPC vamp898 # cat /var/tmp/portage/media-libs/libpgf-6.12.27/temp/aclocal.out
***** aclocal *****
***** PWD: /var/tmp/portage/media-libs/libpgf-6.12.27/work/libpgf-6.12.27
***** aclocal

configure.ac:29: error: 'AM_CONFIG_HEADER': this macro is obsolete.
    You should use the 'AC_CONFIG_HEADERS' macro instead.
/usr/share/aclocal-1.13/obsolete-err.m4:12: AM_CONFIG_HEADER is expanded from...
configure.ac:29: the top level
autom4te-2.69: /usr/bin/m4 failed with exit status: 1
aclocal-1.13: error: echo failed with exit status: 1

Reproducible: Always
Comment 1 白川間瀬流 2013-04-28 19:06:16 UTC
Created attachment 346806 [details]
Ebuild for workaround
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2013-04-29 12:31:39 UTC
Comment on attachment 346806 [details]
Ebuild for workaround

--- libpgf-6.12.27.ebuild       2012-10-29 00:41:29.129717502 +0100
+++ -   2013-04-29 14:31:33.572724931 +0200
@@ -22,7 +22,8 @@
        if ! use doc; then
                sed -i -e "/HAS_DOXYGEN/{N;N;d}" Makefile.am || die
        fi
-
+
+       sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.ac || die
        eautoreconf
 }
Comment 3 Thomas Capricelli 2013-08-31 23:58:11 UTC
confirmed here..

% automake --version
automake (GNU automake) 1.13.1

and same build.log.
Comment 4 Thomas Capricelli 2013-09-01 00:07:18 UTC
I can confirm that applying the workaround work, though.
Comment 5 白川間瀬流 2014-12-10 19:45:02 UTC
Did the situation changed after 1,5 years or is this bug still persistant?
Comment 6 Viorel 2021-04-01 04:43:14 UTC
Current versions of libpgf use AC_CONFIG_HEADERS.