Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 467704 - =media-libs/id3lib-3.8.3-r8 fails with =sys-devel/automake-1.13.1 - error: 'AM_CONFIG_HEADER': this macro is obsolete.
Summary: =media-libs/id3lib-3.8.3-r8 fails with =sys-devel/automake-1.13.1 - error: 'A...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: automake-1.13
  Show dependency tree
 
Reported: 2013-04-28 09:05 UTC by Ulrich Plate
Modified: 2013-05-03 17:34 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ulrich Plate 2013-04-28 09:05:53 UTC
Same as all the others in #451744, I suppose. Builds fine with automake-1.12.6.

configure.in:86: error: 'AM_CONFIG_HEADER': this macro is obsolete.
    You should use the 'AC_CONFIG_HEADERS' macro instead.
/usr/share/aclocal-1.13/obsolete-err.m4:12: AM_CONFIG_HEADER is expanded from...
configure.in:86: the top level
autom4te-2.69: /usr/bin/m4 failed with exit status: 1
aclocal-1.13: error: echo failed with exit status: 1
Comment 1 Justin Lecher gentoo-dev 2013-05-03 17:34:02 UTC
+*id3lib-3.8.3-r9 (03 May 2013)
+
+  03 May 2013; Justin Lecher <jlec@gentoo.org> +id3lib-3.8.3-r9.ebuild,
+  metadata.xml:
+  Fix obsolete macros to work with automake-1.13, #467704; bumped to EAPI=5 and
+  autotools-utils.eclass
+