Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 46767 - HPT372 PCI RAID Controller is unable to handle the hard disks attached to it (RAID-0)
Summary: HPT372 PCI RAID Controller is unable to handle the hard disks attached to it ...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: (DEPRECATED)
Depends on:
Reported: 2004-04-04 06:43 UTC by Johan Capraro
Modified: 2004-06-02 18:03 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

PCI Devices (pci,2.67 KB, application/octet-stream)
2004-04-04 06:45 UTC, Johan Capraro
/proc/partitions (partitions,735 bytes, application/octet-stream)
2004-04-04 06:46 UTC, Johan Capraro
LILO Configuration (lilo.conf,196 bytes, application/octet-stream)
2004-04-04 06:46 UTC, Johan Capraro
/etc/fstab (fstab,1.46 KB, application/octet-stream)
2004-04-04 06:47 UTC, Johan Capraro
Kernel configuration (Gentoo sources 2.4.25) (kernel,24.96 KB, application/octet-stream)
2004-04-04 06:50 UTC, Johan Capraro
LiveCD dmesg output (dmesg,11.50 KB, application/octet-stream)
2004-04-04 06:50 UTC, Johan Capraro
fdisk -l (fdisk,1.42 KB, application/octet-stream)
2004-04-04 06:51 UTC, Johan Capraro

Note You need to log in before you can comment on or make changes to this bug.
Description Johan Capraro 2004-04-04 06:43:40 UTC
This problem occurs with a PCI DawiControl DC-100 RAID controller. It's based on the Highpoint HPT372A Chip, Rev. 2. and other HPT372A based controllers.

The Gentoo 1.4_rc1 LiveCD can detect the controller and the hard disks attached to it, as well as the raid array. The Gentoo system can be installed properly, but after compiling the kernel and booting the new kernel you get a null pointer derefence error after detection of the first hard disk on the first channel.

The problem occurs with every kernel available on Gentoo 1.4 rc1 and also with gentoo-sources 2.4.25, after updating the portage tree.

The problem probably persists because of the lack of support for this chip in older a recent kernel. The boot parameters specified in the kernel help for HPT36x/37x chipset support under ATA/IDE/MFM/RLL Support > IDE, ATA and ATAPI block devices are of no use either.

Reproducible: Always
Steps to Reproduce:
1. Install a HPT372A PCI controller with 2 hard disks in RAID 0.
2. Boot the LiveCD with "smp doataraid"
3. Install the system and configure the kernel as it's supposed to be for this hardware.
4. Install and configure LILO or GRUB and boot your system.

Actual Results:  
The kernel crashes with a null pointer dereference error.

Expected Results:  
Booting the system correctly.
Comment 1 Johan Capraro 2004-04-04 06:45:52 UTC
Created attachment 28680 [details]
PCI Devices
Comment 2 Johan Capraro 2004-04-04 06:46:21 UTC
Created attachment 28682 [details]
Comment 3 Johan Capraro 2004-04-04 06:46:45 UTC
Created attachment 28683 [details]
LILO Configuration
Comment 4 Johan Capraro 2004-04-04 06:47:10 UTC
Created attachment 28684 [details]
Comment 5 Johan Capraro 2004-04-04 06:50:05 UTC
Created attachment 28685 [details]
Kernel configuration (Gentoo sources 2.4.25)
Comment 6 Johan Capraro 2004-04-04 06:50:37 UTC
Created attachment 28686 [details]
LiveCD dmesg output
Comment 7 Johan Capraro 2004-04-04 06:51:11 UTC
Created attachment 28687 [details]
fdisk -l
Comment 8 Johan Capraro 2004-04-04 06:52:40 UTC
See attachment for more information on the kernel as wel as the system.
Comment 9 Jason Cox (RETIRED) gentoo-dev 2004-04-13 13:39:13 UTC
Could you possibly try gentoo-dev-sources? The 2.6 kernels are supposed to have much better raid support.
Comment 10 Johan Capraro 2004-04-13 15:01:21 UTC
You're talking about md raid, right? I don't remember kernel 2.6.* supporting hptraid. If so, I haven't considered that option yet, since I'm trying to get it running using the chip's native raid.

Meanwhile I've found a patch that solved the kernel panic when detecting the hard disks, but the system is still not bootable.

The patch can be found here:
Comment 11 Jason Cox (RETIRED) gentoo-dev 2004-06-02 18:03:46 UTC
I think we've proven that this is over our heads. That or we have no clue. Perhaps a bug at would find a solution to this quicker.