Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 467602 - =app-text/aspell-0.60.6.1 fails with automake-1.13 - error: 'AM_CONFIG_HEADER': this macro is obsolete
Summary: =app-text/aspell-0.60.6.1 fails with automake-1.13 - error: 'AM_CONFIG_HEADER...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
: 482738 (view as bug list)
Depends on:
Blocks: automake-1.13
  Show dependency tree
 
Reported: 2013-04-27 21:08 UTC by Ian Stakenvicius
Modified: 2014-03-18 22:39 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
aspell-configure_fix.patch (aspell-configure_fix.patch,334 bytes, text/plain)
2013-05-05 10:44 UTC, David Heidelberg (okias)
Details
aspell-0.60.6.1 (aspell-0.60.6.1.ebuild,2.52 KB, text/plain)
2013-05-05 10:46 UTC, David Heidelberg (okias)
Details
aspell-0.60.6.1.patch (aspell.patch,432 bytes, patch)
2014-01-12 15:02 UTC, David Heidelberg (okias)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ian Stakenvicius gentoo-dev 2013-04-27 21:08:06 UTC
# cat /var/tmp/portage/app-text/aspell-0.60.6.1/temp/aclocal.out
***** aclocal *****
***** PWD: /var/tmp/portage/app-text/aspell-0.60.6.1/work/aspell-0.60.6.1
***** aclocal -I m4

/usr/share/aclocal/zthread.m4:34: warning: underquoted definition of AM_PATH_ZTHREAD
/usr/share/aclocal/zthread.m4:34:   run info Automake 'Extending aclocal'
/usr/share/aclocal/zthread.m4:34:   or see http://www.gnu.org/software/automake/manual/automake.html#Extending-aclocal
configure.ac:5: error: 'AM_CONFIG_HEADER': this macro is obsolete.
    You should use the 'AC_CONFIG_HEADERS' macro instead.
/usr/share/aclocal-1.13/obsolete-err.m4:12: AM_CONFIG_HEADER is expanded from...
configure.ac:5: the top level
autom4te-2.69: /usr/bin/m4 failed with exit status: 1
aclocal-1.13: error: echo failed with exit status: 1

Please note that although this package is stable and automake-1.13 is ~arch,
this is still a priority fix because ~arch users are immediately affected.
Comment 1 David Heidelberg (okias) 2013-05-05 10:44:54 UTC
Created attachment 347422 [details]
aspell-configure_fix.patch

This patch should help.
Comment 2 David Heidelberg (okias) 2013-05-05 10:46:04 UTC
Created attachment 347424 [details]
aspell-0.60.6.1

+ fixed ebuild
Comment 3 Jeroen Roovers gentoo-dev 2013-08-28 02:20:51 UTC
*** Bug 482738 has been marked as a duplicate of this bug. ***
Comment 4 David Heidelberg (okias) 2014-01-12 15:02:30 UTC
Created attachment 367720 [details, diff]
aspell-0.60.6.1.patch

Please, fix this. Thank you.
Comment 5 Steve Arnold gentoo-dev 2014-02-11 06:57:23 UTC
Okay, fixed this one along with another annoying failure I just created (by having ncurses built with use=tinfo).  Should be available shortly.