Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 46704 - Ebuild request for SuperCollider
Summary: Ebuild request for SuperCollider
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Jeremy Huddleston (RETIRED)
URL: http://swiki.hfbk-hamburg.de:8888/Mus...
Whiteboard:
Keywords: EBUILD
Depends on:
Blocks:
 
Reported: 2004-04-03 10:30 UTC by matt shanley
Modified: 2004-10-03 20:48 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
supercollider-cvs-20040903.ebuild (supercollider-cvs-20040903.ebuild,1.61 KB, text/plain)
2004-09-03 13:51 UTC, CJ Kucera
Details
supercollider-messages.txt (supercollider-messages.txt,3.59 KB, text/plain)
2004-09-03 13:54 UTC, CJ Kucera
Details
supercollider-cvs-20040903.ebuild (supercollider-cvs-20040903.ebuild,2.73 KB, text/plain)
2004-09-03 18:47 UTC, CJ Kucera
Details
files/README-gentoo.txt (README-gentoo.txt,3.17 KB, text/plain)
2004-09-03 18:48 UTC, CJ Kucera
Details

Note You need to log in before you can comment on or make changes to this bug.
Description matt shanley 2004-04-03 10:30:49 UTC
I would appreciate it if someone could build an ebuild for SuperCollider 3, a real time audio synthesis programming language.

Information about the software in general can be found:
http://www.audiosynth.com/

and about the linux version more specifically:
http://swiki.hfbk-hamburg.de:8888/MusicTechnology/478

Many thanks.
Comment 1 Jeremy Huddleston (RETIRED) gentoo-dev 2004-06-15 00:02:03 UTC
We are short on devs, and most additions to portage come from community contributions.  See the documentation for information on how to create ebuilds.
Comment 2 CJ Kucera 2004-09-02 09:50:15 UTC
I just found out about SuperCollider earlier today and figured that I could slap together an ebuild for it, so I should be able to get something up here in a bit.  The major issue as I see it is that SuperCollider doesn't seem to package up any source tarballs; any source you get seems to have to come through CVS, and so I'm not sure exactly how that would play.  I'll keep investigating though.
Comment 3 Jeremy Huddleston (RETIRED) gentoo-dev 2004-09-02 10:01:15 UTC
you can create a cvs snapshot tarball which we can host on our mirrors...
Comment 4 CJ Kucera 2004-09-02 10:04:38 UTC
Yeah, but it'd be nice to have actual source tarballs anyway.  I've emailed the mailing list for SuperCollider; we'll see what they have to say.  The project's already at sourceforge, so it shouldn't be too hard to get some official source packages together.  If not, I'll just take the CVS snapshot.
Comment 5 CJ Kucera 2004-09-03 13:51:20 UTC
Created attachment 38843 [details]
supercollider-cvs-20040903.ebuild

Here's an initial version of an ebuild for SuperCollider.  Currently you'll
need to make a tarball from cvs and name it supercollider-cvs-20040903.tgz. 
Alternatively, you can grab the one I've been using from
http://apocalyptech.com/linux/supercollider

I've noticed that there's a bunch of CVS-based ebuilds using a "cvs" eclass
which puts actual repository information into the ebuild, so eventually I'll
move over to using that, but for now this'll do.

I should stress that this probably isn't a production-ready ebuild yet.  The
code compiles fine and everything seems to be basically in order, but I have
yet to actually get this thing to produce any sound, so I'm not sure if it's
working properly or not.

Also, looking through the various READMEs, etc, it appears that they recommend
that your interface to supercollider be through emacs.	I haven't actually used
emacs in almost 8 years or so (being in the vi camp, myself), and I'm not sure
if that stuff's working either.
Comment 6 CJ Kucera 2004-09-03 13:54:36 UTC
Created attachment 38844 [details]
supercollider-messages.txt

This is a list of the messages I get when attempting to run supercollider with:


sclang linux/examples/onetwoonetwo.sc -

... as per the README files.  After the "Library has not been compiled
successfully" line, it sits doing nothing until I hit Ctrl-C.  That leads me to
believe that perhaps it's just sitting there waiting to get some input or
something, but I'm pretty sure that it's supposed to be playing some music or
something at that point.  It of course doesn't help that this is a version from
CVS, so it could very well be that the problem is simply in the code currently.


I'll keep looking around and post back here later.
Comment 7 Jeremy Huddleston (RETIRED) gentoo-dev 2004-09-03 14:00:41 UTC
the cvs "live" ebuilds are provided as a convenience for developers.  The prefered method is to just use a snapshot ebuild like this.  I'll leave this for a week to allow you to thuroughly test out the snapshot at that URL you gave and if you have no problems with it, I'll mirror it on the gentoo mirrors and add it to portage.
Comment 8 CJ Kucera 2004-09-03 18:47:37 UTC
Created attachment 38866 [details]
supercollider-cvs-20040903.ebuild

Okay, here's an updated ebuild which I feel contains everything the program
needs.	I've got it running and creating sounds like it should, both on the
command line and via the emacs interface, and I've got all the docs sucked into
the docs directory on this one too.

Getting it up and running once it's been succesfully compiled isn't an entirely
intuitive process, so I've added a little readme which lives in the files dir
and gets copied over into /usr/share/doc upon installation; I'll attach that in
just a second, and it should probably be looked over before making it into
Portage too.

There may be some existing commands to use in ebuilds which I'm not aware of,
and if so, the following could simplify a bit of the src_install() routine:
  * Is there a dodoc which doesn't compress files? (Other than dohtml, which
doesn't apply in this case.)
  * Is there a recursive dodoc?  (Again, dohtml seems to have this, but not
dodoc - and again, it'd be nice to have this not compress files)
  * Is there a variable which expands to /usr/share/doc (so that if the doc dir
ever changes the ebuild doesn't have to be changed too?)

I think that's about it...
Comment 9 CJ Kucera 2004-09-03 18:48:01 UTC
Created attachment 38867 [details]
files/README-gentoo.txt

Here's some docs to get people started with SuperCollider
Comment 10 CJ Kucera 2004-09-05 20:19:46 UTC
Oop, I noticed one line in README-gentoo.txt uses the word "SuperConnector" instead of "SuperCollider" - should probably change that before it makes it into CVS...
Comment 11 Jeremy Huddleston (RETIRED) gentoo-dev 2004-10-03 20:48:26 UTC
finally in portage...