Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 466256 - net-im/empathy don´t connect to ICQ Messanger after Update to Version 3.8 [3.8.1]
Summary: net-im/empathy don´t connect to ICQ Messanger after Update to Version 3.8 [3....
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gnome-3.8
  Show dependency tree
 
Reported: 2013-04-17 16:48 UTC by Andreas Mielke
Modified: 2013-04-21 11:39 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
telepathy-haze for working ICQ (telepathy-haze-0.7.0.ebuild,983 bytes, text/plain)
2013-04-20 21:11 UTC, Andreas Mielke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Mielke 2013-04-17 16:48:33 UTC
net-im/empathy don´t connect to ICQ Messanger after Update to Version 3.8 [3.8.1]

telepathy is installed. 

My telepathy Version:
eix telepa|grep ^.I
[I] net-im/telepathy-connection-managers
[I] net-im/telepathy-logger
[I] net-im/telepathy-mission-control
[I] net-libs/telepathy-farstream
[I] net-libs/telepathy-glib
[I] net-voip/telepathy-gabble
[I] net-voip/telepathy-haze
[I] net-voip/telepathy-rakia

[I] net-im/empathy
     Available versions:  2.34.0-r2 (~)3.6.3 (~)3.6.4 {M}(~)3.8.0 {M}(~)3.8.1 {M}**9999[1] {debug eds +geocode +geoloc gnome gnome-online-accounts +map nautilus networkmanager sendto spell test +v4l webkit}
     Installed versions:  3.8.1(17:26:39 17.04.2013)(geoloc gnome gnome-online-accounts map spell v4l -debug -test)
     Homepage:            http://live.gnome.org/Empathy
     Description:         Telepathy instant messaging and video/audio call client for GNOME




[I] net-im/telepathy-connection-managers
     Available versions:  1 2 {icq irc jabber msn sip yahoo zeroconf}
     Installed versions:  2(00:58:25 04.04.2013)(icq jabber msn sip -irc -yahoo -zeroconf)
     Homepage:            http://telepathy.freedesktop.org/
     Description:         Meta-package for Telepathy Connection Managers


[I] net-im/telepathy-logger
     Available versions:  0.4.0 0.4.0-r1 0.6.0(0/3) {M}(~)0.8.0(0/3) {+introspection test}
     Installed versions:  0.8.0(15:40:11 29.03.2013)(introspection -test)
     Homepage:            http://telepathy.freedesktop.org/wiki/Logger
     Description:         Telepathy Logger is a session daemon that should be activated whenever telepathy is being used.

[I] net-im/telepathy-mission-control
     Available versions:  5.12.3^t 5.14.0-r1 {connman debug gnome-keyring networkmanager +upower}
     Installed versions:  5.14.0-r1(00:51:37 04.04.2013)(gnome-keyring networkmanager upower -connman -debug)
     Homepage:            http://telepathy.freedesktop.org/wiki/Mission%20Control
     Description:         An account manager and channel dispatcher for the Telepathy framework.


[I] net-libs/telepathy-farstream
     Available versions:  0.4.0 0.6.0(0/3) {examples +introspection python}
     Installed versions:  0.6.0(00:49:53 04.04.2013)(introspection -examples)
     Homepage:            http://telepathy.freedesktop.org
     Description:         Telepathy client library that uses Farstream to handle Call channels


[I] net-libs/telepathy-glib
     Available versions:  0.20.1-r1 (~)0.20.2 {debug +introspection test +vala PYTHON_TARGETS="python2_5 python2_6 python2_7"}
     Installed versions:  0.20.2(17:09:48 08.04.2013)(introspection vala -debug -test PYTHON_TARGETS="python2_7 -python2_5 -python2_6")
     Homepage:            http://telepathy.freedesktop.org
     Description:         GLib bindings for the Telepathy D-Bus protocol.


[I] net-voip/telepathy-gabble
     Available versions:  0.16.1 0.16.4 {gnutls +jingle test}
     Installed versions:  0.16.4(00:46:22 04.04.2013)(jingle -gnutls -test)
     Homepage:            http://telepathy.freedesktop.org
     Description:         A Jabber/XMPP connection manager, with handling of single and multi user chats and voice calls


[I] net-voip/telepathy-haze
     Available versions:  0.6.0^t
     Installed versions:  0.6.0^t(00:58:16 04.04.2013)
     Homepage:            http://developer.pidgin.im/wiki/TelepathyHaze
     Description:         Telepathy connection manager providing libpurple supported protocols.


[I] net-voip/telepathy-rakia
     Available versions:  0.6.8 0.7.4 {test}
     Installed versions:  0.7.4(00:41:45 04.04.2013)(-test)
     Homepage:            http://telepathy.freedesktop.org/
     Description:         A SIP connection manager for Telepathy based around the Sofia-SIP library




emerge --info

Portage 2.1.11.62 (default/linux/amd64/13.0, gcc-4.7.2, glibc-2.17, 3.8.5-gentoo x86_64)
=================================================================
System uname: Linux-3.8.5-gentoo-x86_64-Intel-R-_Core-TM-2_Extreme_CPU_X9100_@_3.06GHz-with-gentoo-2.2
KiB Mem:     4056220 total,     47060 free
KiB Swap:    4003836 total,   4003828 free
Timestamp of tree: Wed, 17 Apr 2013 15:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
ccache version 3.1.9 [disabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/ccache:          3.1.9
dev-util/cmake:           2.8.10.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.13.1
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.7.2-r1
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r5::gnome
sys-kernel/linux-headers: 3.8 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo amielke-overlay steam-overlay gnome
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.UTF-8"
LC_ALL="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/amielke-overlay /var/lib/layman/steam /var/lib/layman/gnome"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi alsa amd64 apm apng berkdb bindist bluray bzip2 cairo cdr cli consolekit cracklib crypt cups cxx dbus dconf dri dts dvd eds extensions faac ffmpeg firefox-bookmarks fortran fts g3dvl gconf gdbm geolocation geonames gmp gnome gnome-keyring gnome-online-accounts gnome-shell gpm gstreamer gtk gtk3 gudev hwdb iconv icq introspection ipv6 jabber jingle jpeg lame laptop libass libnotify memprofile mms mmx modules mp3 mpeg msn mtp mudflap multilib nautilus ncurses networkmanager nls nptl nsplugin ogg openmp openrc opus pam pcre pdf playlist plugins png policykit pulseaudio python readline resolvconf rss sendto session sip spell sqlite sse sse2 sse3 sse4_1 ssl ssse3 tcpd telepathy theora tracker udev udisks unicode vala vdpau x264 xinerama xvid zeitgeist zlib" ABI_X86="64" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nv nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON





Reproducible: Always
Comment 1 Pacho Ramos gentoo-dev 2013-04-17 17:57:53 UTC
Could you try bumping locally to telepathy-haze-0.7.0?
Comment 2 Gilles Dartiguelongue gentoo-dev 2013-04-17 22:06:19 UTC
It's not a problem with 3.8, or at least not entirely since I'm having the same issue with gnome 3.6 and the following unmasked packages:

>=dev-libs/glib-2.36
>=dev-util/gdbus-codegen-2.36
>=net-libs/glib-networking-2.36
>=app-misc/gnote-3.8
>=dev-libs/gdl-3.8
>=x11-libs/libcryptui-3.8
>=gnome-base/libgnome-keyring-3.8
>=app-crypt/gcr-3.8
Comment 3 Andreas Mielke 2013-04-20 21:11:27 UTC
Created attachment 346126 [details]
telepathy-haze for working ICQ
Comment 4 Andreas Mielke 2013-04-20 21:14:07 UTC
Thank you, with telepathy-haze 0.7.0 ICQ is working.
Comment 5 Pacho Ramos gentoo-dev 2013-04-21 11:39:47 UTC
+*telepathy-haze-0.7.0 (21 Apr 2013)
+
+  21 Apr 2013; Pacho Ramos <pacho@gentoo.org>
+  +files/001-handle_purple_account_request_password.patch,
+  +files/002-fix_resource_leakage.patch,
+  +files/003-fix_more_resource_leaks.patch, +telepathy-haze-0.7.0.ebuild:
+  Version bump, bug #466256 by Andreas Mielke
+