Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 466206 - net-libs/libnet : does not respect RANLIB
Summary: net-libs/libnet : does not respect RANLIB
Status: RESOLVED DUPLICATE of bug 466202
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal QA (vote)
Assignee: Netmon Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2013-04-17 08:17 UTC by Agostino Sarubbo
Modified: 2013-04-17 13:52 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2013-04-17 08:17:49 UTC
You receive this bug because this package does not respect my system's RANLIB (x86_64-pc-linux-gnu-ranlib) and calls directly /usr/bin/ranlib
The possible solutions to fix this issue are:
1)Fix the buildsystem, if you can;
2)inherit toolchain-funcs and use tc-export RANLIB
3)inherit toolchain-funcs and use emake RANLIB="$(tc-getRANLIB)"


From the build log:

checking for ranlib... ranlib

ranlib lib/libnet-1.0.a
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2013-04-17 13:52:06 UTC

*** This bug has been marked as a duplicate of bug 466202 ***