Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 465436 - app-text/sigil-0.8.4 version bump
Summary: app-text/sigil-0.8.4 version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: M. B.
URL:
Whiteboard:
Keywords:
: 542102 (view as bug list)
Depends on: 457024 466244
Blocks:
  Show dependency tree
 
Reported: 2013-04-10 20:10 UTC by avx
Modified: 2015-05-31 21:30 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
sigil-0.7.2.ebuild (sigil-0.7.2.ebuild,1.15 KB, text/plain)
2013-04-17 14:28 UTC, M. B.
Details
sigil-0.7.2.ebuild (sigil-0.7.2.ebuild,1.24 KB, text/plain)
2013-04-17 19:28 UTC, M. B.
Details
sigil-0.7.2.ebuild (sigil-0.7.2.ebuild,1.15 KB, text/plain)
2013-05-18 09:27 UTC, M. B.
Details
sigil-0.7.2.ebuild (sigil-0.7.2.ebuild,1.15 KB, text/plain)
2013-05-20 12:01 UTC, M. B.
Details
sigil-0.7.4.ebuild (sigil-0.7.4.ebuild,1.12 KB, text/plain)
2014-01-30 22:09 UTC, M. B.
Details
sigil-0.7.4.ebuild (sigil-0.7.4.ebuild,1.13 KB, text/plain)
2014-07-15 22:56 UTC, M. B.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description avx 2013-04-10 20:10:22 UTC
Sigil has been updated ~1.5 months ago, an updated version in portage would be nice.

Reproducible: Always
Comment 1 M. B. 2013-04-16 22:09:53 UTC
1. it's 0.7.2 now
2. it depends on qt:5 - please make it depend on #454132
Comment 2 M. B. 2013-04-17 14:28:54 UTC
Created attachment 345788 [details]
sigil-0.7.2.ebuild

as i already wrote, it depends on qt5, especially on qttools which has no ebuild yet. ( bug #466244 )
Comment 3 M. B. 2013-04-17 19:28:10 UTC
Created attachment 345822 [details]
sigil-0.7.2.ebuild

updated version

as always you can also get it from my overlay (tbc)
Comment 4 Sander Sweers 2013-05-15 16:28:44 UTC
Tried the ebuild but it seems something is not installed which sigil wants. I have the qt overlay installed for qt5. I looked around but can't really find a package that would provide this..

CMake Warning at src/Sigil/CMakeLists.txt:48 (find_package):
  By not providing "FindQt5LinguistTools.cmake" in CMAKE_MODULE_PATH this
  project has asked CMake to find a package configuration file provided by
  "Qt5LinguistTools", but CMake did not find one.

  Could not find a package configuration file provided by "Qt5LinguistTools"
  with any of the following names:

    Qt5LinguistToolsConfig.cmake
    qt5linguisttools-config.cmake

  Add the installation prefix of "Qt5LinguistTools" to CMAKE_PREFIX_PATH or
  set "Qt5LinguistTools_DIR" to a directory containing one of the above
  files.  If "Qt5LinguistTools" provides a separate development package or
  SDK, be sure it has been installed.


CMake Error at src/Sigil/CMakeLists.txt:468 (qt5_add_translation):
  Unknown CMake command "qt5_add_translation".


-- Configuring incomplete, errors occurred!
Comment 5 Sander Sweers 2013-05-16 12:16:04 UTC
In qt4 linguistics tools is part qtcore. But these tools are not build in qtcore version 5 ebuild.
Comment 6 M. B. 2013-05-18 09:27:01 UTC
Created attachment 348602 [details]
sigil-0.7.2.ebuild

Hehehe, I filed bug #466244 for that, but since it was magically fixed a couple of hours later I didn't recall to re-upload the ebuild.
Comment 7 Sander Sweers 2013-05-18 23:47:43 UTC
(In reply to comment #6)
> Hehehe, I filed bug #466244 for that, but since it was magically fixed a
> couple of hours later I didn't recall to re-upload the ebuild.

No, that (qttest) is not what it wants. The linguistics tools are not in any of the qt5 ebuilds afaics. They are the last 3 in the qtcore version 4 ebuild.

	QT4_TARGET_DIRECTORIES="
		src/tools/bootstrap
		src/tools/moc
		src/tools/rcc
		src/tools/uic
		src/corelib
		src/xml
		src/network
		src/plugins/codecs
		tools/linguist/lconvert
		tools/linguist/lrelease
		tools/linguist/lupdate"
Comment 8 M. B. 2013-05-20 12:01:47 UTC
Created attachment 348730 [details]
sigil-0.7.2.ebuild

erm, my bad.
that stuff is in the qttools-ebuild. bug #466244 dealt with that, but somehow in my ingenuity i put qttest into the depend part.


and you won't have any luck with qt regarding sigil 0.7. it needs the qt packages from the qt-overlay for this to work.
Comment 9 M. B. 2013-05-20 12:03:11 UTC
okay, no idea what i'm on today ...

and you won't have any luck with *qt4* regarding sigil 0.7. it needs the *qt5*
packages from the qt-overlay for this to work.
Comment 10 Sander Sweers 2013-05-20 12:41:26 UTC
(In reply to comment #8)
> erm, my bad.
> that stuff is in the qttools-ebuild. bug #466244 dealt with that, but
> somehow in my ingenuity i put qttest into the depend part.

That bug has wrongfully been closed by yoo. There is no ebuild for qttools in the qt overlay...

!!! The following update has been skipped due to unsatisfied dependencies:

app-text/sigil:0

emerge: there are no ebuilds to satisfy "dev-qt/qttools:5".
(dependency required by "app-text/sigil-0.7.2::infirit" [ebuild])
Comment 11 Sander Sweers 2013-05-20 14:44:39 UTC
So after a brief adventure into qttools compile dependancies I got this to build. It runs but that is as far as my testing went.
Comment 12 Bertrand Jacquin 2013-06-06 16:41:26 UTC
Quiet off topic. Is this also possible to get some stable version for 0.6 ?
Comment 13 Sander Sweers 2013-12-23 16:00:40 UTC
(In reply to Bertrand Jacquin from comment #12)
> Quiet off topic. Is this also possible to get some stable version for 0.6 ?

Yes, sigil 0.6.x is in the tree.

Updated ebuild now that the neccesary changes have been made to the qt overlay.

https://github.com/infirit/infirit/tree/master/app-text/sigil

Removed the user guide and put in some einfo where to get it.
Comment 14 Pacho Ramos gentoo-dev 2013-12-23 16:43:21 UTC
(In reply to Bertrand Jacquin from comment #12)
> Quiet off topic. Is this also possible to get some stable version for 0.6 ?

Simply open a bug report for that is there is none yet (as done for most of the packages)

Thanks!
Comment 15 M. B. 2014-01-30 22:09:12 UTC
Created attachment 369160 [details]
sigil-0.7.4.ebuild

This builds fine with "stock" qt-5 from the qt-overlay.
The ebuild is available in my overlay (tbc) and installs the documentation epub for 0.7.2.
Comment 16 M. B. 2014-07-15 22:56:05 UTC
Created attachment 380778 [details]
sigil-0.7.4.ebuild

Updated the ebuild to work with assistant-tools instead of qttools, available in the qt-overlay.
Comment 17 Jesse Adelman 2015-01-15 23:22:49 UTC
Howdy. I'd be happy to test this if the code were committed to unstable. :)
Comment 18 Michael Palimaka (kensington) gentoo-dev 2015-03-05 06:27:05 UTC
*** Bug 542102 has been marked as a duplicate of this bug. ***
Comment 19 Michael Palimaka (kensington) gentoo-dev 2015-03-05 06:27:46 UTC
There's some new ebuilds too in bug #542102.
Comment 20 Maxim Koltsov gentoo-dev 2015-04-05 17:01:22 UTC
I've added sigil-0.8.5. Please check it and report.
Comment 21 Manuel Rüger (RETIRED) gentoo-dev 2015-05-31 21:30:58 UTC
sigil-0.8.6 is also in the tree.