Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 464956 - Please stabilize kde-base/kleopatra-4.4.11.1-r1
Summary: Please stabilize kde-base/kleopatra-4.4.11.1-r1
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard: was: kde-base/kleopatra-4.4.11.1 segf...
Keywords: STABLEREQ
Depends on:
Blocks:
 
Reported: 2013-04-07 13:10 UTC by MickKi
Modified: 2013-04-21 13:07 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description MickKi 2013-04-07 13:10:19 UTC
For the last 6 months or longer Kleopatra has been crashing when launched.  Currently on kleopatra-4.4.11.1, stable amd64 arch, the problem remains.

Reproducible: Always

Steps to Reproduce:
1. Launch kleopatra from a terminal or from the kmail or kde menu.
2. Kleopatra segfaults as it tries to launch.
3.
Actual Results:  
This is what the terminal shows:
========================
$ kleopatra 
Statup timing: 20 ms elapsed: Command line args created 
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
Startup timing: 343 ms elapsed: Application created 
Startup timing: 382 ms elapsed: UiServer created 
KCrash: Application 'kleopatra' crashing...
KCrash: Attempting to start /usr/lib64/kde4/libexec/drkonqi from kdeinit
sock_file=/home/michael/.kde4/socket-dell_xps/kdeinit4__0
kleopatra(5942): Communication problem with  "kleopatra" , it probably crashed. 
Error message was:  "org.freedesktop.DBus.Error.NoReply" : " "Message did not receive a reply (timeout by message bus)" " 

QSocketNotifier: Invalid socket 8 and type 'Read', disabling...
QSocketNotifier: Invalid socket 10 and type 'Read', disabling...
$ 
========================



This is a BT (I haven't yet compiled kleopatra with USE="debug"):
========================
Application: Kleopatra (kleopatra), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f71ed522780 (LWP 5943))]

Thread 3 (Thread 0x7f71d7b29700 (LWP 5944)):
#0  0x00007fff69bde78f in clock_gettime ()
#1  0x00007f71e31c288d in clock_gettime () from /lib64/librt.so.1
#2  0x00007f71eaa11834 in qt_gettime() () from /usr/lib64/qt4/libQtCore.so.4
#3  0x00007f71eaaea64d in QTimerInfoList::updateCurrentTime() () from /usr/lib64/qt4/libQtCore.so.4
#4  0x00007f71eaaea983 in QTimerInfoList::timerWait(timeval&) () from /usr/lib64/qt4/libQtCore.so.4
#5  0x00007f71eaae935c in timerSourcePrepareHelper(GTimerSource*, int*) () from /usr/lib64/qt4/libQtCore.so.4
#6  0x00007f71eaae9405 in timerSourcePrepare(_GSource*, int*) () from /usr/lib64/qt4/libQtCore.so.4
#7  0x00007f71e2ee4ed9 in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#8  0x00007f71e2ee5603 in g_main_context_iterate.clone.6 () from /usr/lib64/libglib-2.0.so.0
#9  0x00007f71e2ee57f4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#10 0x00007f71eaae9e06 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#11 0x00007f71eaab97b2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#12 0x00007f71eaab9a07 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#13 0x00007f71ea9b8157 in QThread::exec() () from /usr/lib64/qt4/libQtCore.so.4
#14 0x00007f71eaa9928f in QInotifyFileSystemWatcherEngine::run() () from /usr/lib64/qt4/libQtCore.so.4
#15 0x00007f71ea9bb1bc in QThreadPrivate::start(void*) () from /usr/lib64/qt4/libQtCore.so.4
#16 0x00007f71ec551ec6 in start_thread () from /lib64/libpthread.so.0
#17 0x00007f71e94b486d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f71d7328700 (LWP 5945)):
#0  0x00007f71e94abbd3 in poll () from /lib64/libc.so.6
#1  0x00007f71e2ee56d6 in g_main_context_iterate.clone.6 () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f71e2ee57f4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f71eaae9e06 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#4  0x00007f71eaab97b2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#5  0x00007f71eaab9a07 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#6  0x00007f71ea9b8157 in QThread::exec() () from /usr/lib64/qt4/libQtCore.so.4
#7  0x00007f71eaa9928f in QInotifyFileSystemWatcherEngine::run() () from /usr/lib64/qt4/libQtCore.so.4
#8  0x00007f71ea9bb1bc in QThreadPrivate::start(void*) () from /usr/lib64/qt4/libQtCore.so.4
#9  0x00007f71ec551ec6 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f71e94b486d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f71ed522780 (LWP 5943)):
[KCrash Handler]
#6  0x00007f71ec96ec8d in _assuan_socket () from /usr/lib64/libassuan.so.0
#7  0x0000000000594db2 in Kleo::UiServer::Private::doMakeListeningSocket(QByteArray const&) ()
#8  0x0000000000591290 in Kleo::UiServer::Private::makeListeningSocket() ()
#9  0x0000000000447957 in main ()
========================

Please ask if you need more info.
-- 
Regards,
Mick
Comment 1 Michael Palimaka (kensington) gentoo-dev 2013-04-07 15:24:59 UTC
(In reply to comment #0)
> For the last 6 months or longer Kleopatra has been crashing when launched. 
> Currently on kleopatra-4.4.11.1, stable amd64 arch, the problem remains.

To clarify, is this happening only with kleopatra-4.4.11.1, or did you test other stable 4.10.1 as well?
Comment 2 MickKi 2013-04-07 17:04:38 UTC
Yes, it segfaults on previous version too.
Comment 3 MickKi 2013-04-07 17:06:30 UTC
Oops!  Sorry wrong response:

kleopatra-4.10.1 is hard masked here.  I am not using kmail2.  This is a stable box for most packages.


$ eix -l kleopatra
[I] kde-base/kleopatra
     Available versions:  
      (4)
		4.4.11.1	^t	[aqua debug +handbook]
	[m]	4.10.1	[aqua debug +handbook]
	[m]~	4.10.2	[aqua debug +handbook]
     Installed versions:  4.4.11.1(4)^t(13:58:27 04/07/13)(handbook -aqua -debug)
     Homepage:            http://www.kde.org/
     Description:         Kleopatra - KDE X.509 key manager
Comment 4 MickKi 2013-04-07 17:16:10 UTC
I'm thinking ... is kleopatra now *only* working on systems that are running mysql and the full nepomuk kde desktop?  I am just running kmail-1.13.7, without strigi/nepomuk.
Comment 5 Andreas K. Hüttel gentoo-dev 2013-04-07 17:45:14 UTC
(In reply to comment #4)
> I'm thinking ... is kleopatra now *only* working on systems that are running
> mysql and the full nepomuk kde desktop?  I am just running kmail-1.13.7,
> without strigi/nepomuk.

Forget about mysql, that particular problem for sure only affects kmail2. 

I have problems with kleopatra(-4.4) too, but did not look too closely at the bitrot yet. I suspect this is a kdepim-4.4-only problem.
Comment 7 Andreas K. Hüttel gentoo-dev 2013-04-20 01:22:04 UTC
Excellent, works. Thank you!
(We already had a very aged libassuan2 patch, no time right now to find out in detail what went wrong there...)

Patch added in kde-base/kleopatra-4.4.11.1-r1

Arches please stabilize immediately (since current stable is nonfunctional).
Target: amd64 ppc x86
Comment 8 Agostino Sarubbo gentoo-dev 2013-04-21 13:07:00 UTC
amd64 stable
Comment 9 Agostino Sarubbo gentoo-dev 2013-04-21 13:07:25 UTC
x86 stable
Comment 10 Agostino Sarubbo gentoo-dev 2013-04-21 13:07:48 UTC
ppc stable. Last arch, closing