Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 463816 - media-sound/alsa-tools does not respect AR
Summary: media-sound/alsa-tools does not respect AR
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo ALSA team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2013-03-30 09:37 UTC by Agostino Sarubbo
Modified: 2013-05-02 01:07 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2013-03-30 09:37:36 UTC
You receive this bug because this package does not respect my system's AR ( x86_64-pc-linux-gnu-ar - /usr/bin/x86_64-pc-linux-gnu-ar ) and calls directly ar - /usr/bin/ar
The possible solutions to fix this issue are:
1)Fix the buildsystem, if you can
2)inherit toolchain-funcs and use tc-export AR
3)inherit toolchain-funcs and use emake AR="$(tc-getAR)"


ar cru libac3.a bitstream.o decode.o imdct.o coeff.o exponent.o stats.o bit_allocate.o parse.o crc.o debug.o rematrix.o downmix.o dither.o sanity_check.o
Comment 1 Samuli Suominen gentoo-dev 2013-05-02 01:07:17 UTC
This is solved because alsa-tools-1.0.27 doesn't have this ac3lib anymore, it's one of the differences to 1.0.26
Upstream dropped it for some other reason