Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 463018 - =app-emacs/ocaml-mode-4.00.1 =dev-lang/ocaml-4.02.3 =dev-ml/camldbm-1.0 =dev-ml/camlp4-4.02.1_p3 =dev-ml/camlp5-6.14 =dev-ml/labltk-8.06.0 =dev-ml/findlib-1.5.6 stable request
Summary: =app-emacs/ocaml-mode-4.00.1 =dev-lang/ocaml-4.02.3 =dev-ml/camldbm-1.0 =dev-...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Gentoo Team for the ML programming language family
URL:
Whiteboard: last EAPI=1 ebuild!
Keywords: STABLEREQ
Depends on: 564660
Blocks: EAPI1Removal 564404 586914 586916 604934
  Show dependency tree
 
Reported: 2013-03-24 20:25 UTC by Paweł Hajdan, Jr. (RETIRED)
Modified: 2017-01-15 01:14 UTC (History)
4 users (show)

See Also:
Package list:
=app-emacs/ocaml-mode-4.00.1 =dev-lang/ocaml-4.02.3 =dev-ml/camlp4-4.02.1_p3 =dev-ml/labltk-8.06.0 =dev-ml/findlib-1.5.6
Runtime testing required: ---
kensington: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2013-03-24 20:25:44 UTC
Is it OK to stabilize =app-emacs/ocaml-mode-4.00.1 ?

If so, please CC all arches which have stable keywords

for older versions of this package and add STABLEREQ keyword

to the bug.
Comment 1 Ulrich Müller gentoo-dev 2013-03-24 20:47:49 UTC
This shares its tarball with dev-lang/ocaml, so preferably we shouldn't stabilise it at the same time.
Comment 2 Pacho Ramos gentoo-dev 2014-02-15 20:18:48 UTC
When will ocaml-4 be stabilized?
Comment 3 Alexis Ballier gentoo-dev 2015-06-11 12:40:41 UTC
(In reply to Pacho Ramos from comment #2)
> When will ocaml-4 be stabilized?

it could go now, but i'd like to see a tinderbox run first; ocaml breaks a lot between versions :/
Comment 4 Pacho Ramos gentoo-dev 2015-06-24 07:48:33 UTC
(In reply to Alexis Ballier from comment #3)
> (In reply to Pacho Ramos from comment #2)
> > When will ocaml-4 be stabilized?
> 
> it could go now, but i'd like to see a tinderbox run first; ocaml breaks a
> lot between versions :/

For that maybe Toralf could help us: we would need a stable tinderbox with this newer ocaml to see what packages need to be fixed or stabilized with this

Thanks a lot :)
Comment 5 Toralf Förster gentoo-dev 2015-06-24 13:10:34 UTC
(In reply to Pacho Ramos from comment #4)

> For that maybe Toralf could help us: we would need a stable tinderbox with
> this newer ocaml to see what packages need to be fixed or stabilized with
> this
> 
> Thanks a lot :)

No problem, would just need a keyword file - attached here - or is app-emacs/ocaml-mode-4.00.1 the only one ?
Comment 6 Alexis Ballier gentoo-dev 2015-06-24 13:19:50 UTC
(In reply to Toralf Förster from comment #5)
> (In reply to Pacho Ramos from comment #4)
> 
> > For that maybe Toralf could help us: we would need a stable tinderbox with
> > this newer ocaml to see what packages need to be fixed or stabilized with
> > this
> > 
> > Thanks a lot :)
> 
> No problem, would just need a keyword file - attached here - or is
> app-emacs/ocaml-mode-4.00.1 the only one ?

thanks

dev-lang/ocaml-4.02.1 is the only one
Comment 7 Toralf Förster gentoo-dev 2015-06-24 16:54:21 UTC
A stable chroot image is setup and now running with these 2 packages accepted :

$ cat amd64-stable_20150624-154436/etc/portage/package.accept_keywords/ocaml
~app-emacs/ocaml-mode-4.00.1
~dev-lang/ocaml-4.02.1


Are there any package you'd like to see to be emerged first ? Otherwise just the 1-liner in [1] would be run after the first world update.


[1] http://www.zwiebeltoralf.de/tinderbox/index.html
Comment 8 Alexis Ballier gentoo-dev 2015-06-25 07:54:04 UTC
(In reply to Toralf Förster from comment #7)
> Are there any package you'd like to see to be emerged first ? Otherwise just
> the 1-liner in [1] would be run after the first world update.

everything (r)depending on ocaml, but i guess this would work too :)
Comment 9 Toralf Förster gentoo-dev 2015-06-25 18:02:20 UTC
(In reply to Alexis Ballier from comment #8)
> (In reply to Toralf Förster from comment #7)
> > Are there any package you'd like to see to be emerged first ? Otherwise just
> > the 1-liner in [1] would be run after the first world update.
> 
> everything (r)depending on ocaml, but i guess this would work too :)

Ok, putted those packages on top of the last :
find . -type f -name '*.ebuild' | xargs grep -Hl -e dev-lang/ocaml -e app-emacs/ocaml  | xargs -n1 dirname | cut -f2- -d '/' | sort -u >> /tmp/packages

and got the first fall out, or ? :

 * Package:    sci-mathematics/coq-8.4_p1
 * Repository: gentoo
 * Maintainer: ml@gentoo.org sci-mathematics@gentoo.org
 * USE:        abi_x86_64 amd64 elibc_glibc kernel_linux ocamlopt userland_GNU
 * FEATURES:   preserve-libs sandbox userpriv usersandbox
>>> Unpacking source...
>>> Unpacking coq-8.4pl1.tar.gz to /var/tmp/portage/sci-mathematics/coq-8.4_p1/work
>>> Source unpacked in /var/tmp/portage/sci-mathematics/coq-8.4_p1/work
>>> Preparing source in /var/tmp/portage/sci-mathematics/coq-8.4_p1/work/coq-8.4pl1 ...
 * Applying coq-8.4_p1-camlp4.patch ...
 [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/sci-mathematics/coq-8.4_p1/work/coq-8.4pl1 ...
GNU Make >= 3.81 is needed.
Make 3.81 can be downloaded from ftp://ftp.gnu.org/gnu/make/make-3.81.tar.gz
then locally installed on a Unix-style system by issuing:
  tar xzvf make-3.81.tar.gz
  cd make-3.81
  ./configure
  make
  mv make ..
  cd ..
Restart then the configure script and later use ./make instead of make.
 * ERROR: sci-mathematics/coq-8.4_p1::gentoo failed (configure phase):
 *   configure failed
 *
Comment 10 Alexis Ballier gentoo-dev 2015-06-26 10:32:57 UTC
(In reply to Toralf Förster from comment #9)
> (In reply to Alexis Ballier from comment #8)
> > (In reply to Toralf Förster from comment #7)
> > > Are there any package you'd like to see to be emerged first ? Otherwise just
> > > the 1-liner in [1] would be run after the first world update.
> > 
> > everything (r)depending on ocaml, but i guess this would work too :)
> 
> Ok, putted those packages on top of the last :
> find . -type f -name '*.ebuild' | xargs grep -Hl -e dev-lang/ocaml -e
> app-emacs/ocaml  | xargs -n1 dirname | cut -f2- -d '/' | sort -u >>
> /tmp/packages

this wont work as some (maybe most) packages depend on ocaml via an eclass i think

> and got the first fall out, or ? :
> 
>  * Package:    sci-mathematics/coq-8.4_p1
>  * Repository: gentoo
>  * Maintainer: ml@gentoo.org sci-mathematics@gentoo.org
>  * USE:        abi_x86_64 amd64 elibc_glibc kernel_linux ocamlopt
> userland_GNU
>  * FEATURES:   preserve-libs sandbox userpriv usersandbox
> >>> Unpacking source...
> >>> Unpacking coq-8.4pl1.tar.gz to /var/tmp/portage/sci-mathematics/coq-8.4_p1/work
> >>> Source unpacked in /var/tmp/portage/sci-mathematics/coq-8.4_p1/work
> >>> Preparing source in /var/tmp/portage/sci-mathematics/coq-8.4_p1/work/coq-8.4pl1 ...
>  * Applying coq-8.4_p1-camlp4.patch ...
>  [ ok ]
> >>> Source prepared.
> >>> Configuring source in /var/tmp/portage/sci-mathematics/coq-8.4_p1/work/coq-8.4pl1 ...
> GNU Make >= 3.81 is needed.
> Make 3.81 can be downloaded from ftp://ftp.gnu.org/gnu/make/make-3.81.tar.gz
> then locally installed on a Unix-style system by issuing:
>   tar xzvf make-3.81.tar.gz
>   cd make-3.81
>   ./configure
>   make
>   mv make ..
>   cd ..
> Restart then the configure script and later use ./make instead of make.
>  * ERROR: sci-mathematics/coq-8.4_p1::gentoo failed (configure phase):
>  *   configure failed
>  *

this one probably needs to go stable, i think it is due to make-4.x; please file a new bug for it
Comment 11 Alexis Ballier gentoo-dev 2015-10-30 11:19:18 UTC
Okey, so here is the (hopefuly) complete list for ocaml 4.02.3:

=app-emacs/ocaml-mode-4.00.1
=dev-lang/ocaml-4.02.3
=dev-ml/camldbm-1.0
=dev-ml/camlp4-4.02.1_p3
=dev-ml/camlp5-6.14
=dev-ml/labltk-8.06.0
=dev-ml/findlib-1.5.6



it's the usual 2 (ocaml + camlp5), those new ones that are split (camldbm, camlp4, labltk), findlib to support split packages, ocaml-mode for emacs.

I have not been able to reproduce bug #544176, if anyone can trigger it and confirm that it is just a parallel make problem, feel free to add -j1 to emake calls as this is the case with current stable
Comment 12 Jeroen Roovers gentoo-dev 2015-11-01 11:14:08 UTC
Stable for HPPA.
Comment 13 Jeroen Roovers gentoo-dev 2015-11-03 04:14:54 UTC
Stable for PPC64.
Comment 14 Agostino Sarubbo gentoo-dev 2015-11-10 12:01:41 UTC
amd64 stable
Comment 15 Agostino Sarubbo gentoo-dev 2015-11-11 09:55:29 UTC
x86 stable
Comment 16 Agostino Sarubbo gentoo-dev 2015-11-12 11:21:50 UTC
ppc stable
Comment 17 Agostino Sarubbo gentoo-dev 2015-11-18 10:56:08 UTC
on ia64 I can't go ahead because of:

  dependency.bad [fatal]        14
   dev-ml/camldbm/camldbm-1.0.ebuild: DEPEND: ia64(default/linux/ia64/13.0)                                                                                                                                                                                                    
['>=dev-lang/ocaml-3.12:=[ocamlopt]']
Comment 18 Alexis Ballier gentoo-dev 2015-11-18 10:59:10 UTC
(In reply to Agostino Sarubbo from comment #17)
> on ia64 I can't go ahead because of:
> 
>   dependency.bad [fatal]        14
>    dev-ml/camldbm/camldbm-1.0.ebuild: DEPEND: ia64(default/linux/ia64/13.0) 
> 
> ['>=dev-lang/ocaml-3.12:=[ocamlopt]']

hmm, right, it's not even keyworded there: drop camldbm from the list; nothing on ia64 should need it.
Comment 19 Markus Meier gentoo-dev 2015-11-21 14:27:39 UTC
arm stable
Comment 20 Tobias Klausmann gentoo-dev 2016-02-01 09:45:54 UTC
This needs some work:

RepoMan scours the neighborhood...
  dependency.bad [fatal]        28
   dev-ml/camldbm/camldbm-1.0.ebuild: DEPEND: alpha(default/linux/alpha/13.0)
['>=dev-lang/ocaml-3.12:=[ocamlopt]']

The ocamlopt USE flag is masked for ocaml on alpha, ppc64ul, mips, ia64 and hppa -- but that should apply to camldbm just as it does for the ocaml ebuild. Is repoman broken here?

Please advise.
Comment 21 Alexis Ballier gentoo-dev 2016-02-01 10:34:29 UTC
(In reply to Tobias Klausmann from comment #20)
> This needs some work:
> 
> RepoMan scours the neighborhood...
>   dependency.bad [fatal]        28
>    dev-ml/camldbm/camldbm-1.0.ebuild: DEPEND: alpha(default/linux/alpha/13.0)
> ['>=dev-lang/ocaml-3.12:=[ocamlopt]']
> 
> The ocamlopt USE flag is masked for ocaml on alpha, ppc64ul, mips, ia64 and
> hppa -- but that should apply to camldbm just as it does for the ocaml
> ebuild. Is repoman broken here?

camldbm just doesnt properly support disabling ocamlopt. Please skip it on alpha (and other arches without ocamlopt support), nothing should need it.
Comment 22 Tobias Klausmann gentoo-dev 2016-02-04 17:23:45 UTC
(In reply to Alexis Ballier from comment #21)
> camldbm just doesnt properly support disabling ocamlopt. Please skip it on
> alpha (and other arches without ocamlopt support), nothing should need it.

Stable on alpha:

=app-emacs/ocaml-mode-4.00.1
=dev-lang/ocaml-4.02.3 
=dev-ml/camlp4-4.02.1_p3 
=dev-ml/camlp5-6.14 
=dev-ml/labltk-8.06.0
=dev-ml/findlib-1.5.6
Comment 23 Manuel Rüger (RETIRED) gentoo-dev 2016-03-06 17:23:10 UTC
@ia64, sparc: Friendly ping :)
Comment 24 Pacho Ramos gentoo-dev 2016-11-10 17:14:28 UTC
(In reply to Manuel Rüger from comment #23)
> @ia64, sparc: Friendly ping :)

What about simply use.stable.masking dev-lang/ocaml[emacs] and dropping ocaml-mode to ~sparc ~ia64 ?
Comment 25 Pacho Ramos gentoo-dev 2016-11-10 17:15:35 UTC
Ah no, it's the full ocaml ebuild that is eapi1 :S
Comment 26 Pacho Ramos gentoo-dev 2016-11-16 16:15:30 UTC
For ia64 maybe Emeric can help us for the arch testing (thanks!). For sparc I have no idea about how to fix it (I would probably opt for blindly stabilizing it and waiting them to complain... or maybe we should consider to move sparc to the status of m68k/s390/sh arches... that are stabilized by the people who care when they need it)
Comment 27 Émeric Maschino 2016-11-16 23:27:56 UTC
(In reply to Pacho Ramos from comment #26)
> For ia64 maybe Emeric can help us for the arch testing (thanks!). For sparc
> I have no idea about how to fix it (I would probably opt for blindly
> stabilizing it and waiting them to complain... or maybe we should consider
> to move sparc to the status of m68k/s390/sh arches... that are stabilized by
> the people who care when they need it)

=app-emacs/ocaml-mode-4.00.1
=dev-lang/ocaml-4.02.3
=dev-ml/camlp4-4.02.1_p3
=dev-ml/labltk-8.06.0
=dev-ml/findlib-1.5.6

All emerged successfully, with tests enabled. But besides checking that they all build fine and pass test-suite, is there anything else I can do to ensure these would be really stable on ia64?

BTW, =dev-ml/camlp5-6.14 needs ia64 keyword. Should I try this one too?

Just let me know,

     Émeric
Comment 28 Ulrich Müller gentoo-dev 2016-11-17 11:15:15 UTC
(In reply to Émeric Maschino from comment #27)
> All emerged successfully, with tests enabled. But besides checking that they
> all build fine and pass test-suite, is there anything else I can do to
> ensure these would be really stable on ia64?

For app-emacs/ocaml-mode, we have a test plan:
https://wiki.gentoo.org/wiki/Project:Emacs/Test_plans#app-emacs.2Focaml-mode
Comment 29 Émeric Maschino 2016-11-17 18:40:34 UTC
(In reply to Ulrich Müller from comment #28)
> For app-emacs/ocaml-mode, we have a test plan:
> https://wiki.gentoo.org/wiki/Project:Emacs/Test_plans#app-emacs.2Focaml-mode

No problem detected.

     Émeric
Comment 30 Agostino Sarubbo gentoo-dev 2016-12-28 08:33:57 UTC
Dear Maintainer (or who is mainly involved in this stable request),

This is an auto-generated message that will move the current component to the new component Stabilization.
To ensure that the stabilization will proceed correctly, please fill the fields "Atoms to stabilize" and "Runtime testing required" as described here:
https://archives.gentoo.org/gentoo-dev/message/4b2ef0e9aa7588224b8ae799c5fe31fa
Comment 31 Agostino Sarubbo gentoo-dev 2017-01-11 10:36:25 UTC
sparc stable
Comment 32 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2017-01-15 01:14:52 UTC
ia64 stable