Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 462796 - eselect binutils should allow enabling plugin-aware wrappers
Summary: eselect binutils should allow enabling plugin-aware wrappers
Status: RESOLVED DUPLICATE of bug 494228
Alias: None
Product: Gentoo Hosted Projects
Classification: Unclassified
Component: eselect (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Gentoo eselect Team
URL:
Whiteboard:
Keywords: NeedPatch
Depends on:
Blocks:
 
Reported: 2013-03-23 15:26 UTC by uran238
Modified: 2015-09-24 19:20 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description uran238 2013-03-23 15:26:18 UTC
Newer versions of binutils ship with wrappers for "ar" "ranlib" and "nm". They start with "gcc-" and can handle plugins, which is atm only the lto plugin. I know lto isn't supported by gentoo at the moment, but this request is about infrastructure which should be there some time ahead. 
This plugin aware binutils helpers are needed when linking against a static library containing only "GIMPLE" objects, these are objects that have been created with -fno-fat-lto-objects. This speeds up the build process a lot. 
There are quite a lot of packages out there using static libraries during build, they will fail to link if those wrappers wont, but the -fno-fat-lto-objects, will be used.

Reproducible: Always

Steps to Reproduce:
1. set CFLAGS to "-flto -fno-fat-lto-objects"
2. set LDFLAGS to "-O2 -flto"
3. build wget and watch it fail with loads of unresolved symbols.
Comment 1 Jeroen Roovers gentoo-dev 2013-03-23 17:07:45 UTC
(According to the toolchain people, you should be using binutils-config instead.)
Comment 2 SpanKY gentoo-dev 2015-09-24 19:20:32 UTC
`eselect binutils` is a wrapper around binutils-config now

*** This bug has been marked as a duplicate of bug 494228 ***