Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 462746 - app-emulation/vmware-tools-9.2.3.1031769 not available from within app-emulation/vmware-workstation-9.0.2.1031769
Summary: app-emulation/vmware-tools-9.2.3.1031769 not available from within app-emulat...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Matt Whitlock
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-23 07:00 UTC by Manfred Knick
Modified: 2013-06-21 19:46 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Manfred Knick 2013-03-23 07:00:18 UTC
Upgrade or Installation (new) of VMware-Tools from within workstation fails.
Installation of new VMs with "Easy Install" fails.

Reproducible: Always

Steps to Reproduce:
1. Try to update e.g. MS-Windows-based VMs
2. Try to install new VMs

Actual Results:  
Error messages alike "vmware-tools not available" ;
trying to "Download" fails ; ...


Expected Results:  
Clean Installation of vmware-tools for the respective OS architecture.

# equery list vmware*
[IP-] [  ] app-emulation/vmware-modules-271.2:0
[IP-] [  ] app-emulation/vmware-tools-9.2.3.1031769:0
[IP-] [  ] app-emulation/vmware-workstation-9.0.2.1031769:0

 # ll /opt/vmware/lib/vmware/isoimages/
-rw-r--r-- 1 root root 65M Mar 21 19:20 linux.iso
-rw-r--r-- 1 root root 256 Mar 21 19:20 linux.iso.sig
-rw-r--r-- 1 root root 451 Mar 21 19:21 tools-key.pub
-rw-r--r-- 1 root root 73M Mar 21 19:20 windows.iso
-rw-r--r-- 1 root root 256 Mar 21 19:20 windows.iso.sig

It seems that these CD images don't get dynamically mounted into the VMs properly, as had been working in earlier versions already.
Comment 1 Manfred Knick 2013-03-24 12:18:36 UTC
P.S.:
Jsut to point it out clearly once again:
With current installation, the correct ISO images _are_ prefectly availible as
. --->  /opt/vmware/lib/vmware/isoimages/{OS.Class}.iso  <---
already.

For the time being: WORKAROUND: Update / Install them by "Do it the old way"

1.a) Assign /opt/vmware/lib/vmware/isoimages/{OS.Class}.iso
to the CD/DVD device

1.b) Enable "Connect at power on"

2.) Start your VM;
login as root / Administrator-enabled user

3.A) M$-Windows based:
Click the "Setup.EXE" corresponding to your ARCH:
either 32-bit or 64-bit, and follow on.

3.B) *NIX based:
Mount the cdrom device; find your TAR archive;
Unpack to a local temporary directory inside your VM, and follow on.


For new installations, you might consider to assign TWO cdrom devices:
   cdrom-1 == for OS installation media ISO
   cdrom-2 == for OS vmware tools media ISO

Installing via the "Custom (advanced)" path,
this helps /eases your way quite a bit, 
but it will not allow for "Easy Install", sure.

Thanks.
Comment 2 Manfred Knick 2013-04-06 19:10:49 UTC
Hi, Matt,

can I offer any additional information / help to solve this?

Kind regards
Manfred
Comment 3 Matt Whitlock 2013-04-07 16:53:05 UTC
(In reply to comment #2)
> can I offer any additional information / help to solve this?

VMware Workstation (and Player) aren't really designed to be installed by a package manager. They're designed to be installed by VMware's Installer, and the user who runs the software is assumed to have write access to the installation paths, which is pretty undesirable, IMHO.

If VMware Workstation is no longer recognizing that the ISO images are already available, then it's something we would need to take up with VMware. Since this is not open-source software, it's not something we can simply patch to fix.
Comment 4 Andreas K. Hüttel gentoo-dev 2013-06-21 19:46:38 UTC
This is basically a "can't fix", sorry.