Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 462064 - =dev-lang/lua-5.1.5 fails to compile (relocation R_X86_64_PC32 against undefined hidden symbol `luaP_opnames' can not be used when making a shared object)
Summary: =dev-lang/lua-5.1.5 fails to compile (relocation R_X86_64_PC32 against undefi...
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: William Hubbs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-17 15:02 UTC by Agostino Sarubbo
Modified: 2019-03-18 21:45 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2013-03-17 15:02:29 UTC
* Package:    dev-lang/lua-5.1.5                                                                                                                                                   
 * Repository: gentoo                                                                                                                                                               
 * Maintainer: mabi@gentoo.org rafaelmartins@gentoo.org                                                                                                                             
 * USE:        abi_x86_64 amd64 deprecated elibc_glibc kernel_linux multilib userland_GNU                                                                                           
 * FEATURES:   sandbox userpriv usersandbox                                                                                                                                         
 * Applying lua-5.1-make-r1.patch ...                                                                                                                                               
 [ ok ]                                                                                                                                                                             
 * Applying lua-5.1-module_paths.patch ...                                                                                                                                          
 [ ok ]                                                                                                                                                                             
 * Applying lua-5.1-readline.patch ...                                                                                                                                              
 [ ok ]                                                                                                                                                                             
.libs/luac.o: In function `pmain':                                                                                                                                                  
luac.c:(.text+0x169): undefined reference to `luaF_newproto'                                                                                                                        
luac.c:(.text+0x1ab): undefined reference to `luaS_newlstr'                                                                                                                         
luac.c:(.text+0x1d7): undefined reference to `luaM_realloc_'                                                                                                                        
luac.c:(.text+0x1fe): undefined reference to `luaM_realloc_'                                                                                                                        
luac.c:(.text+0x2d7): undefined reference to `luaU_dump'                                                                                                                            
luac.c:(.text+0x359): undefined reference to `luaD_growstack'
luac.c:(.text+0x36a): undefined reference to `luaM_toobig'
luac.c:(.text+0x386): undefined reference to `luaM_toobig'
.libs/print.o: In function `luaU_print':
print.c:(.text+0x5bb): undefined reference to `luaP_opnames'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../x86_64-pc-linux-gnu/bin/ld: .libs/print.o: relocation R_X86_64_PC32 against undefined hidden symbol `luaP_opnames' can not be used when making a shared object
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../x86_64-pc-linux-gnu/bin/ld: final link failed: Bad value
collect2: ld returned 1 exit status
make: *** [luac] Error 1
make: *** Waiting for unfinished jobs....
 * ERROR: dev-lang/lua-5.1.5 failed (compile phase):


I get this error only on hardened.
Comment 1 Agostino Sarubbo gentoo-dev 2013-03-17 15:09:33 UTC
err. It happens also on non-hardened:

.libs/luac.o: In function `pmain':
luac.c:(.text+0x1c4): undefined reference to `luaF_newproto'
luac.c:(.text+0x20b): undefined reference to `luaS_newlstr'
luac.c:(.text+0x230): undefined reference to `luaM_realloc_'
luac.c:(.text+0x255): undefined reference to `luaM_realloc_'
luac.c:(.text+0x320): undefined reference to `luaU_dump'
luac.c:(.text+0x3b1): undefined reference to `luaD_growstack'
luac.c:(.text+0x3c4): undefined reference to `luaM_toobig'
luac.c:(.text+0x3de): undefined reference to `luaM_toobig'
.libs/print.o: In function `luaU_print':
print.c:(.text+0x534): undefined reference to `luaP_opnames'
print.c:(.text+0x552): undefined reference to `luaP_opmodes'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.4/../../../../x86_64-pc-linux-gnu/bin/ld: luac: hidden symbol `luaF_newproto' isn't defined
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.4/../../../../x86_64-pc-linux-gnu/bin/ld: final link failed: Bad value
collect2: ld returned 1 exit status
make: *** [luac] Errore 1
Comment 2 Vadim A. Misbakh-Soloviov (mva) gentoo-dev 2013-05-26 17:54:27 UTC
Uhm.
WORKSFORME.
It flawlessly compiles both on hardened with GCC 4.6 and non-hardened with 4.7.3.
Comment 3 Agostino Sarubbo gentoo-dev 2013-05-26 17:56:21 UTC
I can reproduce on 3 pc's, it is not a worksforme only because it works for you
Comment 4 Vadim A. Misbakh-Soloviov (mva) gentoo-dev 2013-05-27 07:44:53 UTC
(In reply to Agostino Sarubbo from comment #3)
> I can reproduce on 3 pc's, it is not a worksforme only because it works for
> you

I mean exactly that it works for me, but not that bug should change the status ;)

Anyway, can you try to reproduce it with disabled PIE and with modern versions of GCC (4.6.4/4.7.3).

Actually, it works for me even with PIE and ccache, but just try to check.

And, anyway, I fix such errors in packages developed by my, by adding "-shared -fPIC" to CFLAGS. And sometimes — by "--no-as-needed" to LDFLAGS.

It may also help you, but I doubt, that it is a reason to do that in ebuild.

Btw, can you post your CFLAGS/LDFLAGS?
Comment 5 Agostino Sarubbo gentoo-dev 2013-05-27 08:25:26 UTC
Portage 2.1.12.1 (hardened/linux/x86, gcc-4.6.3, glibc-2.15-r3, 3.2.42-gentoo i686)
=================================================================
System uname: Linux-3.2.42-gentoo-i686-Intel-R-_Celeron-R-_M_CPU_430_@_1.73GHz-with-gentoo-2.2
KiB Mem:     2060284 total,    383260 free
KiB Swap:    2047996 total,   2038684 free
Timestamp of tree: Fri, 24 May 2013 19:30:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p45
dev-lang/python:          2.7.3-r3
dev-util/cmake:           2.8.10.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo ago x-portage
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium-m -g0"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions /usr/share/themes/oxygen-gtk/gtk-2.0 /usr/share/themes/oxygen-gtk/gtk-3.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=pentium-m -g0"
DISTDIR="/media/sources"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FCFLAGS="-O2"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-O2"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="it_IT.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/ago /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aac acl acpi alsa apic bash-completion berkdb bzip2 cairo cli consolekit cracklib crypt custom-cflags custom-optimization cxx dbus dri dvd extras ffmpeg gdbm gpm gtk gudev hardened hwdb iconv jpeg jpeg2k kde kmod lame lm_sensors mad minizip mmx modules mp3 mudflap ncurses networkmanager nptl nsplugin opengl openmp openrc pam pax_kernel pcre pic png policykit qt3support qt4 readline semantic-desktop session sse sse2 ssl svg symlink tcpd theora threads tiff udev unicode urandom vorbis x264 x86 xvid zlib" ABI_X86="32" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev synaptics" KERNEL="linux" LINGUAS="en en_GB" OFFICE_IMPLEMENTATION="libreoffice" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" USERLAND="GNU" VIDEO_CARDS="intel"
USE_PYTHON="2.7"
Comment 6 Roman Zimmermann 2013-06-19 07:00:57 UTC
I had the same issue here and I've solved it by upgrading to sys-devel/libtool-2.4-r4 (building lua previously failed with libtool-2.4-r1)
Comment 7 Agostino Sarubbo gentoo-dev 2013-07-03 19:31:25 UTC
(In reply to Roman Zimmermann from comment #6)
> I had the same issue here and I've solved it by upgrading to
> sys-devel/libtool-2.4-r4 (building lua previously failed with libtool-2.4-r1)

Works for me too with 2.4-r4
Comment 8 Ondřej Súkup 2014-04-03 15:00:22 UTC
 * Package:    dev-lang/lua-5.1.5-r1
 * Repository: gentoo
 * Maintainer: mabi@gentoo.org rafaelmartins@gentoo.org
 * USE:        abi_x86_64 amd64 deprecated elibc_glibc kernel_linux readline userland_GNU
 * FEATURES:   preserve-libs sandbox userpriv usersandbox
>>> Unpacking source...
>>> Unpacking lua-5.1.5.tar.gz to /var/tmp/portage/dev-lang/lua-5.1.5-r1/work
>>> Source unpacked in /var/tmp/portage/dev-lang/lua-5.1.5-r1/work
>>> Preparing source in /var/tmp/portage/dev-lang/lua-5.1.5-r1/work/lua-5.1.5 ...
 * Applying lua-5.1-make-r1.patch ...                                                                                                                                                                      [ ok ]
 * Applying lua-5.1-module_paths.patch ...                                                                                                                                                                 [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-lang/lua-5.1.5-r1/work/lua-5.1.5 ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/dev-lang/lua-5.1.5-r1/work/lua-5.1.5 ...
make -j9 CC=x86_64-pc-linux-gnu-gcc 'CFLAGS=-DLUA_USE_LINUX -march=native -O2 -pipe' RPATH=/usr/lib64/ LUA_LIBS=-lreadline 'LIB_LIBS=-lm -ldl' V=5.1.5 gentoo_all 
libtool --quiet --tag=CC --mode=compile x86_64-pc-linux-gnu-gcc -c  -DLUA_USE_LINUX -march=native -O2 -pipe -o lapi.lo lapi.c
libtool --quiet --tag=CC --mode=compile x86_64-pc-linux-gnu-gcc -c  -DLUA_USE_LINUX -march=native -O2 -pipe -o lcode.lo lcode.c
libtool --quiet --tag=CC --mode=compile x86_64-pc-linux-gnu-gcc -c  -DLUA_USE_LINUX -march=native -O2 -pipe -o ldebug.lo ldebug.c
libtool --quiet --tag=CC --mode=compile x86_64-pc-linux-gnu-gcc -c  -DLUA_USE_LINUX -march=native -O2 -pipe -o ldo.lo ldo.c
libtool --quiet --tag=CC --mode=compile x86_64-pc-linux-gnu-gcc -c  -DLUA_USE_LINUX -march=native -O2 -pipe -o ldump.lo ldump.c
libtool --quiet --tag=CC --mode=compile x86_64-pc-linux-gnu-gcc -c  -DLUA_USE_LINUX -march=native -O2 -pipe -o lfunc.lo lfunc.c
libtool --quiet --tag=CC --mode=compile x86_64-pc-linux-gnu-gcc -c  -DLUA_USE_LINUX -march=native -O2 -pipe -o lgc.lo lgc.c
libtool --quiet --tag=CC --mode=compile x86_64-pc-linux-gnu-gcc -c  -DLUA_USE_LINUX -march=native -O2 -pipe -o llex.lo llex.c
libtool --quiet --tag=CC --mode=compile x86_64-pc-linux-gnu-gcc -c  -DLUA_USE_LINUX -march=native -O2 -pipe -o lmem.lo lmem.c
libtool --quiet --tag=CC --mode=compile x86_64-pc-linux-gnu-gcc -c  -DLUA_USE_LINUX -march=native -O2 -pipe -o lobject.lo lobject.c
libtool --quiet --tag=CC --mode=compile x86_64-pc-linux-gnu-gcc -c  -DLUA_USE_LINUX -march=native -O2 -pipe -o lopcodes.lo lopcodes.c
libtool --quiet --tag=CC --mode=compile x86_64-pc-linux-gnu-gcc -c  -DLUA_USE_LINUX -march=native -O2 -pipe -o lparser.lo lparser.c
libtool --quiet --tag=CC --mode=compile x86_64-pc-linux-gnu-gcc -c  -DLUA_USE_LINUX -march=native -O2 -pipe -o lstate.lo lstate.c
libtool --quiet --tag=CC --mode=compile x86_64-pc-linux-gnu-gcc -c  -DLUA_USE_LINUX -march=native -O2 -pipe -o lstring.lo lstring.c
libtool --quiet --tag=CC --mode=compile x86_64-pc-linux-gnu-gcc -c  -DLUA_USE_LINUX -march=native -O2 -pipe -o ltable.lo ltable.c
libtool --quiet --tag=CC --mode=compile x86_64-pc-linux-gnu-gcc -c  -DLUA_USE_LINUX -march=native -O2 -pipe -o ltm.lo ltm.c
libtool --quiet --tag=CC --mode=compile x86_64-pc-linux-gnu-gcc -c  -DLUA_USE_LINUX -march=native -O2 -pipe -o lundump.lo lundump.c
libtool --quiet --tag=CC --mode=compile x86_64-pc-linux-gnu-gcc -c  -DLUA_USE_LINUX -march=native -O2 -pipe -o lvm.lo lvm.c
libtool --quiet --tag=CC --mode=compile x86_64-pc-linux-gnu-gcc -c  -DLUA_USE_LINUX -march=native -O2 -pipe -o lzio.lo lzio.c
libtool --quiet --tag=CC --mode=compile x86_64-pc-linux-gnu-gcc -c  -DLUA_USE_LINUX -march=native -O2 -pipe -o lauxlib.lo lauxlib.c
libtool --quiet --tag=CC --mode=compile x86_64-pc-linux-gnu-gcc -c  -DLUA_USE_LINUX -march=native -O2 -pipe -o lbaselib.lo lbaselib.c
libtool --quiet --tag=CC --mode=compile x86_64-pc-linux-gnu-gcc -c  -DLUA_USE_LINUX -march=native -O2 -pipe -o ldblib.lo ldblib.c
libtool --quiet --tag=CC --mode=compile x86_64-pc-linux-gnu-gcc -c  -DLUA_USE_LINUX -march=native -O2 -pipe -o liolib.lo liolib.c
libtool --quiet --tag=CC --mode=compile x86_64-pc-linux-gnu-gcc -c  -DLUA_USE_LINUX -march=native -O2 -pipe -o lmathlib.lo lmathlib.c
libtool --quiet --tag=CC --mode=compile x86_64-pc-linux-gnu-gcc -c  -DLUA_USE_LINUX -march=native -O2 -pipe -o loslib.lo loslib.c
libtool --quiet --tag=CC --mode=compile x86_64-pc-linux-gnu-gcc -c  -DLUA_USE_LINUX -march=native -O2 -pipe -o ltablib.lo ltablib.c
libtool --quiet --tag=CC --mode=compile x86_64-pc-linux-gnu-gcc -c  -DLUA_USE_LINUX -march=native -O2 -pipe -o lstrlib.lo lstrlib.c
libtool --quiet --tag=CC --mode=compile x86_64-pc-linux-gnu-gcc -c  -DLUA_USE_LINUX -march=native -O2 -pipe -o loadlib.lo loadlib.c
libtool --quiet --tag=CC --mode=compile x86_64-pc-linux-gnu-gcc -c  -DLUA_USE_LINUX -march=native -O2 -pipe -o linit.lo linit.c
libtool --quiet --tag=CC --mode=compile x86_64-pc-linux-gnu-gcc -c  -DLUA_USE_LINUX -march=native -O2 -pipe -o lua.lo lua.c
libtool --quiet --tag=CC --mode=compile x86_64-pc-linux-gnu-gcc -c  -DLUA_USE_LINUX -march=native -O2 -pipe -o luac.lo luac.c
libtool --quiet --tag=CC --mode=compile x86_64-pc-linux-gnu-gcc -c  -DLUA_USE_LINUX -march=native -O2 -pipe -o print.lo print.c
libtool --quiet --tag=CC --mode=link x86_64-pc-linux-gnu-gcc -version-info 6:5:1 \
            -rpath /usr/lib64/ -Wl,-O1 -Wl,--as-needed -o liblua.la lapi.lo lcode.lo ldebug.lo ldo.lo ldump.lo lfunc.lo lgc.lo llex.lo lmem.lo lobject.lo lopcodes.lo lparser.lo lstate.lo lstring.lo ltable.lo ltm.lo lundump.lo lvm.lo lzio.lo lauxlib.lo lbaselib.lo ldblib.lo liolib.lo lmathlib.lo loslib.lo ltablib.lo lstrlib.lo loadlib.lo linit.lo -lm -ldl
libtool --quiet --tag=CC --mode=link x86_64-pc-linux-gnu-gcc -export-dynamic -Wl,-O1 -Wl,--as-needed -o lua lua.lo liblua.la -lreadline
libtool --quiet --tag=CC --mode=link x86_64-pc-linux-gnu-gcc -static -export-dynamic -Wl,-O1 -Wl,--as-needed -o lua_test lua.lo liblua.la -lreadline
libtool --quiet --tag=CC --mode=link x86_64-pc-linux-gnu-gcc -static -Wl,-O1 -Wl,--as-needed -o luac luac.lo print.lo liblua.la
.libs/luac.o: In function `pmain':
luac.c:(.text+0x177): undefined reference to `luaF_newproto'
luac.c:(.text+0x1be): undefined reference to `luaS_newlstr'
luac.c:(.text+0x1e3): undefined reference to `luaM_realloc_'
luac.c:(.text+0x208): undefined reference to `luaM_realloc_'
luac.c:(.text+0x2d9): undefined reference to `luaU_dump'
luac.c:(.text+0x340): undefined reference to `luaD_growstack'
luac.c:(.text+0x351): undefined reference to `luaM_toobig'
luac.c:(.text+0x36b): undefined reference to `luaM_toobig'
.libs/print.o: In function `luaU_print':
print.c:(.text+0x431): undefined reference to `luaP_opnames'
print.c:(.text+0x44f): undefined reference to `luaP_opmodes'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.2/../../../../x86_64-pc-linux-gnu/bin/ld: luac: hidden symbol `luaF_newproto' isn't defined
/usr/lib/gcc/x86_64-pc-linux-gnu/4.8.2/../../../../x86_64-pc-linux-gnu/bin/ld: final link failed: Bad value
collect2: error: ld returned 1 exit status
Makefile:207: recipe for target 'luac' failed
make: *** [luac] Error 1
make: *** Waiting for unfinished jobs....
 * ERROR: dev-lang/lua-5.1.5-r1::gentoo failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=dev-lang/lua-5.1.5-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-lang/lua-5.1.5-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-lang/lua-5.1.5-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-lang/lua-5.1.5-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-lang/lua-5.1.5-r1/work/lua-5.1.5/src'
 * S: '/var/tmp/portage/dev-lang/lua-5.1.5-r1/work/lua-5.1.5'

:::::::::::::::::::: emerge --info :::::::::::::::::::::::::::::::::::::

Portage 2.2.10 (default/linux/amd64/13.0/desktop, gcc-4.8.2, glibc-2.19, 3.13.7-gentoo x86_64)
=================================================================
System uname: Linux-3.13.7-gentoo-x86_64-AMD_Phenom-tm-_9600_Quad-Core_Processor-with-gentoo-2.2
KiB Mem:     4053988 total,    270584 free
KiB Swap:    4000180 total,   4000152 free
Timestamp of tree: Thu, 03 Apr 2014 13:15:01 +0000
ld GNU ld (GNU Binutils) 2.24
app-shells/bash:          4.2_p46-r1
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.6, 3.3.5, 3.4.0
dev-util/cmake:           2.8.12.2-r1::kde
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.14.1
sys-devel/binutils:       2.24-r2
sys-devel/gcc:            4.8.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2-r1::ixit
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.14 (virtual/os-headers)
sys-libs/glibc:           2.19
Repositories: gentoo kde sunrise gentoo-haskell gamerlay x11 steam-overlay enlightenment ixit qt mimi_vx
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* @EULA openssl"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildsyspkg candy config-protect-if-modified distlocks downgrade-backup ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.supp.name/ http://ftp.fi.muni.cz/pub/linux/gentoo/ rsync://ftp6.linux.cz/pub/linux/gentoo/ rsync://ftp.fi.muni.cz/pub/linux/gentoo/ ftp://ftp.fi.muni.cz/pub/linux/gentoo/ http://gentoo.mirror.dkm.cz/pub/gentoo/ ftp://gentoo.mirror.dkm.cz/pub/gentoo/ rsync://gentoo.mirror.dkm.cz/gentoo/ http://gentoo.mirror.web4u.cz/ ftp://gentoo.mirror.web4u.cz/"
LANG="cs_CZ.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/kde /var/lib/layman/sunrise /var/lib/layman/haskell /var/lib/layman/gamerlay /var/lib/layman/x11 /var/lib/layman/steam /var/lib/layman/enlightenment /var/lib/layman/ixit /var/lib/layman/qt /home/mimi/Overlay/mimi_vx_overlay"
SYNC="rsync://rsync.cz.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acpi alsa amd64 avahi berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam ffmpeg firefox flac fortran gdbm gif gles gles2 gpm gstreamer iconv icu ipv6 jpeg json lcms libnotify lzma lzo mad mmx mmxext mng modules mp3 mp4 mpeg multilib ncurses nls nptl ogg openexr opengl openmp opus pam pango pcre pdf png policykit postscript ppds pulseaudio python qml qt3support qt4 rdp readline samba scanner sdl semantic-desktop session sox spell sqlite sse sse2 sse3 ssl ssse3 startup-notification svg tcpd theora threads tiff truetype udev udisks unicode upnp upower usb v4l vdpau vorbis vpx wayland webp x264 xcb xml xorg xv xvid zeroconf zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" ENLIGHTENMENT_MODULES="appmenu bluez4 contact music-control wl-desktop-shell wl-screenshot backlight clock comp conf-applications conf-dialogs conf-display conf-edgebindings conf-interaction conf-intl conf-keybindings conf-menus conf-paths conf-performance conf-randr conf-shelves conf-theme conf-window-manipulation conf-window-remembers connman cpufreq dropshadow everything fileman fileman-opinfo gadman ibar ibox illume2 mixer msgbus notification pager quickaccess start syscon systray tasks tiling winlist wizard xkbswitch conf-comp conf-wallpaper2" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en cs" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python3_4 python3_3 python2_7" RUBY_TARGETS="ruby21" SANE_BACKENDS="epson epson2" USERLAND="GNU" VIDEO_CARDS="radeon r600" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="3.4 3.3 2.7"


i have libtool-2.4.2