Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 461482 - net-im/pidgin[ncurses] fails to build with ncurses[tinfo]
Summary: net-im/pidgin[ncurses] fails to build with ncurses[tinfo]
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
: 501980 519360 528098 (view as bug list)
Depends on:
Blocks: tinfo
  Show dependency tree
 
Reported: 2013-03-12 07:52 UTC by Justin Lecher
Modified: 2015-06-28 17:14 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,444.48 KB, text/plain)
2013-03-12 07:52 UTC, Justin Lecher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Justin Lecher gentoo-dev 2013-03-12 07:52:09 UTC
n/sh ../libtool --silent  --tag=CC   --mode=link x86_64-pc-linux-gnu-gcc  -g -O2 -pipe -march=corei7-avx -mtune=corei7-avx -mno-movbe -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-bmi2 -mno-tbm -mno-avx2 -mno-lzcnt -mno-rdrnd -mno-f16c -mno-fsgsbase -g -Wimplicit-function-declaration -export-dynamic -Wl,-O1 -Wl,--as-needed -Wl,-O1 -Wl,--hash-style=gnu -Wl,--sort-common -o finch gntaccount.o gntblist.o gntcertmgr.o gntconn.o gntconv.o gntdebug.o gntft.o finch.o gntidle.o gntlog.o gntmedia.o gntnotify.o gntplugin.o gntpounce.o gntprefs.o gntrequest.o gntroomlist.o gntsound.o gntstatus.o gntui.o -ldbus-glib-1 -ldbus-1 -lgobject-2.0 -lglib-2.0   -lgobject-2.0 -Wl,--export-dynamic -lgmodule-2.0 -pthread -lrt -lgthread-2.0 -pthread -lrt -lglib-2.0  -lxml2  -lncursesw -lpanelw -lgstreamer-0.10 -lgobject-2.0 -lgmodule-2.0 -pthread -lrt -lgthread-2.0 -pthread -lrt -lglib-2.0 -lxml2  ./libgnt/libgnt.la ../libpurple/libpurple.la -lutil -lpthread -lm -lnsl -lresolv
gntaccount.c:825: error: undefined reference to 'cur_term'
gntaccount.c:834: error: undefined reference to 'cur_term'
gntblist.c:1945: error: undefined reference to 'cur_term'
gntblist.c:1833: error: undefined reference to 'stdscr'
gntblist.c:1891: error: undefined reference to 'stdscr'
gntcertmgr.c:309: error: undefined reference to 'cur_term'
collect2: error: ld returned 1 exit status
make[3]: *** [finch] Error 1
make[3]: Leaving directory `/var/tmp/portage/net-im/pidgin-2.10.7/work/pidgin-2.10.7/finch'


$ einfo pidgin
Portage 2.2.0_alpha166 (default/linux/amd64/13.0, gcc-4.7.2-asneeded, glibc-2.16.0, 3.8.2-lh-r1 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.8.2-lh-r1-x86_64-Intel-R-_Core-TM-_i7-2600_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    16468748 total,   6404944 free
KiB Swap:    4000180 total,   3524420 free
Timestamp of tree: Tue, 12 Mar 2013 06:30:01 +0000
ld GNU gold (GNU Binutils 2.23.1) 1.11
ccache version 3.1.9 [enabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.6.8-r1, 2.7.3-r3, 3.1.5-r1, 3.2.3-r2, 3.3.0-r1
dev-util/ccache:          3.1.9-r1::science
dev-util/cmake:           2.8.10.2-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6, 1.12.6, 1.13.1
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.1.2, 4.6.3, 4.7.2-r1
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.8 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo sunrise bicatali betagarden dummy neurogeek science last-hope g-ctan
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -ftracer -march=corei7-avx -mtune=corei7-avx -mcx16 -msahf -mno-movbe -maes -mpclmul -mpopcnt -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-bmi2 -mno-tbm -mavx -mno-avx2 -msse4.2 -msse4.1 -mno-lzcnt -mno-rdrnd -mno-f16c -mno-fsgsbase --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=8192 -frecord-gcc-switches -g -Wimplicit-function-declaration"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/eselect/ /usr/share/gnupg/qualified.txt /usr/share/nano/ /var/spool/munin-async/.ssh /var/spool/torque"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -ftracer -march=corei7-avx -mtune=corei7-avx -mcx16 -msahf -mno-movbe -maes -mpclmul -mpopcnt -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-bmi2 -mno-tbm -mavx -mno-avx2 -msse4.2 -msse4.1 -mno-lzcnt -mno-rdrnd -mno-f16c -mno-fsgsbase --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=8192 -frecord-gcc-switches -g -Wenum-compare"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs=4 --load-average=12 -t --keep-going --autounmask-write --autounmask --quiet-build=n"
FCFLAGS="-O2 -pipe -ftracer -march=corei7-avx -mtune=corei7-avx -mcx16 -msahf -mno-movbe -maes -mpclmul -mpopcnt -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-bmi2 -mno-tbm -mavx -mno-avx2 -msse4.2 -msse4.1 -mno-lzcnt -mno-rdrnd -mno-f16c -mno-fsgsbase --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=8192 -frecord-gcc-switches -g"
FEATURES="assume-digests binpkg-logs buildsyspkg candy ccache collision-protect compressdebug distlocks ebuild-locks fixlafiles merge-sync metadata-transfer multilib-strict news noinfo parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms sign split-log splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe -ftracer -march=corei7-avx -mtune=corei7-avx -mcx16 -msahf -mno-movbe -maes -mpclmul -mpopcnt -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-bmi2 -mno-tbm -mavx -mno-avx2 -msse4.2 -msse4.1 -mno-lzcnt -mno-rdrnd -mno-f16c -mno-fsgsbase --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=8192 -frecord-gcc-switches -g"
GENTOO_MIRRORS=" /mnt/tmpfs/ http://gentoo.j-schmitz.net/mirror/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo ftp://ftp.tu-clausthal.de/pub/linux/gentoo/"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,-O1 -Wl,--hash-style=gnu -Wl,--sort-common"
MAKEOPTS="-j16 -l9"
PKGDIR="/usr/portage/packages"
PORTAGE_COMPRESS="xz"
PORTAGE_COMPRESS_FLAGS="-z -e -9 -v"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/local/overlays/sunrise-reviewed /local/overlays/bicatali /local/overlays/betagarden /local/overlays/dummy /local/overlays/neurogeek /local/overlays/sci /local/overlays/lh/ebuilds /local/overlays/g-ctan"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl alsa amd64 avx bash-completion berkdb branding bzip2 cairo caps cli cracklib crypt cups cxx dbus dri fortran gdbm gif gmp gnome gnome-keyring gpm gstreamer gtk iconv icu ipv6 jpeg jpeg2k ldap logrotate mmx mmxext modules mudflap multilib ncurses network-cron nls nptl nsplugin numa opengl openmp pam pcre pgo png pulseaudio qt3support readline session smp sse sse2 sse2_4way sse2check sse3 sse4 sse41 sse4_1 sse4a sse5 ssl ssse3 startup-notification tcpd threads tiff truetype unicode vaapi vdpau xinerama zlib" ABI_X86="64" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="plymouth" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="efi-64 pc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer nlpsolver" LINGUAS="en" NGINX_MODULES_HTTP="fastcgi rewrite dav stub_status" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python2_6 python3_1 python3_2 python3_3 pypy1_9 pypy2_0" QEMU_SOFTMMU_TARGETS="i386 x86_64 arm" QEMU_USER_TARGETS="i386 x86_64 arm" RUBY_TARGETS="ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.6 2.7 3.1 3.2 3.3 2.7-pypy-1.9 2.7-pypy-2.0"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

net-im/pidgin-2.10.6 was built with the following:
USE="dbus gnutls gstreamer gtk (multilib) ncurses nls python spell xscreensaver (-aqua) -debug -doc -eds -gadu -groupwise -idn -meanwhile -networkmanager -perl -prediction -sasl -silc -tcl -tk -zephyr -zeroconf"
CFLAGS="-O2 -pipe -march=corei7-avx -mtune=corei7-avx -mno-movbe -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-bmi2 -mno-tbm -mno-avx2 -mno-lzcnt -g -Wimplicit-function-declaration"
CXXFLAGS="-O2 -pipe -march=corei7-avx -mtune=corei7-avx -mno-movbe -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-bmi2 -mno-tbm -mno-avx2 -mno-lzcnt -g -Wenum-compare"
Comment 1 Justin Lecher gentoo-dev 2013-03-12 07:52:35 UTC
Created attachment 341776 [details]
build.log

build.log
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2014-02-21 12:35:25 UTC
*** Bug 501980 has been marked as a duplicate of this bug. ***
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2014-08-08 07:11:54 UTC
*** Bug 519360 has been marked as a duplicate of this bug. ***
Comment 4 Daniel.Savard 2014-08-08 15:32:35 UTC
I ran into this problem with version 2.10.9-r1 and I managed to make pidgin to compile by hacking the Makefile left in the ebuild tree after failure.

cd into directory /var/tmp/portage/net-im/pidgin-2.10.9-r1/work/pidgin-2.10.9/finch

Edit Makefile
Find the line: LIBS = -lutil -lpthread -lm -lnsl -lresolv
Add -ltinfow after -lresolv
ebuild pidgin-2.10.9-r1.ebuild compile
ebuild pidgin-2.10.9-r1.ebuild merge

However, since it is failing without this library, it appears the software may not have been tested with this library and my fix may introduce bugs in the software.
Comment 5 Jeroen Roovers gentoo-dev 2014-11-03 10:52:00 UTC
*** Bug 528098 has been marked as a duplicate of this bug. ***
Comment 6 Daniel.Savard 2014-11-03 16:16:56 UTC
Same problem in pidgin-2.10.10 fixed with my own patch I applied to pidgin-2.10.9-r1.

files/pidgin-2.10.9-tinfow_fix.patch
--- configure.ac	2014-02-02 16:29:16.000000000 -0500
+++ /tmp/configure.ac	2014-09-11 14:49:38.331020652 -0400
@@ -634,6 +634,8 @@
 		[ac_ncurses_includes="$withval"], [ac_ncurses_includes=""])
 if test "x$enable_consoleui" = "xyes"; then
 	AC_CHECK_LIB(ncursesw, initscr, [GNT_LIBS="-lncursesw"], [enable_consoleui=no])
+	AC_CHECK_LIB(tinfow, termname, [GNT_LIBS="$GNT_LIBS -ltinfow"],
+	    [enable_consoleui=no], [$GNT_LIBS])
 	AC_CHECK_LIB(panelw, update_panels, [GNT_LIBS="$GNT_LIBS -lpanelw"],
 	    [enable_consoleui=no], [$GNT_LIBS])
 
With a modification to the ebuild:

diff -Naur /usr/portage/net-im/pidgin/pidgin-2.10.10.ebuild pidgin-2.10.10.ebuild 
--- /usr/portage/net-im/pidgin/pidgin-2.10.10.ebuild	2014-10-30 17:01:14.000000000 -0400
+++ pidgin-2.10.10.ebuild	2014-11-02 17:04:50.978395093 -0500
@@ -140,6 +140,7 @@
 	epatch "${FILESDIR}/${PN}-2.10.0-gold.patch" \
 		"${WORKDIR}/${PN}-eds-3.6.patch" \
 		"${FILESDIR}/${PN}-2.10.9-fix-gtkmedia.patch" \
+		"${FILESDIR}/${PN}-2.10.9-tinfow_fix.patch" \
 		"${FILESDIR}/${PN}-2.10.10-eds-3.6-configure.ac.patch"
 	epatch_user
Comment 7 Daniel Savard 2015-06-27 12:14:51 UTC
I wonder why this bug isn't still resolved in pidgin-2.10.11? The solution is known. Why it hasn't been implemented in the ebuild?
Comment 8 Justin Lecher gentoo-dev 2015-06-28 17:14:33 UTC
+  28 Jun 2015; Justin Lecher <jlec@gentoo.org>
+  +files/pidgin-2.10.11-tinfo.patch, pidgin-2.10.11.ebuild:
+  Add fix for ncurses[tinfo], bug #461482
+