Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 461448 - x11-drivers/nvidia-drivers-304.84, no vt console, tuxonice, or any framebuffers after X starts
Summary: x11-drivers/nvidia-drivers-304.84, no vt console, tuxonice, or any framebuffe...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Jeroen Roovers
URL: http://forums.gentoo.org/viewtopic-p-...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-11 20:22 UTC by Robert Cabrera
Modified: 2013-04-10 18:18 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Cabrera 2013-03-11 20:22:20 UTC
x11-drivers/nvidia-drivers-304.84 is causing anything having to do with framebuffer to fail after X starts and it is loaded. This is on my ~amd64 laptop.

For example, as my machine starts my framebuffer splash works beautifully and I can 'Alt+F2' to switch to 'verbose' mode to track start-up, however, after X starts and the Nvidia driver loads it's impossible to switch to a vt console using Ctrl+Alt+Fn, logout of my display manager (KDM) into a vt console, and both the logout splash and tuxonice fail to display anything all.

Once X starts and the nvidia driver loads all of the above actions result in a black blank screen with no graphics and no character display at all - none, nothing.

The only solution I've found was to go back to x11-drivers/nvidia-drivers-304.64 and the patches from this thread, bug 447566 however this also requires downgrading to < x11-base/xorg-server-1.14 because the previous nvidia-driver is incompatible with xorg-server-1.14.

This is probably an upstream issue, but I'm reporting it here, because it has now hit the Gentoo forums on this thread http://forums.gentoo.org/viewtopic-p-7265414.html#7265414

Reproducible: Always

Steps to Reproduce:
1. emerge -1 =x11-drivers/nvidia-drivers-304.84 (for legacy cards)
2. reboot
3. attempt to get a vt console or logout to vt console
Actual Results:  
Black blank screen with no display.

Expected Results:  
A usable vt console, and framebuffer graphics on exiting and with tuxonice.

My emerge --info
Portage 2.2.0_alpha166 (default/linux/amd64/13.0/desktop/kde, gcc-4.7.2, glibc-2.17, 3.7.5-pf x86_64)                                                                                                      
=================================================================                                                                                                                                          
System uname: Linux-3.7.5-pf-x86_64-Intel-R-_Core-TM-2_CPU_T7200_@_2.00GHz-with-gentoo-2.2                                                                                                                 
KiB Mem:     3337744 total,   1182716 free                                                                                                                                                                 
KiB Swap:    4200960 total,   4200868 free                                                                                                                                                                 
Timestamp of tree: Mon, 11 Mar 2013 17:45:01 +0000                                                                                                                                                         
ld GNU ld (GNU Binutils) 2.23.1                                                                                                                                                                            
app-shells/bash:          4.2_p45                                                                                                                                                                          
dev-java/java-config:     2.1.12-r1                                                                                                                                                                        
dev-lang/python:          2.7.3-r3, 3.2.3-r2                                                                                                                                                               
dev-util/cmake:           2.8.10.2-r1                                                                                                                                                                      
dev-util/pkgconfig:       0.28                                                                                                                                                                             
sys-apps/baselayout:      2.2                                                                                                                                                                              
sys-apps/openrc:          0.11.8                                                                                                                                                                           
sys-apps/sandbox:         2.6                                                                                                                                                                              
sys-devel/autoconf:       2.13, 2.69                                                                                                                                                                       
sys-devel/automake:       1.11.6, 1.13.1                                                                                                                                                                   
sys-devel/binutils:       2.23.1                                                                                                                                                                           
sys-devel/gcc:            4.7.2-r1                                                                                                                                                                         
sys-devel/gcc-config:     1.8                                                                                                                                                                              
sys-devel/libtool:        2.4.2                                                                                                                                                                            
sys-devel/make:           3.82-r4                                                                                                                                                                          
sys-kernel/linux-headers: 3.7 (virtual/os-headers)                                                                                                                                                         
sys-libs/glibc:           2.17                                                                                                                                                                             
Repositories: gentoo sunrise sabayon my_local_overlay                                                                                                                                                      
Installed sets: @nicefonts, @toolchain, @xorgupdate
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions /usr/share/themes/oxygen-gtk/gtk-2.0 /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=native"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs=2 --with-bdeps=y --keep-going --complete-graph --load-average=1.5"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs candy collision-protect config-protect-if-modified distlocks ebuild-locks fail-clean fixlafiles merge-sync multilib-strict news parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe -march=native"
GENTOO_MIRRORS="http://gentoo.netnitco.net http://gentoo.osuosl.org/ http://gentoo.mirrors.tds.net/gentoo http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/ http://gentoo.wetzlmayr.com/ http://osmirrors.cerias.purdue.edu/pub/gentoo/ http://www.cyberuse.com/gentoo/ http://gentoo.mirrors.hoobly.com/ ftp://gentoo.imj.fr/pub/gentoo/ http://130.59.10.35/ftp/mirror/gentoo/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2 -l1.5 -s"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /var/lib/layman/sabayon /usr/local/portage"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="X a52 aac aacplus aacs aalib acl acpi alsa amd64 amr avahi berkdb bidi bluetooth bluray branding bzip2 cairo cdda cddb cdio cdparanoia cdr cli consolekit cracklib crypt cups curl cvs cxx dbus declarative device-mapper dirac djvu dri dts dv dvd dvdr emboss encode exif faac fam ffmpeg firefox flac fontconfig fortran gdbm gif git gphoto2 gtk iconv idn ieee1394 imagemagick ipv6 java jbig joystick jpeg jpeg2k kde kipi lame lastfm lcms ldap libass libnotify libsamplerate live lua lzma lzo mad matroska mime mjpeg mms mmx mmxext mng modplug modules mp3 mp4 mpeg mudflap multilib musepack musicbrainz ncurses netlink nls nptl nsplugin ntp ogg openal openexr opengl openmp pam pango pcre pdf phonon plasma png policykit postproc ppds qalculate qt3support qt4 quicktime rar readline samba scanner schroedinger sdl semantic-desktop session smp sndfile sox speex spell sse sse2 sse3 ssl ssse3 startup-notification subversion svg symlink taglib tcpd telepathy theora tiff truetype twolame udev udisks unicode upower usb vcd vcdx vlm vnc vorbis vpx wavpack wicd wifi wmf wxwidgets x264 xa xcb xcomposite xinerama xml xscreensaver xv xvid xvmc zeroconf zlib" ABI_X86="64" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="evdev keyboard mouse synaptics joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_US" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" SANE_BACKENDS="epson epson2" USERLAND="GNU" VIDEO_CARDS="nvidia nv" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Jeroen Roovers gentoo-dev 2013-03-12 16:06:52 UTC
I can confirm I get blank VTs when I switch from an X server. Does it help to disable all FB support in your kernel?

Also, I get this in dmesg:

NVRM: Your system is not currently configured to drive a VGA console
NVRM: on the primary VGA device. The NVIDIA Linux graphics driver
NVRM: requires the use of a text-mode VGA console. Use of other console
NVRM: drivers including, but not limited to, vesafb, may result in
NVRM: corruption and stability problems, and is not supported.

Do you?
Comment 2 Robert Cabrera 2013-03-13 13:16:45 UTC
(In reply to comment #1)
> I can confirm I get blank VTs when I switch from an X server. Does it help
> to disable all FB support in your kernel?
> 
> Also, I get this in dmesg:
> 
> NVRM: Your system is not currently configured to drive a VGA console
> NVRM: on the primary VGA device. The NVIDIA Linux graphics driver
> NVRM: requires the use of a text-mode VGA console. Use of other console
> NVRM: drivers including, but not limited to, vesafb, may result in
> NVRM: corruption and stability problems, and is not supported.
> 
> Do you?

Jeroen, that dmesg output has been normal for as long as I can remember. Nvidia has never officially supported any kernel video driver except for the basic vga text-mode, however, both the vesafb and uvesafb have worked without problems in the past.

I don't know what has changed with this driver but I will continue to investigate for a solution, maybe one of the other distros has answers.
Comment 3 Kamen Dokov 2013-03-14 21:07:40 UTC
I can confirm this on my 
01:00.0 VGA compatible controller: NVIDIA Corporation G71 [GeForce 7950 GT] (rev a1)

!
Comment 4 Jeroen Roovers gentoo-dev 2013-03-16 18:41:26 UTC
Even with only the VGA Text Console (so no framebuffer drivers in use) I get corrupted vts. Maybe the Nvidia forums reports similar experiences?
Comment 5 quazgar 2013-03-16 20:50:32 UTC
A similar bug as the one mentioned here on the forum:  https://forums.gentoo.org/viewtopic-t-925156.html

Problem appears for me with this device:

00:05.0 VGA compatible controller: NVIDIA Corporation C51 [Quadro NVS 210S/GeForce 6150LE] (rev a2)
Comment 6 Account Disabled (uid 86422) 2013-04-06 23:24:48 UTC
I can confirm this bug on 00:0d.0 VGA compatible controller: NVIDIA Corporation C61 [GeForce 7025 / nForce 630a] (rev a2) using nvidia-drivers-304.84 with gentoo-sources-3.7.10.

I just have a blank black screen and a blinking cursor. I tested with uvesafb as framebuffer and without it. In both cases the vt is unusable after starting kdm.

After upgrading to nvidia-drivers-304.88 the problem is solved for me.

Here my emerge --info
Portage 2.1.11.55 (default/linux/amd64/13.0/desktop/kde, gcc-4.6.3, glibc-2.15-r3, 3.7.10-gentoo x86_64)
=================================================================
System uname: Linux-3.7.10-gentoo-x86_64-AMD_Athlon-tm-_II_X4_640_Processor-with-gentoo-2.1
KiB Mem:     3792588 total,    599480 free
KiB Swap:    4915196 total,   4915196 free
Timestamp of tree: Sat, 06 Apr 2013 12:45:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo gamerlay steam-overlay hasufell x-portage
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="-j5"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/gamerlay /var/lib/layman/steam /var/lib/layman/hasufell /usr/local/portage"
SYNC="rsync://rsync6.de.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi alsa amd64 berkdb branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm iconv ipv6 jpeg kde kipi lcms ldap libnotify mad mmx mmxext mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds qt3support qt4 readline sdl semantic-desktop session spell sse sse2 sse4a ssl startup-notification svg tcpd threads tiff truetype udev unicode upower usb vorbis wxwidgets x264 xcb xcomposite xinerama xml xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="lvm syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 7 Jeroen Roovers gentoo-dev 2013-04-08 11:54:31 UTC
I can't seem to confirm the consoles return after the driver upgrade, but then I haven't rebooted the system yet, so maybe I get better results after that. Anyone else?
Comment 8 Jeroen Roovers gentoo-dev 2013-04-10 18:18:25 UTC
After a reboot, I can get back from X to a console. Assume this is fixed for everybody.