Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 460006 - dev-db/metakit-2.4.9.7-r1 with tcl-8.6: mk4tcl.cpp:982:39: error: invalid conversion from ‘const Tcl_ObjType*’ to ‘Tcl_ObjType*’ [-fpermissive]
Summary: dev-db/metakit-2.4.9.7-r1 with tcl-8.6: mk4tcl.cpp:982:39: error: invalid con...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords: NeedPatch
Depends on:
Blocks: tcltk-8.6
  Show dependency tree
 
Reported: 2013-03-02 16:58 UTC by Juergen Rose
Modified: 2015-03-20 09:49 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
/var/tmp/portage/dev-db/metakit-2.4.9.7-r1/temp/build.log (build.log,6.89 KB, text/plain)
2013-03-02 16:58 UTC, Juergen Rose
Details
build.log (build.log,8.05 KB, text/x-log)
2014-12-28 17:29 UTC, Juergen Rose
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen Rose 2013-03-02 16:58:40 UTC
Created attachment 340774 [details]
/var/tmp/portage/dev-db/metakit-2.4.9.7-r1/temp/build.log

'emerge metakit' fails with:
...
x86_64-pc-linux-gnu-g++ -c -march=amdfam10 -O2 -pipe -fPIC -Iunix/../include -I/usr/include/generic -I/usr/include unix/../tcl/mk4too.cpp
unix/../tcl/mk4tcl.cpp: In function ‘const c4_Property& AsProperty(Tcl_Obj*, const c4_View&)’:
unix/../tcl/mk4tcl.cpp:982:39: error: invalid conversion from ‘const Tcl_ObjType*’ to ‘Tcl_ObjType*’ [-fpermissive]
unix/../tcl/mk4tcl.cpp: In function ‘int SetCursorFromAny(Tcl_Interp*, Tcl_Obj*)’:
unix/../tcl/mk4tcl.cpp:1086:39: error: invalid conversion from ‘const Tcl_ObjType*’ to ‘Tcl_ObjType*’ [-fpermissive]
unix/../tcl/mk4tcl.cpp:1100:51: warning: cast to pointer from integer of different size [-Wint-to-pointer-cast]
unix/../tcl/mk4tcl.cpp: In member function ‘int MkTcl::LoopCmd()’:
unix/../tcl/mk4tcl.cpp:2159:65: error: ‘Tcl_Interp’ has no member named ‘errorLine’
make: *** [mk4tcl.o] Error 1
make: *** Waiting for unfinished jobs....
unix/../tcl/mk4too.cpp: In static member function ‘static int MkView::Dispatcher(ClientData, Tcl_Interp*, int, Tcl_Obj* const*)’:
unix/../tcl/mk4too.cpp:23:75: warning: deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
unix/../tcl/mk4too.cpp: In member function ‘int MkView::SearchCmd()’:
unix/../tcl/mk4too.cpp:401:68: warning: deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
unix/../tcl/mk4too.cpp: In member function ‘int MkView::LoopCmd()’:
unix/../tcl/mk4too.cpp:615:67: error: ‘Tcl_Interp’ has no member named ‘errorLine’
make: *** [mk4too.o] Error 1
 * ERROR: dev-db/metakit-2.4.9.7-r1 failed (compile phase):




root@impala:/root(57)# emerge --info '=dev-db/metakit-2.4.9.7-r1'
Portage 2.1.11.53 (default/linux/amd64/13.0, gcc-4.6.3, glibc-2.16.0, 3.8.0-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.8.0-gentoo-x86_64-AMD_Phenom-tm-_II_X4_965_Processor-with-gentoo-2.2
KiB Mem:     8165668 total,    925824 free
KiB Swap:   50347696 total,  50200172 free
Timestamp of tree: Sat, 02 Mar 2013 06:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p42
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.10.2-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6, 1.12.6, 1.13.1
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.8 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo x11 science sage-on-gentoo sunrise lisp lordvan sabayon x-portage x-cpan g-octave
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL Intel-SDP dlj-1.1 skype-eula skype-4.0.0.7-copyright googleearth AdobeFlash-11.x cadsoft Oracle-BCLA-JavaSE MakeMKV-EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=amdfam10 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/x11 /var/lib/layman/science /var/lib/layman/sage-on-gentoo /var/lib/layman/sunrise /var/lib/layman/lisp /var/lib/layman/lordvan /var/lib/layman/sabayon /usr/local/portage /var/lib/cpan /var/lib/g-octave"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext 64bit R X Xaw3d a52 aac accessibility acl acpi admin afs alsa amd64 ao apache2 apng applet archive armadillo arpack asf aspell assistant atlas audacious audiofile automap automount bash-completion berkdb blas blast bluetooth bluray boo boost bzip2 cairo cdda cddb cdf cdio cdparanoia cdr cg cgi chm cli consolekit corba cracklib crypt css cuda cups curl cxx daap db dbi dbm dbus declarative designer devhelp device-mapper dga dia dirac djvu doc dot dri ds2490 ds9097 ds9097u dts dv dvb dvd dvdr dvi dynamicplugin eds egl elf emacs emboss emf encode epiphany evo examples exif expat extensions extra extras faac faad fam ffmpeg fftw firefox fits flac fltk fontconfig foomaticdb fortran fortran95 fpm fpx fts3 fuse g3dvl gcj gd gdal gdbm gdu gedit geoip geolocation geos gfortran gif gimp git glade glib glpk gml gmp gnome gnome-keyring gnome-print gnuplot gnutls gold gphoto2 gpm grammar graphics graphtft graphviz grass gsl gsm gstreamer gtk gtk3 gudev guile harness hddtemp hdf hdf5 hdri html http httpd hvm hwdb iconv icq icu id3 id3tag ide imagemagick imap inotify introspection ipod ipv6 ithreads jabber jadetex java java6 jbig john jpeg jpeg2k kate kde kdepim kdrive kerberos keymap kpathsea kqemu kvm ladspa lame lapack latex lcms ldap lensfun libffi libkms libnotify libsamplerate live lm_sensors lua lzo mad mail maildir mapnik math matroska media-library mercurial mikmod mkl mmx mmxext mng mod modules mono motif mozilla mp3 mp4 mpeg mpi mplayer mtp mudflap multilib musepack musicbrainz mysql mysqli nautilus ncurses netcdf netpbm network networking networkmanager nfs nls nntp nptl nsplugin ntfs ntp numpy nvidia obex objc ocaml ocr octave odbc ofa ogdi ogg openexr opengl openmp overview pam pcre pda pdf perl plasma plotutils plugins png podcast policykit portaudio posix postgres postscript ppds preview-latex proj projectm projectx pstricks pulseaudio python python-bindings q16 q32 qemu qhull qt3support qt4 quicktime raw readline reiserfs reports rhythmbox rle romio rpc rrdcgi rrdtool sage samba sasl schroedinger science sdk sdl secure-delete semantic-desktop server session shout sip slang slp smart smbclient smp sms sndfile snmp soap sockets sound soup sox speex spell sql sqlite sse sse2 sse4a ssl stlport subtitles subversion sudo suexec svg svm swig szip t1lib tcl tcpd tex tex4ht texmacs tgif theora thesaurus threads thunderbird tidy tiff tk tools truetype udev udisks unicode usb userlocales utempter v4l vaapi vala vdpau video virt-network virtualbox visio vorbis vpx wav webdav webdav-serf webkit wmf wxwidgets x264 xa xattr xcb xemacs xetex xext xft xine xml xmlreader xmlrpc xpm xv xvid xvmc yaml youtube zlib zvbi" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_core authn_dbm authn_default authn_file authz_core authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgid dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info lbmethod_byrequests log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif slotmem_shm so socache_shmcb speling status unique_id unixd userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="canon fuji ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="nss" DRACUT_MODULES="caps lvm mdraid syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de fr ru" NETBEANS_MODULES="apisupport cnd dlight enterprise ergonomics groovy gsf harness ide identity j2ee java mobility nb php profiler ruby websvccommon xml" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="arm i386 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON




root@impala:/root(58)# emerge -pqv '=dev-db/metakit-2.4.9.7-r1'
[ebuild  N    ] dev-db/metakit-2.4.9.7-r1  USE="python tcl -static"
Comment 1 Pacho Ramos gentoo-dev 2013-10-13 16:20:11 UTC
I cannot reproduce with gcc-4.7 :/
Comment 2 Juergen Rose 2013-10-13 17:35:31 UTC
I have still the same issue, now with gcc-4.7.3-r1:
...
x86_64-pc-linux-gnu-g++ -c -march=amdfam10 -O2 -pipe -fPIC -Iunix/../include -I/usr/include/generic -I/usr/include unix/../tcl/mk4too.cpp
unix/../tcl/mk4too.cpp: In static member function ‘static int MkView::Dispatcher(ClientData, Tcl_Interp*, int, Tcl_Obj* const*)’:
unix/../tcl/mk4too.cpp:23:75: warning: deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
unix/../tcl/mk4too.cpp: In member function ‘int MkView::SearchCmd()’:
unix/../tcl/mk4too.cpp:401:68: warning: deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]
unix/../tcl/mk4too.cpp: In member function ‘int MkView::LoopCmd()’:
unix/../tcl/mk4too.cpp:615:67: error: ‘Tcl_Interp’ has no member named ‘errorLine’
make: *** [mk4too.o] Error 1
make: *** Waiting for unfinished jobs....
unix/../tcl/mk4tcl.cpp: In function ‘const c4_Property& AsProperty(Tcl_Obj*, const c4_View&)’:
unix/../tcl/mk4tcl.cpp:982:39: error: invalid conversion from ‘const Tcl_ObjType*’ to ‘Tcl_ObjType*’ [-fpermissive]
unix/../tcl/mk4tcl.cpp: In function ‘int SetCursorFromAny(Tcl_Interp*, Tcl_Obj*)’:
unix/../tcl/mk4tcl.cpp:1086:39: error: invalid conversion from ‘const Tcl_ObjType*’ to ‘Tcl_ObjType*’ [-fpermissive]
unix/../tcl/mk4tcl.cpp:1100:51: warning: cast to pointer from integer of different size [-Wint-to-pointer-cast]
unix/../tcl/mk4tcl.cpp: In member function ‘int MkTcl::LoopCmd()’:
unix/../tcl/mk4tcl.cpp:2159:65: error: ‘Tcl_Interp’ has no member named ‘errorLine’
make: *** [mk4tcl.o] Error 1
 * ERROR: dev-db/metakit-2.4.9.7-r1::gentoo failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=dev-db/metakit-2.4.9.7-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-db/metakit-2.4.9.7-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-db/metakit-2.4.9.7-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-db/metakit-2.4.9.7-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-db/metakit-2.4.9.7-r1/work/metakit-2.4.9.7'
 * S: '/var/tmp/portage/dev-db/metakit-2.4.9.7-r1/work/metakit-2.4.9.7'

>>> Failed to emerge dev-db/metakit-2.4.9.7-r1, Log file:

>>>  '/var/tmp/portage/dev-db/metakit-2.4.9.7-r1/temp/build.log'
root@impala:/root(14)# gcc -v
Using built-in specs.
COLLECT_GCC=/usr/x86_64-pc-linux-gnu/gcc-bin/4.7.3/gcc
COLLECT_LTO_WRAPPER=/usr/libexec/gcc/x86_64-pc-linux-gnu/4.7.3/lto-wrapper
Target: x86_64-pc-linux-gnu
Configured with: /var/tmp/portage/sys-devel/gcc-4.7.3-r1/work/gcc-4.7.3/configure --prefix=/usr --bindir=/usr/x86_64-pc-linux-gnu/gcc-bin/4.7.3 --includedir=/usr/lib/gcc/x86_64-pc-linux-gnu/4.7.3/include --datadir=/usr/share/gcc-data/x86_64-pc-linux-gnu/4.7.3 --mandir=/usr/share/gcc-data/x86_64-pc-linux-gnu/4.7.3/man --infodir=/usr/share/gcc-data/x86_64-pc-linux-gnu/4.7.3/info --with-gxx-include-dir=/usr/lib/gcc/x86_64-pc-linux-gnu/4.7.3/include/g++-v4 --host=x86_64-pc-linux-gnu --build=x86_64-pc-linux-gnu --disable-altivec --disable-fixed-point --without-cloog --without-ppl --disable-lto --enable-nls --without-included-gettext --with-system-zlib --enable-obsolete --disable-werror --enable-secureplt --enable-multilib --with-multilib-list=m32,m64 --enable-libmudflap --disable-libssp --enable-libgomp --with-python-dir=/share/gcc-data/x86_64-pc-linux-gnu/4.7.3/python --enable-checking=release --enable-java-awt=gtk --enable-libstdcxx-time --enable-languages=c,c++,java,objc,fortran --enable-shared --enable-threads=posix --enable-__cxa_atexit --enable-clocale=gnu --enable-targets=all --with-bugurl=http://bugs.gentoo.org/ --with-pkgversion='Gentoo 4.7.3-r1 p1.3, pie-0.5.5'
Comment 3 Juergen Rose 2013-10-13 17:36:22 UTC
And I have the issue at least on two systems.
Comment 4 Pacho Ramos gentoo-dev 2013-10-13 19:14:24 UTC
What tcl version are you running? I have:
$ emerge -Opv tcl

These are the packages that would be merged, in order:

[ebuild   R    ] dev-lang/tcl-8.5.13-r1  USE="threads -debug" 0 kB
Comment 5 Juergen Rose 2013-10-13 20:07:13 UTC
root@condor:/root(25)# emerge -Opv tcl

These are the packages that would be merged, in order:

[ebuild   R    ] dev-lang/tcl-8.6.1:0/8.6  USE="threads -debug" 0 kB


root@impala:/root(17)# emerge -Opv tcl

These are the packages that would be merged, in order:

[ebuild   R    ] dev-lang/tcl-8.6.1:0/8.6  USE="threads -debug" 0 kB
Comment 6 Juergen Rose 2014-12-28 17:18:00 UTC
The same happens now at the next system with metakit-2.4.9.7-r2 and tcl-8.6.3:

x86_64-pc-linux-gnu-g++ -c -march=native -O2 -pipe -fPIC -Iunix/../include -I/usr/include/generic -I/usr/include unix/../tcl/mk4tcl.cpp
unix/../tcl/mk4tcl.cpp: In function ‘const c4_Property& AsProperty(Tcl_Obj*, const c4_View&)’:
unix/../tcl/mk4tcl.cpp:982:39: error: invalid conversion from ‘const Tcl_ObjType*’ to ‘Tcl_ObjType*’ [-fpermissive]
     Tcl_ObjType *oldTypePtr = objPtr->typePtr;
                                       ^
unix/../tcl/mk4tcl.cpp: In function ‘int SetCursorFromAny(Tcl_Interp*, Tcl_Obj*)’:
unix/../tcl/mk4tcl.cpp:1086:39: error: invalid conversion from ‘const Tcl_ObjType*’ to ‘Tcl_ObjType*’ [-fpermissive]
     Tcl_ObjType *oldTypePtr = objPtr->typePtr;
                                       ^
unix/../tcl/mk4tcl.cpp:1100:51: warning: cast to pointer from integer of different size [-Wint-to-pointer-cast]
     objPtr->internalRep.twoPtrValue.ptr1 = (void*)i;
                                                   ^
unix/../tcl/mk4tcl.cpp: In member function ‘int MkTcl::LoopCmd()’:
unix/../tcl/mk4tcl.cpp:2159:65: error: ‘Tcl_Interp’ has no member named ‘errorLine’
         sprintf(msg, "\n  (\"mk::loop\" body line %d)", interp->errorLine);
                                                                 ^
Makefile:185: recipe for target 'mk4tcl.o' failed
make: *** [mk4tcl.o] Error 1
 * ERROR: dev-db/metakit-2.4.9.7-r2::gentoo failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=dev-db/metakit-2.4.9.7-r2::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-db/metakit-2.4.9.7-r2::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-db/metakit-2.4.9.7-r2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-db/metakit-2.4.9.7-r2/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-db/metakit-2.4.9.7-r2/work/metakit-2.4.9.7'
 * S: '/var/tmp/portage/dev-db/metakit-2.4.9.7-r2/work/metakit-2.4.9.7'

>>> Failed to emerge dev-db/metakit-2.4.9.7-r2, Log file:

>>>  '/var/tmp/portage/dev-db/metakit-2.4.9.7-r2/temp/build.log'

root@lynx:/usr/local/portage/app-office(99)# emerge -Opv tcl

These are the packages that would be merged, in order:

[ebuild   R    ] dev-lang/tcl-8.6.3:0/8.6  USE="threads -debug" ABI_X86="(64) -32 (-x32)" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB





root@lynx:/usr/local/portage/app-office(100)# emerge --info '=dev-db/metakit-2.4.9.7-r2::gentoo'
Portage 2.2.15 (python 2.7.9-final-0, default/linux/amd64/13.0/desktop, gcc-4.8.4, glibc-2.20, 3.18.1-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.18.1-gentoo-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T9500_@_2.60GHz-with-gentoo-2.2
KiB Mem:     8117052 total,   3110284 free
KiB Swap:   12582908 total,  12534048 free
Timestamp of tree: Sat, 27 Dec 2014 12:30:01 +0000
sh bash 4.3_p30-r1
ld GNU ld (Gentoo 2.24 p1.4) 2.24
distcc[23615] (dcc_trace_version) distcc 3.2rc1 x86_64-pc-linux-gnu; built Nov  8 2014 22:04:02 [disabled]
app-shells/bash:          4.3_p30-r1
dev-java/java-config:     2.2.0
dev-lang/perl:            5.20.1-r4
dev-lang/python:          2.7.9-r1, 3.3.5-r1, 3.4.2
dev-util/cmake:           3.0.2
dev-util/pkgconfig:       0.28-r2
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.13.6
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r4, 1.10.3-r1, 1.11.6-r1, 1.12.6, 1.14.1
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.8.4
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.4
sys-devel/make:           4.1-r1
sys-kernel/linux-headers: 3.17-r1 (virtual/os-headers)
sys-libs/glibc:           2.20
Repositories: gentoo sage-on-gentoo science sunrise x11 ago tlp local g-cpan g-octave
Installed sets: @system
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL Intel-SDP dlj-1.1 skype-eula skype-4.0.0.7-copyright googleearth AdobeFlash-11.x cadsoft Oracle-BCLA-JavaSE MakeMKV-EULA NVIDIA-CUDA Nero-AAC-EULA GIMPS"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=native -O2 -pipe"
GENTOO_MIRRORS="http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo ftp://ftp.tu-clausthal.de/pub/linux/gentoo ftp://ftp.easynet.nl/mirror/gentoo/ "
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage_lynx"
PORTDIR_OVERLAY="/var/lib/layman/sage-on-gentoo /var/lib/layman/science /var/lib/layman/sunrise /var/lib/layman/x11 /var/lib/layman/ago /var/lib/layman/tlp /usr/local/portage /var/lib/cpan /var/lib/g-octave"
USE="64bit R X Xaw3d a52 aac acl acpi admin afs alsa amd64 ao apache2 apng applet archive armadillo arpack asf aspell atlas audacious audiofile automap automount bash-completion berkdb blas blast bluetooth bluray boost branding bzip2 cairo cdda cddb cdf cdio cdparanoia cdr cg cgi chm cli cmake consolekit cracklib crypt css cups curl cxx daap db dbi dbm dbus declarative designer devhelp device-mapper dga dia dirac djvu doc dot dri ds2490 ds9097 ds9097u dts dv dvb dvd dvdr dvi dynamicplugin eds egl elf emacs emboss emf encode epiphany evo examples exif expat extensions extra extras faac faad fam ffmpeg fftw firefox fits flac fltk fontconfig foomaticdb fortran fortran95 fpm fpx fuse g3dvl garmin gcj gd gdal gdbm gdu gedit geoip geolocation geos gfortran gif gimp git glade glamor glib glpk gml gmp gnome gnome-keyring gnome-print gnuplot gnutls gold gphoto2 gpm grammar graphics graphtft graphviz grass gsl gsm gstreamer gtk gtk3 gudev guile hdaps hddtemp hdf hdf5 hdri html http httpd hvm hwdb iconv icq icu id3tag ide imagemagick imap inotify introspection ipod ipv6 irda ithreads jabber jadetex java java6 jbig jit john jpeg jpeg2k kate kde kdepim kdrive kerberos keymap kpathsea kvm ladspa lame lapack laptop latex lcms ldap lensfun libffi libkms libnotify libsamplerate lirc live lua lzma lzo mad mail maildir mapnik math matroska media-library mercurial mikmod mkl mmx mmxext mng mod modules mono motif mozilla mp3 mp4 mpeg mpi mplayer mtp multilib multimedia musepack musicbrainz mysql mysqli nautilus ncurses neXt netcdf netpbm network networking nfs nls nntp nptl nsplugin ntfs ntp numpy obex objc ocaml ocr octave odbc ofa ogdi ogg openexr opengl openmp openvg pam pango pcre pda pdf pdl2 perl plasma plotutils plugins png podcast policykit portaudio posix postgres postscript ppds preview-latex proj projectm pstricks pulseaudio python python-bindings q16 q32 qemu qhull qt3support qt4 quicktime raw readline reiserfs reports rle romio rpc rrdcgi rrdtool sage samba sasl schroedinger science sdk sdl secure-delete semantic-desktop server session shout sip slang slp smart smbclient smp sms sndfile snmp soap sockets sound soup sox speex spell sql sqlite sse sse2 sse4 sse4_1 ssl ssse3 startup-notification stlport subtitles subversion sudo suexec svg svm swig systemd szip t1lib tcl tcpd tex tex4ht texmacs theora thesaurus thinkpad threads thunderbird tidy tiff tk tools truetype udev udisks unicode upower usb utempter v4l vaapi vala valgrind vdpau video virt-network virtualbox visio vorbis vpx vtk wav webdav webdav-serf webkit wifi wmf wxwidgets x264 xa xattr xcb xetex xext xft xine xml xmlreader xmlrpc xpm xv xvid xvmc yaml youtube zlib zvbi" ABI_X86="64" ALSA_CARDS="intel8x0" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_core authn_dbm authn_default authn_file authz_core authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgid dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info lbmethod_byrequests log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif slotmem_shm so socache_shmcb speling status unique_id unixd userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="canon fuji ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog sensors thermal" CURL_SSL="nss" DRACUT_MODULES="caps lvm syslog" DVB_CARDS="usb-wt220u" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev synaptics void" KERNEL="linux" LCD_DEVICES="cfontz hd44780 mtxorb ncurses X lcd2usb lcdlinux png usblcd" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de fr ru" NETBEANS_MODULES="apisupport cnd dlight enterprise ergonomics groovy gsf harness ide identity j2ee java mobility nb php profiler websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" QEMU_SOFTMMU_TARGETS="arm i386 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="nouveau displaylink" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON



root@lynx:/usr/local/portage/app-office(101)# emerge -pqv '=dev-db/metakit-2.4.9.7-r2::gentoo'
[ebuild     U ] dev-db/metakit-2.4.9.7-r2 [2.4.9.7-r1] USE="python tcl -static" PYTHON_TARGETS="python2_7%*"
Comment 7 Juergen Rose 2014-12-28 17:29:38 UTC
Created attachment 392586 [details]
build.log
Comment 8 Juergen Rose 2015-01-10 22:48:46 UTC
The same happens with metakit-2.4.9.7-r2.
Comment 9 Justin Lecher gentoo-dev 2015-03-20 09:49:00 UTC
+  20 Mar 2015; Justin Lecher <jlec@gentoo.org>
+  +files/metakit-2.4.9.7-tcltk86.patch, metakit-2.4.9.7-r2.ebuild:
+  Fix for tcltk8.6, bug #460006; fix correct usage of python eclasses, bug
+  #541796
+