Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 458738 - Stable x11-drivers/nvidia-drivers-304.64 not compatible with stable gentoo-sources-3.7.9
Summary: Stable x11-drivers/nvidia-drivers-304.64 not compatible with stable gentoo-so...
Status: RESOLVED DUPLICATE of bug 447566
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Doug Goldstein
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-22 13:48 UTC by Marek Szuba
Modified: 2013-02-22 14:29 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marek Szuba gentoo-dev 2013-02-22 13:48:55 UTC
To begin with, a digression: according to the warning in the ebuilds of even the latest versions of nvidia-drivers available in Portage, kernels newer than 3.6 are not officially supported by Gentoo. The warning ends with ominous "you're on your own". Given 3.7 kernels are now marked stable on both amd64 and x86, this warning could perhaps be formulated somewhat better.

Back to the main issue, though. Version 304.64, i.e. the latest one marked stable on amd64, doesn't just leave people on their own - it just doesn't build. An "unable to determine the target kernel version" appears at the very beginning of preparing the nvidia module and that's it.

Emerging the latest amd64-unstable version, 313.18, works fine. Haven't tried hacking the makefiles of the stable version to get the test to pass.

Let me know if you need any more information.
Comment 1 Chí-Thanh Christopher Nguyễn gentoo-dev 2013-02-22 13:57:46 UTC
For the build failure, see bug 447566.
For the stabilization of newer nvidia-drivers, see bug 458666.
Comment 2 Doug Goldstein gentoo-dev 2013-02-22 14:29:53 UTC

*** This bug has been marked as a duplicate of bug 447566 ***