Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 458598 - media-gfx/asymptote-2.21 USE="doc latex" - ../base/plain_shipout.asy: 82.10: runtime: shipout failed
Summary: media-gfx/asymptote-2.21 USE="doc latex" - ../base/plain_shipout.asy: 82.10: ...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Andrey Grozin
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-21 14:48 UTC by MaratIK
Modified: 2015-11-11 10:05 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,60.63 KB, text/plain)
2013-02-21 14:49 UTC, MaratIK
Details
build.log (build.log,53.23 KB, text/plain)
2013-02-22 09:49 UTC, MaratIK
Details
diatom_.tex on my computer (diatom_.tex,10.94 KB, text/plain)
2013-02-22 15:17 UTC, Andrey Grozin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description MaratIK 2013-02-21 14:48:48 UTC
emerge failed media-gfx/asymptote-2.21 with USE="doc latex" when latex processes file diatom.tex

Reproducible: Always

Steps to Reproduce:
USE="doc latex" emerge =media-gfx/asymptote-2.21
Actual Results:  
Runaway argument?
{\vphantom {$10^4$}\definecolor {ASYcolor}{gray}{0.000000}\color {ASY\ETC.
! File ended while scanning use of \ASYalign.
<inserted text>
                \par
<*> \scrollmode\input diatom_.tex


*
! Emergency stop.
<*> \scrollmode\input diatom_.tex

No pages of output.
Transcript written on diatom_.log.
../base/plain_shipout.asy: 82.10: runtime: shipout failed
make: *** [diatom.pdf] Ошибка 1
 * ERROR: media-gfx/asymptote-2.21 failed (compile phase):
 *   emake failed


Expected Results:  
Emerge works fine.

$ sudo emerge --info asymptote
Password:
Portage 2.2.0_alpha163 (default/linux/amd64/13.0/desktop/kde, gcc-4.6.3, glibc-2.15-r3, 3.6.11-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.6.11-gentoo-x86_64-AMD_Athlon-tm-_II_X4_640_Processor-with-gentoo-2.1
KiB Mem:     8169896 total,   1926728 free
KiB Swap:    6291932 total,   6278052 free
Timestamp of tree: Thu, 21 Feb 2013 06:00:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r2, 3.2.3-r2
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo science steam-overlay local
Installed sets: @system
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /lib/rc/net /lib/udev /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /var/lib/hsqldb /var/spool/torque"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/games/angband/edit/ /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=native"
DISTDIR="/var/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync metadata-transfer news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-O2 -pipe -march=native"
GENTOO_MIRRORS="http://mirror2.corbina.ru/gentoo-distfiles/ http://mirror.yandex.ru/gentoo-distfiles/ http://distfiles.gentoo.org"
LANG="ru_RU.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/science /usr/local/portage/layman/steam /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="32bit 3dnow 3dnowext 3ds 64bit R S3TC X X509 Xaw3d a52 aac aacplus aacs aalib accessibility acl acpi adns aesicm aften aio akonadi alisp all_sfx alsa amd64 amr analitza android ant ao aplaymidi apng archive ares armadillo artworkextra aspell ass assistant async asyncns atm atmo attica audacious audio audiofile auto-completion autoipd autotools autotrace avalon-framework avalon-logkit avconv bash-completion bazaar bcmath berkdb bineditor binfilter bittorrent bl blas blender-game bluetooth bluray boehm-gc bonusscripts bookmarks boost branding bs2b bsf bugzilla bzip2 cacao cairo calendar caps cblas-external cdda cddb cdf cdinstall cdio cdparanoia cdr cdrom cdsound cg cgc cgi charconv chardet chipcard chm cleartype cli clisp clucene cmake collab color colord colordiff combination-explosion-check common-lisp commons-digester commonslogging commonsnet compress compressed-lumas consolekit context contrast contrib coverage cracklib creds crnl-as-line-terminator cron crypt cscope csharp css csv ctype ctypes-python cuda cue cups curl curlwrappers cursors cvs cvsgraph cxx d dap darcs data dbi dbus dc1394 ddate debugger declarative demosaic derby designer designer-plugin desktopglobe detex dev-doc development devhelp device-mapper dhcp dia dirac diskio djbfft djvu doc docbook doctool dot drawing dselect dssi dts dv dvd dvdr dvi dvi2tty dvipdfm eap-tls ebook eclipse ecwj2k edd editor egl eigen elf elisp emacs emboss emerald emovix enca enchant encode epydoc equalizer espeak examples excel exceptions exif expat expoblending extensions extra extra-algorithms extra-cardsets extra-webapps extras faac faad facedetect fam fat festival ffmpeg fftw filter finger firefox firefox-bookmarks firefox3 fits flac flash flickr floppy fltk fluidsynth fontconfig fontforge foomaticdb fortran fortran2003 fox fpm fpx freetts freetype frei0r ftp fts3 fuse g3dvl galago games gcdmaster gcode gconf gcrypt gd gdal gdbm gdu geoip geos ggi gif gimp ginac git gjdoc gkrellm glade glew glib glibc-omitfp glsl glut gme gml gmm gmp gnet gnome gnumeric gnuplot gnutls go gold google google-gadgets gopher gpac gpg gphoto2 gpm gps gpu grammar graph graphics graphicsmagick graphite graphviz grp gs gsf gsl gsm gstreamer gtk gtk3 gtkhtml gtkspell gtkstyle guile gunit gusb gzip hardcoded-tables hash hbci hddtemp hdf hdf5 hdri health help highlight hipe hog hou howl-compat hpijs hpn hscolour html http httpd humanities hunspell hybrid-auth hyperestraier hyphenation i18n ical icons iconv icoutils icq icu id3 id3tag ide idn ieee1394 ifc ilbc image image-cache imagemagick imaging imlib infinality inkjar inotify int64 intl introspection iodbc iostats iplayer ipp iptc ipv6 ipython isag ithreads itk j2me jabber jadetex jai jamvm java java6 javamail javascript jbig jce jemalloc jingle jmf jms jmx joystick jpeg jpeg2k jsapi json judy kate kde kdecards kdenlive kdepim kdm kdrive kernel-patch keychain kig-scripting kipi kontact kpathsea kpoll ladspa lame lapack larcsim lash lasi latex latex3 lcms libass libcaca libcanberra libdsk libedit libffi libgda libkms libmpeg2 libnotify libproxy libsamplerate libssh2 libtiger libv4l libv4l2 libvisual libwww live llvm llvm-gcc lm_sensors log log4j logrotate lpsol lto lua lua-cairo lua-imlib luatex lyx lzma lzo m4lib-png mad maemo6 magic man maps marble math mathml matplotlib matroska mbrola mclib md5sum mdb mdev mdnsresponder-compat mediawiki melt mercurial metalink metis metric mfd-rewrites mhash midi mikmod mime minizip mixer mjpeg mkl mmap mms mmx mmxext mng mod modplug modules mono monolithic-build motif mozilla mozsha1 mp3 mp3tunes mp4 mpd mpeg mpg123 mpi mpi-threads mpi_njtree mplayer msn mtp mudflap multicall multilib multimedia multiuser musepack music musicbrainz mvl mysql nano-syntax nas natspec nautilus ncat ncurses ndiff neXt nelma netbeans netcdf netlink netpbm network networking new-clx nio2 nlpsolver nls nntp nocd nowin nping npp nptl nsplugin nss ntfs ntfsprogs ntlm ntp numpy nut nuv nvidia ocaml oci8 oci8-instant-client octave odbc odbcmanual odk ods offensive offscreen ofx ogg ogg123 ogm okteta okular omega openal opencl openexr opengl opengtl openinventor openmp openssl opensslcrypt openvg openxml optimization optimized-qmake opus oracle orc oscar osgapps osmesa ots ovftool pam pam_ssh pango panorama pari parport pbs pcap pcntl pcre pda pdf pdfannotextractor pdfimport pdo perforce perl perl-geoipupdate pgo phonon php physfs pkcs11 plasma player playlist playtools plotutils plugins pnat png pnm policykit posix postproc postscript ppds ppp prediction preview-latex prison private-headers profiler projectm pronounce ps pstricks pth publishers pulseaudio pvr pyglet python python3 pyzord q8 qalculate qhull qimageblitz qpak qscintilla qt-dbus qt-faststart qt-webkit qt3support qt4 qthelp qtscript quicktime quotes quvi qwt rar raster raw rcs rdesktop readline recode redeyes reiserfs remoteosd reports resolvconf reviewboard rfc3779 rle romio rpc rpm rrdcgi rrdtool rss rtaudio rtc rtf rtmp rtsp ruby ruby-bindings rups s3tc samba sasl scale0tilt scanner schematics schroedinger science screen script scripttools scrobbler sctp sdk sdl sdl-image sdl-sound sdlaudio sdlgfx secure-delete security semantic-desktop sendto sensord sep-usr server servletapi session sftp sharedext sharedmem shine shm shmvideo shout sid sift simplexml skins slang smi smp smpeg sms smux sndfile soap sockets socks5 solver sou sound soundex sounds soundtouch soup source sourceview sox sparse spatialite speech speex spell sql sqlite sqlite3 srt srtp sse sse2 sse3 sse4a ssh ssl startup-notification steamgames_tf2 steamgames_unwritten_tales stream subunit subversion suhosin suid supernodal svg swat swfdec swig sysfs syslog system-sqlite sysvipc szip t1lib tads2compiler tads3compiler taglib tcl tcpd tdbtest templates test-programs testdeps tex tex4ht texmacs tga themes theora thesaurus thin-splines threads threadsafe thumbnail tidy tiff timezone timidity tinfo tk tls tokenizer toolbar tools toporouter track-src-odirect tracker transcode truetype truetype-debugger twolame type3 udev udis86 udisks uiuc umfpack unicode unit-mm unlock-notify unsupported unzip upnp upnp-av upower usb utempter utils v4l v4l2 vaapi vala valgrind vcd vcdx vdpau vdr verse vga video videos vim vim-pager vim-syntax virtuoso visibility vix vlc vlm vmware vmware-tools vmware_guest_windows vnc vorbis vpx vrml vst vte wad watchdog wav waveform wavpack weather-metar weather-xoap webcam webdav webdav-neon webdav-serf webgl webkit webkit2 webm webp webphoto wifi wiki win32 win64 windeco wma wma-fixed wmf word-perfect wordperfect wpd wpg wxuniversal wxwidgets x264 xalan xanim xatrix xattr xbase xcb xcomposite xerces-c xetex xext xft xhtml xindy xine xinerama xls xml xmlpatterns xmlreader xmlrpc xmlwriter xmp xorg xosd xpm xps xrandr xrender xscreensaver xsl xslt xulrunner xv xvfb xvid xvmc yahoo yuv4mpeg zip zlib zvbi" ABI_X86="32 64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="*" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="nss" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer nlpsolver pdfimport scripting-beanshell scripting-javascript wiki-publisher" LINGUAS="ru en" NETBEANS_MODULES="xml soa gsf cnd groovy identity profiler apisupport harness ide java nb websvccommon j2ee mobility php visualweb webcommon dlight enterprise ergonomics ruby javacard javafx" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" SANE_BACKENDS="*" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

media-gfx/asymptote-2.13 was built with the following:
USE="X boehm-gc (consolekit) doc emacs examples fftw gsl imagemagick latex (multilib) (policykit) python vim-syntax -sigsegv"
Comment 1 MaratIK 2013-02-21 14:49:39 UTC
Created attachment 339580 [details]
build.log
Comment 2 Andrey Grozin gentoo-dev 2013-02-22 09:19:26 UTC
I cannot reproduce this: asymptote-2.21 with these USE flags compiles normally, including documentation. I suppose your problem is caused by some earlier error. Please post the full build log.
By the way, do you use USE=boehm-gc (which is on by default)? Some examples in the documentation may require a *huge* amount of memory without garbage collection; maybe, asy has run out of memory, thus producing an incomplete .tex file.
Comment 3 MaratIK 2013-02-22 09:38:51 UTC
Build.log was attached earlier.

That my USE-flags:

$ emerge -pqv =media-gfx/asymptote-2.21
[ebuild     U ] media-gfx/asymptote-2.21 [2.13] USE="X boehm-gc doc emacs examples fftw gsl imagemagick latex offscreen%* opengl%* python svg%* vim-syntax -sigsegv"
Comment 4 MaratIK 2013-02-22 09:49:50 UTC
Created attachment 339678 [details]
build.log

Attached build.log with run emerge in locale "en_US.utf8" (the old was in "ru_RU.utf8")
Comment 5 MaratIK 2013-02-22 09:57:04 UTC
MAKEOPTS="-j1" does not help. Error is the same.
Comment 6 Andrey Grozin gentoo-dev 2013-02-22 10:11:52 UTC
I cannot understand what's going on with your build. In my log file, I see

make -j2 -j1 asymptote.pdf 
../asy -dir ../base -config "" -render=0 -f pdf -noprc errorbars.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc shadedtiling.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc lineargraph.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc secondaryaxis.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc triangulate.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc flow.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc diatom.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc loggraph.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc axis3.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc westnile.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc bigdiagonal.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc generalaxis3.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc cylinderskeleton.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc CDlabel.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc superpath.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc subpictures.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc binarytreetest.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc grid3xyz.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc graphmarkers.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc planes.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc Hobbycontrol.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc logimage.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc saddle.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc square.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc elliptic.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc labelsquare.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc markers2.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc brokenaxis.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc dots.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc makepen.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc parametricgraph.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc image.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc eetomumu.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc colons.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc join3.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc logticks.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc mexicanhat.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc irregularcontour.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc linetype.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc colors.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc legend.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc beziercurve.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc hatch.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc leastsquares.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc onecontour.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc Hobbydir.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc tile.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc cube.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc Bode.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc flowchartdemo.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc knots.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc join.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc lineargraph0.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc filegraph.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc histogram.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc icon.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc bezier2.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc multicontour.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc penimage.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc generalaxis.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc vectorfield.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc diagonal.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc loggrid.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc markers1.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc datagraph.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc CAD1.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc penfunctionimage.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc exp.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc GaussianSurface.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc scaledgraph.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc unitcircle3.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc HermiteSpline.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc quartercircle.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc logo.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc helix.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc slopefield1.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc log2graph.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc monthaxis.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc imagecontour.asy
../asy -dir ../base -config "" -render=0 -f pdf -noprc bezier.asy
rm -f latexusage-*
rm -f latexusage.pre
rm -f latexusage.aux
latex latexusage
This is pdfTeX, Version 3.1415926-2.4-1.40.13 (TeX Live 2012)
 restricted \write18 enabled.
entering extended mode
(./latexusage.tex
LaTeX2e <2011/06/27>
Babel <v3.8m> and hyphenation patterns for english, dumylang, nohyphenation, bu
lgarian, russian, ukrainian, loaded.
(/usr/share/texmf-dist/tex/latex/base/article.cls
Document Class: article 2007/10/19 v1.4h Standard LaTeX document class

and so on. In your log, all ../asy lines after diatom.asy are absent, latex is run right away. This cannot be right. But I don't know why make does not do a lot of work it should do (and does for me).
Comment 7 MaratIK 2013-02-22 10:19:45 UTC
Found that "asy" generates incorrect *.tex file

diatom_.tex has such rows:
\ASYalign(298.812097,202.629617)(0.000000,-0.281250){\vphantom{$10^4$}%}
\definecolor{ASYcolor}{gray}{0.000000}\color{ASYcolor}

But '%' is special symbol in latex, which means the comment till the end of line, so closing curly brace ignores '}' by latex.

Adding backslash '\' before '%' fix that error. And tex-file became correct.
\ASYalign(298.812097,202.629617)(0.000000,-0.281250){\vphantom{$10^4$}\%}
\definecolor{ASYcolor}{gray}{0.000000}\color{ASYcolor}

Andrey Grozin, can you find that that row in your doc/diatom_.tex and post here?
In my file that string positioned at row 136.
Comment 8 Andrey Grozin gentoo-dev 2013-02-22 10:36:41 UTC
(In reply to comment #7)
> Found that "asy" generates incorrect *.tex file
> 
> diatom_.tex has such rows:
> \ASYalign(298.812097,202.629617)(0.000000,-0.281250){\vphantom{$10^4$}%}
> \definecolor{ASYcolor}{gray}{0.000000}\color{ASYcolor}
No, I have no such line. The most similar one is line 124:
\ASYalign(298.840240,16.545565)(-0.500000,-1.000000){\vphantom{$10^4$}$10$}
\definecolor{ASYcolor}{gray}{0.000000}\color{ASYcolor}

When everything's normal, one does not see these foo_.tex files at all: they are used to produce foo.pdf and removed at once. I had to add -k to the asy call to keep them.
Comment 9 MaratIK 2013-02-22 11:06:36 UTC
Created bugreport at project bugtracker

https://sourceforge.net/tracker/?func=detail&atid=685683&aid=3605634&group_id=120000
Comment 10 MaratIK 2013-02-22 11:09:16 UTC
Andrey Grozin, can you attach the correct diatom_.tex, I'll try to inspect the sources for error, that caused bug on my machine.
Comment 11 Andrey Grozin gentoo-dev 2013-02-22 15:17:45 UTC
Created attachment 339712 [details]
diatom_.tex on my computer

It definitely contains no %}, and latex does not complain.
Comment 12 Justin Lecher gentoo-dev 2015-11-11 10:04:58 UTC
commit d4b53ef9737f262afefe09ec5539e35c2c425d43
Author: Justin Lecher <jlec@gentoo.org>
Date:   Wed Nov 11 10:59:12 2015 +0100
    
    media-gfx/asymptote: Drop old
    
    obsolets
    
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=314265
    
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=458598
    
    Package-Manager: portage-2.2.23
    Signed-off-by: Justin Lecher <jlec@gentoo.org>
    
    https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d4b53ef9737f262afefe09ec5539e35c2c425d43