Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 458568 - sys-fs/udisks-2 fails to mount flash drive when ACL isn't supported in kernel
Summary: sys-fs/udisks-2 fails to mount flash drive when ACL isn't supported in kernel
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Freedesktop bugs
URL:
Whiteboard:
Keywords: PATCH
: 462492 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-02-21 11:28 UTC by Ostashevskyi Viktor
Modified: 2013-04-01 18:00 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Fallback to /media if ACL is not supported (acl.patch,1.27 KB, patch)
2013-02-21 11:29 UTC, Ostashevskyi Viktor
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ostashevskyi Viktor 2013-02-21 11:28:14 UTC
After upgrade to KDE 4.10 which now uses udisks2 in Gentoo I'm not able to mount any of flash drives.

Short investigation shows that problem lays in udisks2 hard dependency over ACL support. While it is absolutely OK to use it when it present, it would be nice to have some kind of fallback for systems (or filesystems) where ACLs are not supported at all.

It seems that this could be easily fixed by attached patch.

Reproducible: Always

Steps to Reproduce:
1. Install udisks2
2. Insert flash driver / CD/DVD 
3. Try: udisksctl -b /dev/sr0 mount
Actual Results:  
Adding read ACL for uid 1000 to `/run/media/ostash' failed: Operation not supported

Expected Results:  
Get media mounted

Upstream bug:

https://bugs.freedesktop.org/show_bug.cgi?id=61162
Comment 1 Ostashevskyi Viktor 2013-02-21 11:29:38 UTC
Created attachment 339550 [details, diff]
Fallback to /media if ACL is not supported
Comment 2 Rafał Mużyło 2013-02-21 13:17:23 UTC
According to a forum post, all that's needed to fix such problem is CONFIG_TMPFS_POSIX_ACL=y.
Comment 3 Ostashevskyi Viktor 2013-02-21 13:23:05 UTC
Why I need to rebuild kernel if userspace tool doesn't behave correctly?

Anyway, it could happen that in setup /run isn't on tmpfs.
Comment 4 Gilles Dartiguelongue gentoo-dev 2013-02-21 16:26:11 UTC
1. this is an explicit choice made by usptream and after quite a few discussions
2. the ebuild explicitly checks and warns about it (in two different cases)
     CONFIG_CHECK+=" ~TMPFS_POSIX_ACL" bug #412377

There is imho nothing to "fix" here as this will be a patch to carry forever and I do not think ACL is a crazy requirement (like kerberos would be for example) for modern desktop (even with a single user).
Comment 5 Samuli Suominen (RETIRED) gentoo-dev 2013-03-19 19:39:36 UTC
(In reply to comment #4)
> 1. this is an explicit choice made by usptream and after quite a few
> discussions
> 2. the ebuild explicitly checks and warns about it (in two different cases)
>      CONFIG_CHECK+=" ~TMPFS_POSIX_ACL" bug #412377
> 
> There is imho nothing to "fix" here as this will be a patch to carry forever
> and I do not think ACL is a crazy requirement (like kerberos would be for
> example) for modern desktop (even with a single user).

I agree, and I doubt upstream will take the patch:

https://bugs.freedesktop.org/show_bug.cgi?id=48842#c1

So we shouldn't be carrying it either. And since the ebuild has the kernel option check, the package is actually already OK in portage.

If upstream takes the patch and plans on supporting non-ACL kernels, please reopen this bug!
Comment 6 Rafał Mużyło 2013-03-20 16:06:55 UTC
*** Bug 462492 has been marked as a duplicate of this bug. ***