Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 458514 - media-tv/xbmc USE=airplay should depend on net-dns/avahi[dbus] and media-libs/libshairport
Summary: media-tv/xbmc USE=airplay should depend on net-dns/avahi[dbus] and media-libs...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Xbox herd
URL:
Whiteboard:
Keywords: PATCH
Depends on: 386909
Blocks:
  Show dependency tree
 
Reported: 2013-02-21 00:18 UTC by Anthony Ryan
Modified: 2014-05-21 02:16 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
proposed 12.0 ebuild changes (airplay.patch,877 bytes, patch)
2013-02-21 00:19 UTC, Anthony Ryan
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Anthony Ryan 2013-02-21 00:18:52 UTC
XBMC has two explicit dependencies to make airplay functionality actually work.

The first is that avahi must be enabled, such that the system can announce the existence of the service.

Additionally, if avahi was compiled without dbus, airplay will be unable to register itself as a service with avahi-daemon, and airplay will again fail to work as expected.

I've confirmed this affects 12.0, have not tested older versions properly, I suspect this also holds true for the 9999 ebuild.

Reproducible: Always
Comment 1 Anthony Ryan 2013-02-21 00:19:37 UTC
Created attachment 339524 [details, diff]
proposed 12.0 ebuild changes
Comment 2 Anthony Ryan 2013-02-21 00:24:40 UTC
Note: This does not address the absence of libshairport (bug 386909) which I intentionally excluded given it has it's own ticket.
Comment 3 hal 2013-02-21 12:31:28 UTC
I just wanted to emphasize: Although airplay can live without airtunes (libshairport), it will not play back pure audio streams in that case. It will stream videos with audio, pictures, but not pure audio data.

The other way 'round, airtunes will not do anything with the absence of airplay.

So in order to get the full enjoyment of streaming all kinds of media we will need both airplay and airtunes.

This might seem to be strange because airplay is the successor of airtunes and is able to stream the full spectrum of available media on Apple devices. But I **assume** (I really don't know tbh) airplay is based on an enhanced airtunes codebase, so again under the hood we might have both airplay and airtunes again.

http://en.wikipedia.org/wiki/AirPlay

Again I would like to point to bug https://bugs.gentoo.org/show_bug.cgi?id=386909.
I use this ebuild since I created it in 2011 and the overall stability grows with each update of xbmc.
Comment 4 hal 2013-05-04 11:06:06 UTC
Up stream has merged the unified airplay branch into master. Since then my former ebuild is obsolete but an ebuild for libshairplay is available here:

https://bugs.gentoo.org/show_bug.cgi?id=458734
Comment 5 Anthony Ryan 2014-05-21 02:16:10 UTC
https://bugs.gentoo.org/show_bug.cgi?id=468558 can be considered a replacement for this issue.