Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 458404 - dev-libs/boost-1.52.0-r5[-threads] fails to build
Summary: dev-libs/boost-1.52.0-r5[-threads] fails to build
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Julian Ospald
URL: https://svn.boost.org/trac/boost/tick...
Whiteboard:
Keywords: STABLE
Depends on: 525286
Blocks:
  Show dependency tree
 
Reported: 2013-02-20 06:05 UTC by Thomas Beutin
Modified: 2015-02-18 18:53 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
/var/tmp/portage/dev-libs/boost-1.52.0-r5/temp/build.log (build.log,5.06 KB, text/plain)
2013-02-20 15:07 UTC, Thomas Beutin
Details
/media/GFZ650GB/gentoo/tmp/portage/dev-libs/boost-1.52.0-r6/temp/build.log (build.log,4.59 KB, text/plain)
2013-03-03 15:52 UTC, Thomas Beutin
Details
boost-1.52.0-non-threaded.patch for USE="-threads" (boost-1.52.0-non-threaded.patch,2.04 KB, patch)
2013-12-07 16:14 UTC, Thomas Beutin
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Beutin 2013-02-20 06:05:43 UTC
dev-libs/boost-1.52.0-r5 fails to compile

Reproducible: Always

Steps to Reproduce:
1. emerge -1DNu '=dev-libs/boost-1.52.0-r5'
Actual Results:  
 * python3.2: running building
b2 gentoorelease -j3 -q -d+2 --user-config=/media/GFZ650GB/gentoo/tmp/portage/dev-libs/boost-1.52.0-r5/work/boost_1_52_0/user-config.jam -sICU_PATH=/usr --without-mpi pch=off --boost-build=/u
sr/share/boost-build --prefix="/media/GFZ650GB/gentoo/tmp/portage/dev-libs/boost-1.52.0-r5/image/usr" --layout=system threading=single link=shared --without-context --python-buildid=3.2

Building the Boost C++ Libraries.


Performing configuration checks

    - has_icu builds           : yes
warning: Graph library does not contain MPI-based parallel components.
note: to enable them, add "using mpi ;" to your user-config.jam
    - iconv (libc)             : yes
    - icu                      : yes
    - gcc visibility           : yes
    - long double support      : yes
/usr/share/boost-build/build/virtual-target.jam:1079: in virtual-target.register-actual-name from module virtual-target
error: Duplicate name of actual target: <pstage/lib>libboost_system.so.1.52.0
error: previous virtual target { common%common.copy-libboost_system.so.1.52.0.SHARED_LIB { gcc%gcc.link.dll-libboost_system.so.1.52.0.SHARED_LIB { gcc%gcc.compile.c++-error_code.o.OBJ { error_code.cpp.CPP } } } }
error: created from ./stage-proper
error: another virtual target { common%common.copy-libboost_system.so.1.52.0.SHARED_LIB { gcc%gcc.link.dll-libboost_system.so.1.52.0.SHARED_LIB { gcc%gcc.compile.c++-error_code.o.OBJ { error_code.cpp.CPP } } } }
error: created from ./stage-proper
error: added properties: <threading>multi
error: removed properties: <threading>single
/usr/share/boost-build/build/virtual-target.jam:490: in actualize-no-scanner from module object(file-target)@3784
/usr/share/boost-build/build/virtual-target.jam:135: in object(file-target)@3784.actualize from module object(file-target)@3784
/usr/share/boost-build/build-system.jam:749: in load from module build-system
/usr/share/boost-build/kernel/modules.jam:283: in import from module modules
/usr/share/boost-build/kernel/bootstrap.jam:142: in boost-build from module
/media/GFZ650GB/gentoo/tmp/portage/dev-libs/boost-1.52.0-r5/work/boost_1_52_0/boost-build.jam:17: in module scope from module


Expected Results:  
clean compile & installation

phantom ~ # emerge --info '=dev-libs/boost-1.52.0-r5'
Portage 2.1.11.50 (default/linux/amd64/13.0/desktop/gnome, gcc-4.6.3, glibc-2.15-r3, 3.6.11-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.6.11-gentoo-x86_64-Intel-R-_Core-TM-_i5-2520M_CPU_@_2.50GHz-with-gentoo-2.1
KiB Mem:     8133596 total,    639328 free
KiB Swap:    8388604 total,   8388604 free
Timestamp of tree: Tue, 19 Feb 2013 20:00:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4, 4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo desktop-effects sunrise java-overlay science seden x-portage
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=corei7-avx -fomit-frame-pointer -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/fax /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /var/lib/hsqldb /var/spool/fax/etc"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=corei7-avx -fomit-frame-pointer -O2 -pipe"
DISTDIR="/media/GFZ650GB/gentoo/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/media/GFZ650GB/gentoo/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/desktop-effects /var/lib/layman/sunrise /var/lib/layman/java-overlay /var/lib/layman/science /var/lib/layman/seden /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X X509 a52 aac aalib accounting acl acpi adns aim alsa amd64 ansi ao apache2 apng ass audiofile automount avahi avx bacula-console bash-completion bcmath berkdb bidi bind-mysql bittorrent blas bluetooth bonobo bzip2 cairo calendar caps ccache cdb cdda cddb cdparanoia cdr cgi chipcard chroot command-args consolekit cpudetection cpulimit cracklib cramfs crypt cscope css csv ctype cups curl curlwrappers customlog cvsgraph cxx cyrus dba dbi dbm dbus dbx devmap dga dhcp dirac directfb djvu dlopen dnsdb dri dts dv dvb dvd dvdr ecc egl encode exif expat fam fastcgi ffmpeg fits flac flash flatfile fontconfig fpx ftp gallium gd gdal gdbm gdu geoip geos gif gimp ginac glib glut gmp gnome gnome-keyring gnuplot gphoto2 graphviz gs gssapi gstreamer gtk gtk3 gudev gzip hal hardened hardenedphp hddtemp hdf5 hpn http hunspell hwdb iconv icq icu idea idled idn imagemagick imap imlib imlib2 inifile innodb ios ipalias ipc ipod ipv6 jabber jack java javascript jbig jingle jpeg jpeg2k kdrive kerberos keymap kpathsea lame lapack latex lcms ldap less libass libnotify libsamplerate libv4l libv4l2 libwww lm_sensors lmtp logrotate logwatch lua lzma lzo mad matroska mbox mcal memlimit mgetty mhash midi milter mime mimencode ming mmap mms mmx mng mp3 mp4 mpeg mplayer mpm-prefork mppe-mppc msn mtp multilib musepack musicbrainz mysql mysqli nagios-dns nagios-game nagios-ntp nagios-ping nagios-ssh nautilus ncurses netboot netcdf network networkmanager nfs nis nls nntp nptl nptlonly nsplugin oav ocatve octave odbc offensive ogg openal openexr opengl openmp openssh openssl osc oscar pam pam_chroot pam_timestamp parse-clocks pcf pcntl pcre pda pdf pdfkit pdflib perl php pic plotutils png policykit posix postfix postgis postgres postscript ppds procmail ps pulseaudio pwdb python qdbm qt4 quotas radius raw rdesktop readline recode reiserfs rrdtool rss samba sample sasl scanner schroedinger screen sendfile sensord session sftp sftplogging shaper shared sharedext shorten sieve simplexml slang slp smartcard smime smp sms smtp sna sndfile snmp snortsam soap sockets socks5 sound sox spamassassin spatialite speex spell spl sql sqlite sqlite3 sse sse2 sse4 sse4_1 ssl ssse3 stream subversion svg sysfs syslog sysvipc szip taglib tcpd theora tidy tiff timidity tokenizer tools transparent-proxy truetype truetype-fonts type1-fonts udev unicode upnp upnp-av usb userlocales utf8 uuid v4l vaapi vcd vhosts vim-syntax virtual-users virus-scan vnc vorbis vpx wddx weather webdav webm webp wifi withsamplescripts wmf x264 xattr xcb xcomposite xface xfs xft xinerama xinetd xml xml2 xmlrpc xmpp xorg xosd xpdf-headers xpm xrandr xsl xslt xv xvfb xvid yahoo yaz zlib zvbi" ABI_X86="64" APACHE2_MODULES="access auth auth_basic authn_dbm dbd ident imagemap authn_dbd authn_file authn_default authz_groupfile authn_alias authn_anon authz_dbm authz_owner authz_default authz_user auth_digest authz_host alias file_cache echo charset_lite cache disk_cache mem_cache ext_filter case_filter case-filter-in deflate filter mime_magic cern_meta proxy_ajp proxy_balancer expires headers usertrack proxy proxy_connect proxy_ftp proxy_http info include cgi cgid dav dav_lock dav_fs vhost_alias speling rewrite log_config logio env setenvif mime status substitute autoindex asis negotiation dir imap actions userdir so unique_id" APACHE2_MPMS="prefork" CURL_SSL="gnutls" ELIBC="glibc" FFTOOLS="cws2fws qt-faststart" INPUT_DEVICES="keyboard mouse evdev wacom synaptics" KERNEL="linux" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer nlpsolver pdfimport wiki-publisher" LINGUAS="en_GB en en_US de_DE de" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18 ruby19" SANE_BACKENDS="net hp" USERLAND="GNU" VIDEO_CARDS="vga intel fbdev"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Jeroen Roovers gentoo-dev 2013-02-20 14:30:47 UTC
Please attach the entire build log to this bug report.
Comment 2 Thomas Beutin 2013-02-20 15:07:45 UTC
Created attachment 339504 [details]
/var/tmp/portage/dev-libs/boost-1.52.0-r5/temp/build.log

build log as requesting in #1
Comment 3 Thomas Beutin 2013-02-20 15:12:07 UTC
actually the build.log is from another system (with all of the portage stuff in standard locations) but the error is the same.
the interesting part of the build.log was already given in the bug description.
Comment 4 Diego Elio Pettenò (RETIRED) gentoo-dev 2013-03-03 11:03:07 UTC
This might be fixed with boost-1.52.0-r6 — please try that and report, thanks!
Comment 5 Thomas Beutin 2013-03-03 15:51:43 UTC
(In reply to comment #4)
> This might be fixed with boost-1.52.0-r6 — please try that and report,
> thanks!

The problem still exists. I'll attach a build.log.
Comment 6 Thomas Beutin 2013-03-03 15:52:51 UTC
Created attachment 340868 [details]
/media/GFZ650GB/gentoo/tmp/portage/dev-libs/boost-1.52.0-r6/temp/build.log
Comment 7 Diego Elio Pettenò (RETIRED) gentoo-dev 2013-03-04 16:13:44 UTC
Okay, reproduced :)
Comment 8 Thomas Beutin 2013-04-07 17:22:33 UTC
the problem persists on dev-libs/boost-1.52.0-r6
Comment 9 Thomas Beutin 2013-04-07 17:24:03 UTC
(In reply to comment #8)
> the problem persists on dev-libs/boost-1.52.0-r6

sorry for re-reporting - i'm too confused this weekend....
Comment 10 Tiziano Müller gentoo-dev 2013-04-09 15:43:47 UTC
Why do we want a 'threads' USE flag for boost again at all?
Comment 11 Sergey Popov gentoo-dev 2013-08-27 09:49:36 UTC
Problem still exists in 1.54.0? It seems, that suggested allocator variants does not work in shared build in non-threading implementation? Cause we do not do ONLY static boost builds, maybe we should just drop 'threads' USE-flag?
Comment 12 Sergey Popov gentoo-dev 2013-08-27 09:50:07 UTC
Sorry, just to clarify, there is no '?' in first sentence in previous comment
Comment 13 Julian Ospald 2013-09-25 13:23:31 UTC
same here with 1.53.0
Comment 14 Thomas Beutin 2013-12-07 16:14:08 UTC
Created attachment 364820 [details, diff]
boost-1.52.0-non-threaded.patch for USE="-threads"

Using this patch i can upgrade my system from dev-libs/boost-1.49.0-r2 to dev-libs/boost-1.52.0-r using the following patch for the ebuild:

# diff -ubB /usr/portage/dev-libs/boost/boost-1.52.0-r6.ebuild /usr/local/portage/dev-libs/boost/boost-1.52.0-r7.ebuild 
--- /usr/portage/dev-libs/boost/boost-1.52.0-r6.ebuild	2013-09-26 19:31:09.000000000 +0200
+++ /usr/local/portage/dev-libs/boost/boost-1.52.0-r7.ebuild	2013-12-07 16:33:17.044262182 +0100
@@ -71,6 +71,7 @@
 		"${FILESDIR}/${PN}-1.48.0-disable_icu_rpath.patch" \
 		"${FILESDIR}/remove-toolset-1.48.0.patch" \
 		"${FILESDIR}/${PN}-1.52.0-tuple.patch" \
+		"${FILESDIR}/${PN}-1.52.0-non-threaded.patch" \
 		"${FILESDIR}/${P}-locale-utf.patch"
 
 	# Avoid a patch for now

An "emerge @preserved-rebuild" runs fine afterwards, and any other package which depends on dev-libs/boost on my system compiles fine as well.

But i've no clue if this works on a USE="threads" system...
Comment 15 Andrew Savchenko gentoo-dev 2013-12-30 19:58:18 UTC
Patch works fine here with boost-1.53.0-r1.
Comment 16 SpanKY gentoo-dev 2014-01-02 10:54:49 UTC
why is this marked as a blocker of 467256 ?  the OP reported seeing this against glibc-2.15 which means stabilizing 2.16 is not a regression.
Comment 17 Thomas Beutin 2014-01-02 11:14:13 UTC
(In reply to SpanKY from comment #16)
> why is this marked as a blocker of 467256 ?  the OP reported seeing this
> against glibc-2.15 which means stabilizing 2.16 is not a regression.

kodama ~ # eix ^glibc$
[U] sys-libs/glibc
     Available versions:  (2.2) ~2.9_p20081201-r3^s 2.10.1-r1^s 2.11.3^s ~2.12.1-r3^s 2.12.2^s ~2.13-r2^s 2.13-r4^s ~2.14^s ~2.14.1-r2^s 2.14.1-r3^s ~2.15-r1^s 2.15-r2^s 2.15-r3^s 2.16.0^s ~2.17^s **2.18^s **9999^s
       {debug gd hardened multilib nscd profile selinux suid systemtap vanilla CROSSCOMPILE_OPTS="headers-only"}
     Installed versions:  2.15-r3(2.2)^s(02:12:18 11/15/13)(gd multilib -debug -hardened -profile -selinux -vanilla CROSSCOMPILE_OPTS="-headers-only")
     Homepage:            http://www.gnu.org/software/libc/libc.html
     Description:         GNU libc6 (also called glibc2) C library

kodama ~ # emerge -pv1DNu sys-libs/glibc

These are the packages that would be merged, in order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 kB

WARNING: One or more updates have been skipped due to a dependency conflict:

sys-libs/glibc:2.2

  (sys-libs/glibc-2.16.0::gentoo, ebuild scheduled for merge) conflicts with
    <sys-libs/glibc-2.16 required by (dev-libs/boost-1.49.0-r2::gentoo, installed)


 * IMPORTANT: 10 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

As long as dev-libs/boost is not fixed on a non-threaded system i cannot install sys-libs/glibc-2.16. IMHO this is a blocker.
(And what is "OP"?)
Comment 18 Julian Ospald 2014-01-02 11:22:45 UTC
The fix is accepted upstream, what are we waiting for?
Comment 19 Fedja Beader 2014-07-29 10:23:47 UTC
(In reply to Julian Ospald (hasufell) from comment #18)
> The fix is accepted upstream, what are we waiting for?

For the sky to fall, but ofcourse.

update it already -.-
Comment 20 Julian Ospald 2014-07-29 13:34:49 UTC
+*boost-1.52.0-r7 (29 Jul 2014)
+
+  29 Jul 2014; Julian Ospald <hasufell@gentoo.org> +boost-1.52.0-r7.ebuild,
+  boost-1.53.0-r1.ebuild, boost-1.54.0-r1.ebuild, boost-1.55.0-r1.ebuild,
+  +files/boost-1.52.0-threads.patch:
+  fix build with USE=-threads wrt #458404
Comment 21 Sergey Popov gentoo-dev 2015-02-18 18:53:18 UTC
All arches have at least boost-1.52.0-r7 for now in stable, thus - this issue is fixed